Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Black Screen on Laptop


i´ve got an issue since i tried to install Adrenaline 18.5.1 and 18.6.1.

As soon as the driver gets installed my Laptop Screen goes black and doesn´t show anything.

Clean installations didn´t work either.

Thankfully i can connect via HDMI to another screen and this works.

When i go to the Windows settings my main screen isn´t shown at all. Only the HDMI connected Screen is shown as possible Display.

When i restart the Laptop the screen shows Bios and Windows loading screen as usual as soon as the Drivers kick in it goes black again.

Has anyone a similiar issue or can give me a hint what to do to get around?

Im currently running Dual Crossfire HD8970M on Adrenaline 18.3.3. but this gives me some problems with games that require an up to date driver.......(crash flickering etc)

Thank you.

1 Solution
Adept II

Finally the problem is fixed

And No it's not the display port to hdmi trick which fix this annoying problem as the previous comment said


AMD finally fixed this bug in the latest update 19.6.2 so you can just install it normally and your display will work without any problem 


Also I don't think that they listened to us but it is just fixed by mistake from their side 


Really this was very bad and annoying problem without any response for one year from amd so I won't even thank them for the fix 

Here is pic from my laptop

My alienware 18 is with Dual AMD R9 M290x crossfire 


View solution in original post

65 Replies

Required Informations from the attached DX Diag: ( Old Diag with just the Hardware Informations)

System Model: P370SM                   
BIOS: BIOS Date: 06/03/13 09:01:40 Ver: 04.06.05
Processor: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz (8 CPUs), ~2.4GHz
Memory: 16384MB RAM
Available OS Memory: 16338MB RAM

Page File: 3152MB used, 29570MB available

Display Devices


          Card name: AMD Radeon(TM) HD8970M

       Manufacturer: Advanced Micro Devices, Inc.

          Chip type: AMD Radeon Graphics Processor (0x6801)

           DAC type: Internal DAC(400MHz)

        Device Type: Full Device

         Device Key: Enum\PCI\VEN_1002&DEV_6801&SUBSYS_03761558&REV_00

     Display Memory: 16317 MB

   Dedicated Memory: 8148 MB

      Shared Memory: 8169 MB

       Current Mode: 1920 x 1080 (32 bit) (60Hz)

       Monitor Name: Generic PnP Monitor

      Monitor Model: unknown

         Monitor Id: CMO1720

        Native Mode: 1920 x 1080(p) (60.010Hz)

        Output Type: Internal

All other drivers and Software on latest Version including Windows 10 64 Bit Home


Did you install the Intel graphics driver (from Intel support) BEFORE you tried to install the AMD graphics driver? Read > Laptop graphics update...How to

Did you perform a clean install? Clean Install AMD Graphics Drivers

Did you disconnect from the internet before installing the drivers? DDU has new instructions..make sure you have the latest version


Yhea done that a couple of times.

Step one doesn´t work btw shows me no integrated graphics.

Attached the detailed Intel System Report

In attachement you will find screenshots showing the current settings and that the HDMI connection is detected as primary. (18.6.1 installed)Display.jpgWinScreen.jpgGlobal Settings.jpg


Adrenalin 18.4.1 is also not working btw..... So the last working Version is 18.3.3


i'm having the same problem with alienware 18 with the same amd R9 M290x crossfire ..

but u can use drivers up to version 18.3.4 without problems

any update after that will cause this problem and u can use only the screen attached with hdmi and every thing works with it

so the problem that all drivers after 18.3.4 wont recognize internal laptop screen only but any other attached screen will work without any problem

hope to find a fix for that and i already sent alot of complaints but no reply .. this is very bad that we can't use any updated graphics drivers with internal screen

Add me to the list.  Alienware 18, with 2 R9 m290x in Crossfire.  Black screen occurs during the driver update & it just doesn't seem to finish.  Usually I get the hardware removed / hardware installed sounds twice.  Once for each card.  With the current drivers, it seems to disconnect once & then nothing.  I managed to get it to restart and go into safe mode where I could uninstall the drivers & get back in.

It doesn't help that this seems to break System Restore and it always fails with this bug, as well.

Interestingly, after the next reboot, when I could get into AMD Settings again, it said I had the 18.9 driver installed.  I reinstalled 18.1.1 anyway.  Looks like I might download 18.3.4, then.

At least they fixed the 'won't shutdown with crossfire enabled' bug last year.  That only took, what, 2 years to get sorted?

the problem that the driver doesn't identify our internal display but can work perfect with any other connected display through hdmi or display port..

it just works as if there is no internal laptop display..

u can connect the lap to any display during driver installation and u will see that it will continue driver installation on the second screen only and the internal one will turn into black ...

it's really very very bad as the new drivers works great with games through hdmi but can't use it as daily driver because i want to use my internal display for daily use

and for sure u should download 18.3.4 driver as it's the latest one that works great with all latest gems till now without any problems in internal display

I hadn't even thought of plugging it into an external display until I read this!  Testing for the shutdown bug was much less painful!

Go ahead and add me to this list as well.

Alienware 18, Windows 10, i7-4940MX, AMD R9 M290X crossfired.

Yes, I've taken every single troubleshooting step over two dozen times to no avail.

What's worse is that AMD has provided absolutely no reply besides generic troubleshooting steps from 2014.

At least stop pushing incompatible drivers onto your users.

You might want to read through the following.. > Asus laptop black screen


My backlight is on fine, I can see the leakage, and it displays perfectly if I plug in an external monitor, (the only one I have handy is the 55" plasma TV), so I can check the Device Manager.  There is no internal display listed there, only the external TV listed.

So it seems that the driver is just refusing to recognise the laptop display.

Read all that.  None of it helps.

Journeyman III

I am having the same issue.

Alienware M17X, Core i7-4910MQ. 32GB memory, Win10-1803, dual AM Radeon 8970

After installing any driver beyond 18.5.1 and my laptop screen will not be activated, only see screen through HDMI external screen, which becomes my primarey screen with no other screen available.

Very annoying…

Edit: When booting I get the Alienware logo on the laptopscreen, and the spinning dots, then the screen goes blank and the windows 10 logon screen appreas on the HDMI monitor, and nothing ever happens on the laptopscreen.

Booting onto safe mode uses the laptop screen.

That's it!  The display works perfectly until the AMD driver is loaded.  BIOS runs the screen during the startup, and Safe Mode uses the default MS driver.

Adept I

I have the exact same issue, also on an Alienware 18 with 2 R9 M290x in crossfire (detected as HD8970M). Any workaround/fix?

Adept I

got the same issue with alienware 18 7970 crossfire anything after 18.3.4 goes black, and AMD is doing nothing about it what a waste 

I´ve again send an Email  to AMD including the link to this Thread. 

Hopefully they will do something this time.

In the meantime i´ve already built a new system without any AMD hardware in it.

It´s a pitty but this kind of problems really sets me up.

I've done the same exact thing, I reckon AMD might do something if we get enough traction going.

Journeyman III

Same Issue .. If I upgrade drivers past 18.3.4 The primary screen goes black.  It's hard to not get bitter when you have spent so many hours trying to solve a problem..    I also have issues Getting my HTC Vive to work correctly in the HDMI port.  Apparently the HDMI port does not communicate as expected.  I have purchased so many AMD Cards over the years it's kind of a let down.  I am finding more and more people are focusing on nvidia.  The last two Alienware notebooks I purchased for my kids I opted for nVidia instead of AMD due to this specific issue.  I had a choice when I purchased my 18 and went with AMD..  Looks like I might have made the wrong choice.  I don't think it is to much to ask to support a product that the customer spent so much money on.   It says a lot when you just outright break a system.  I have decided that if they can't fix my $5000 rig I will never trust them again! why would anyone.  nVidia may not have the slick driver install..  but at least they keep working.  I expected so much more..  and I have spent many years recommending them even when they have sent me refurbed cards on support issues that fixed one issue and broke another \:-| ..  yes I am bitter...  When I switch to the crappy intel card it works fine..  or if I install the 18.3.4 drivers..   You can't play any new games on the 18.3.4 drivers.. 

I probably would have spent the extra to get nVidia, but in my area it was only offered with AMD. 

Did you try the 'fix' from the posts from 2014? KMD_EnableBrightnessInterface ? 


I tried it, but it didn't work for me.

Adept II

i found a work around for this problem 

this isn't a fix to the problem but just a way to be able to use latest drivers on our lap with internal screen

You will need mini display port to hdmi adaptor and connect it from the mini dispaly port to the hdmi port of the laptop 

so the lap will use hdmi in function and you will find that u can use every thing as normal except u won't be able to use brightness control 

but at least u will be able to use the laptop with latest amd drivers on internal laptop screen

edit : even brightnes control works perfect with fn key 

Adept I

Well this one didn´t work either.

After nearly bricking my Clevo P370SM board i finaly managed to install an updated bios version. 

After this i also installed the newest AMD Driver from Febr.19.

Guess what?  Black Screen as soon as the Driver kicked in. Backlight still active screen is not recognized by system anymore....

Adept III

Today I tested 19.2.1 driver.  No change.  But I had a new idea.  Instead of using the 52" TV to uninstall the drivers, this time I fired up Teamviewer from my desktop & used remote access to get in.  Everything was visible there.  Rebooted as the last step of the install, same.  Computer Management says there is no monitor connected.

Used Teamviewer & uninstalled driver via Computer Management and the laptop screen came straight back up.

After another reboot, I got the message that AMD Radeon Settings could not open as no driver was installed, (as expected), but Computer Management & the installer for 18.3.4 claimed that 19.2.1 was still there.  Someone is clearly mistaken...  Reboot again, all ok.  Computer Management says my Generic PnP Monitor, (the laptop display), is back.  Well, yeah, I can see that!

Already sent a new email back to AMD via their AMD Issue Reporting Form page: AMD Issue Reporting Form 

this what I said above that the driver is working already without any problem but it can't identify our internal laptop monitor and u can see only one display connected when u connect it to hdmi or display port  ..

so the only fix for us now to use our laptop normally is to connect the dislaly port to our hdmi port then we can see everything working on the laptop screen as the laptop thinks that we connected it to external monitor.  this is the use of hdmi in function and u don't need to press any thing  .. you just need to connect the 2 ports and everything will work...


I might try that if I had a DP-HDMI cable, but I don't, so it is not a useful workaround for me.  I do not believe that having to buy an external video cable should be necessary for using the internal monitor on a laptop.  If this works for you, great!  But it is no good to me.  More data for the people who broke it to find the fix, though!

I would also argue that since the driver is causing Windows to remove the laptop display from the list of recognised devices, that it is not "working without any problem", as it is effectively breaking the display.

Adept I

I mean seriously a huge company like AMD with all engineers and techs cannot find a solution for such a problem, since many of us got laptops and can't change anything in it and probably wasted 1k$ or more and can't use it for gaming or else, what in the world we are going to do or who  we need to contact since AMD didn't reply or give us a real solution rather than connecting the laptop to an external screen.


Adept I

I really wanna know how this thread was marked as assumed answered, clearly the issue is still prominent.

Probably because it is answered as "The driver is borked, use the 18.3.4 driver, or an external monitor, & it's ok."

Does not fix the problem of getting reminded to update to the latest driver every month, which will then bork the internal display again, of course...  Or the original issue of it happening in the first place.

Adept I

Yup, add another sucker to the list, I've been struggling with this for years. 

Alienware 18.

Seeing that this is a real and not imaginary issue, it's total crap that AMD refuses to respond or fix the issue. I've created tickets in the past stating which was the last driver I could install and have the monitor detected. This should be plenty for them to isolate any code changes.

They are just lazy. They are waiting for us to die, or our computers to die so we just buy something else.

Product support is a thing of the distant past.


Adept I

BTW, considering this "fixed" is like "fixing" your broke down car by buying a tow truck and just hauling your broke car around with that tow truck. 

Not really a solution.

Adept I

Text from today....

Your service request SR# 8200861166 has been escalated to one of our
    experts who can better address your questions. We appreciate your
    patience, and thank you for your interest in AMD.

    Best Regards,

    AMD Global Customer Care.


Which page did you use to actually get a response from them?


Official AMD Support at Support Ticket Process | AMD

I also linked to this thread in the ticket so if you open a ticket you can refer to the thread and my ticket number so perhaps they take it serious


Thank you guys!! All of you! 

I've got this issue for a long time now and thought I was the only one. I even was running on 18.2.x, so i've got an upgrade to 18.3.4 now. If there is any update keep me/us posted!  

Thanks again!

Would be nice if you could also open a ticket referring to my number I posted above. 


I've created one referencing this thread but haven't got a response from AMD yet