cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Grandmaster
Grandmaster

Re: Black screen during amd driver install

I have written many times. Make sure to apply OCCT CPU-GPU-PSU tests one by one for 10 minutes. You shouldn't have problems with a 850W PSU and other hardwares. If there is a problem with the GPU, set the OC values to normal with WattMan.

0 Kudos
Esteemed Contributor III

Re: Black screen during amd driver install

You should mark your post as the correct answer. This helps others looking for answer to same issue.

Adept I
Adept I

Re: Black screen during amd driver install

I tested it for 20 min with the new driver no issues.. Guess just a bad driver was to blame.. For me work the 20.4.01 

Grandmaster
Grandmaster

Re: Black screen during amd driver install

I am very glad seriously that you have no problems. Be sure to spend time in a game that puts a full load on the GPU for 2-3 hours. Goodbye.

0 Kudos
Journeyman III
Journeyman III

Re: Black screen during amd driver install

For me newer driver dosent work sam thing stuck on black screen when i download and reset pc 

0 Kudos
Journeyman III
Journeyman III

Re: Black screen during amd driver install

 


@axonn wrote:

Hi guys, 

 

 

 

I just set up my brand new desktop pc - brand new meaning the parts have arrived today. Everything went smooth untill the driver install for the gpu - at 70-80% black screen and won't recover. 2 windows reinstalls, dunno how many DDU runs and not working... I don't know what to do.. Anyone who can help me?

 

PS : if I don't install the driver everything works fine - also the latest drivers I used - tryed with 20.2.2; 20.3.1; 19.10.1; 19.12.1; 19.7.1

 

PS2 : I would like to mention that after the black screen the system still runs - music is playing in the background

 

System spec :

 

Motherboard : Asus tuf gaming X570 

 

Processor : Ryzen 7 3700x

 

RAM : CORSAIR DDR4 3600Mhz

 

GPU : Sapphire nitro+ RX 5700xt 

 

Power supply : corsair 80+ gold 650w

 

 

 

Thanks in advance for the help


Have your problem fix? I have the same problem 

0 Kudos
Journeyman III
Journeyman III

Re: Black screen during amd driver install

I'm having the black screen issue as well with R9 200 series GPU. PC was working fine for years but recently started alerting that Rodeon Settings did not work. I believe the black screen started after a recent MS update. Anyway after reading the threads I've been trying to update the driver with Radeon™ Software Adrenalin 2020 Edition 20.11.2 as this one is MS certified. However I can't finish the install by the time I get yet another black screen. I tried installing in safe mode but that didn't work either. Any suggestions? 

0 Kudos
Journeyman III
Journeyman III

Re: Black screen during amd driver install

You need to break the bios setup, shut down your PC and remove all electric supplies, then remove the battery from the motherboard for 10 to 20 seconds > now reinsert the battery on the motherboard and start your pc and install ADM Card driver.

This will work.

FNS
0 Kudos
Journeyman III
Journeyman III

Re: Black screen during amd driver install

You need to break the bios setup, shut down your PC and remove all electric supplies, then remove the battery from the motherboard for 10 to 20 seconds > now reinsert the battery on the motherboard and start your pc and install ADM Card driver.

This will work..

FNS
0 Kudos
Journeyman III
Journeyman III

Re: Black screen during amd driver install

Hey I got the same problem : screen goes black after GPU driver is installed, reboots don't help.

My spec is  Ryzer 3 3100 | 5500XT 8GB XFX / Nitro | 16 GB RAM | 600W PSU bronze | WIN 10 pro 20H2

I am fighting with this issue for a whole week, every evening after work. Everything works fine until graphic driver is installed. Tried newest drivers  20.12.1 /20.11.2.... / 19.12.1 even enterprise editions, optional and recommended ones. With or without Adrenalin software. Using DDU or cleanup utility in safe mode, no difference, also with rest win installation every day!. Also tried prepared drivers without Adrenaline package etc. Tested on 1100W PSU and in another rig! with RX480 working fine, 5500XT gives the same black screens on another rig. Also updated Motherboard BIOS, tried other RAM and manually PCIE settings (thought maybe because its PCIe 3.0 max it may cause some problems but those settings seems to not have any impact on stability).

Very similar as this tread: https://community.amd.com/t5/drivers-software/solved-5600xt-adrenaline-driver-issue-windows-10-start...

So i returned the card( XFX 5500xt 8gb fans), and bought new one - Sapphire 5500XT 8gb Nitro... and issues are the same! My frustration reaches its limit i have no more time fighting this, but now I think maybe it is not entirely driver problem but maybe some software conflicts. Recently I have third card ordered - GTX 1660 super i liked radeon but have no more ideas what to try.

My last guess that came to me this morning is maybe the problem is related to the fact that those chipsets also support apu CPUs, maybe after driver installation video output goes thru HDMI/DVI ports on the motherboard or something i did not checked that, or maybe video device should be set in BIOS.... if i find some time ill try to check if there are settings about that in BIOS.... but if that is true why screen goes black only in windows so when the amd display driver is loaded... no more hope.

Hope GTX will work, really wanted this Radeon to fly :( that NItro card is so well made....

P.S. sorry for so many "maybe" ^^

0 Kudos