cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

oldgrantler
Journeyman III
Journeyman III

black screen at boot after driver installation RX 580

AMD Graphics Card
  PowerColor Red Dragon RX 580 8GB
  Same issue with MSI Radeon RX 580 Armor OC 8GB

Desktop or Laptop System
  Desktop

Operating System
   Windows 7 64bit SP1, all updates installed.

Driver version installed
 tried:
 win7-radeon-software-adrenalin-2020-edition-20.2.2-mar5.exe
 win7-radeon-software-adrenalin-2020-edition-20.9.1-sep29.exe
 win7-64bit-radeon-software-adrenalin-2019-edition-19.6.2-june24.exe

Display Devices
 BenQ GL2480
 DVI to DVI

Motherboard + Bios Revision
 Gigabyte 970A-DS3P Rev 2, Bios FD latest

CPU/APU
 AMD FX 6300 Hexa-Core Prozessor (3,5GHz, Socket AM3+ 14MB Cache, 95 Watt)

Power Supply Unit Make, Model & Wattage
 Corsair VS650 (Active PFC, 80 Plus White, 650W)

RAM
 16GB

Describe your issue:
After installation of the AMD Drivers during boot I can see for a moment the windows logo, then the screen goes black.
Sound comes on, the fans on the graphics card go silent, shortly after that the monitor reports that the signal is lost.
Checking as far as I can understand the event logger, Windows has no issue.
Deinstalled the driver with AMDCleanup and also tried DVU. Both seemingly worked.

Installed the exact same drivers with my old Asusteck R7 370 and all works perfectly.

Deinstalled drivers, switched to the new RX 580, booted. All is fine. Install the driver. Reboot and again the black screen.
Tried booting with 640X480 Resolution and installing then. Same result, black screen after boot.
Tried installing the driver from the extracted files via updating the Display Adapter Driver. Same result, black screen after boot.
There is no error during driver installation.
Checked that I connected the 8 Pin instead of the 6 Pin for the R7 370.
The funny thing is, once I boot with the card inserted into the slot but without the driver installed I can switch to higher resolution. So the card seems to do something.
Had the Virus Scanner deactivated during driver installation.

3 Replies
Maestro1334
Adept I
Adept I

Re: black screen at boot after driver installation RX 580

It really seems like AMD doesn't care about their customers. So many people have problems with drivers, RX580 problems.. Barely gets any attention from AMD. There are literally hundreds of people with the exact same problems that I am having but they don't seem to give a **bleep**.

 

The only way to get anything done anymore is to contact the media (youtubers, etc). If you are lucky they will give your issues some attention.

 

I really hope you are able to solve your problem. I'm at the point where I am probably going to RMA my GPU even though I am fairly sure that will not fix anything. In your case it probably will, so I suggest that is what you do.

pokester
Esteemed Contributor III

Re: black screen at boot after driver installation RX 580

They have been having issues with the drivers and Polaris since the begging of 2020 with the new 2020 GUI. No idea why that is. I can't load the current drivers on my RX 580 at all with any success. 

I have never once seen it as a recognized issue by AMD or commented on by any AMD employee willing to help with this issue. Yet hundreds of users have reported the same problems for 11 months now. 

I can however load the last 2019 drivers with no problem. Just run DDU from wagnardsoft.com before regressing to the older driver. Then I just set the power limit to the max and use a more aggressive fan curve and it is pretty trouble free. You can still get those older drivers if you want to try them at guru3d.com. I am using the last 2019 December drivers before they went to the 2020 at the end of December.

Luckily I have not needed any of the new driver optimizations from 2020 for my machine with the RX580, if you do you might try the following and see if you have better luck.

Some are reporting some success at just using device manager to update the driver only without the adrenaline 2020 GUI by pointing the update driver in device manager to the AMD folder and installing the driver that way, then using Afterburner to control the features it can. I have not tried this myself in a while so can't speak to how well it works but others have said it does. 

Make sure you are reporting these issues to AMD they need to fix this as it is still a supported card and frankly one of the few that is even available for purchase at the moment. 

Let AMD know about it at the following link as they don't know about it from these USER TO USER forums:  https://www.amd.com/en/support/contact-email-form

zarni
Journeyman III
Journeyman III

Re: black screen at boot after driver installation RX 580

black screen at boot after driver installation RX 580 problem have answer ???

:relieved_face:


@oldgrantler wrote:

AMD Graphics Card
  PowerColor Red Dragon RX 580 8GB
  Same issue with MSI Radeon RX 580 Armor OC 8GB

Desktop or Laptop System
  Desktop

Operating System
   Windows 7 64bit SP1, all updates installed.

Driver version installed
 tried:
 win7-radeon-software-adrenalin-2020-edition-20.2.2-mar5.exe
 win7-radeon-software-adrenalin-2020-edition-20.9.1-sep29.exe
 win7-64bit-radeon-software-adrenalin-2019-edition-19.6.2-june24.exe

Display Devices
 BenQ GL2480
 DVI to DVI

Motherboard + Bios Revision
 Gigabyte 970A-DS3P Rev 2, Bios FD latest

CPU/APU
 AMD FX 6300 Hexa-Core Prozessor (3,5GHz, Socket AM3+ 14MB Cache, 95 Watt)

Power Supply Unit Make, Model & Wattage
 Corsair VS650 (Active PFC, 80 Plus White, 650W)

RAM
 16GB

 

Describe your issue:
After installation of the AMD Drivers during boot I can see for a moment the windows logo, then the screen goes black.
Sound comes on, the fans on the graphics card go silent, shortly after that the monitor reports that the signal is lost.
Checking as far as I can understand the event logger, Windows has no issue.
Deinstalled the driver with AMDCleanup and also tried DVU. Both seemingly worked.

Installed the exact same drivers with my old Asusteck R7 370 and all works perfectly.

Deinstalled drivers, switched to the new RX 580, booted. All is fine. Install the driver. Reboot and again the black screen.
Tried booting with 640X480 Resolution and installing then. Same result, black screen after boot.
Tried installing the driver from the extracted files via updating the Display Adapter Driver. Same result, black screen after boot.
There is no error during driver installation.
Checked that I connected the 8 Pin instead of the 6 Pin for the R7 370.
The funny thing is, once I boot with the card inserted into the slot but without the driver installed I can switch to higher resolution. So the card seems to do something.
Had the Virus Scanner deactivated during driver installation.


 

Tags (1)
0 Kudos