Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

BIOS changes needed so that Mint 19.1 will install?


I am trying to install Mint on a new build PC using an ASUS B450 MB, an AMD Ryzen 5 2400G CPU, with 16 GB of G-SkillDDR4-3200 RAM.

Does anyone have the slightest idea why several screens of error messages stream by before the desktop even appears but then neither the keyboard nor the mouse will work so that I can finish the installation?

Any help anyone could provide would be greatly appreciated!

6 Replies

Did you verify the integrity of the installation medium?

It failing to load the live media after these errors occur?

Adept I

Hi, and thanks for the response.
Yes, I verified the downloaded ISO file and verified the file writes to both the DVD and the flash drive ont4o  which I copied it. Both types of media 'worked' the same; the media would be read, 2-3 pages of streaming errors would whiz by, the main installation 'desktop' would finally appear, and then neither the keyboard nor the mouse--both of which HAD worked when I was in the BIOS assigning boot priorities, etc.--would operate so that I could finish the OS installation. Weird, right? It's got me stumped--I recently installed Mint 19.1 on my son's Linux box with an AMD processor and it works as nicely as you could hope for.


Strange, might try hot plugging the mouse and keyboard.

Sounds like a USB issue, maybe try only using USB 2.0.

It's likely that the chipset on the motherboard hasn't got a proper library loaded by the kernel.

OK, I'll look into both of those areas (although I'm not at all sure how I can update the kernel if I can't even load the OS and get the PC running!)
Many thanks for the help!


You may be able to update bios from usb.

Though I doubt bios version is the problem, it seems more like a USB emulation issue if you're plugging into an old school round ps/2 type ports for keyboard and mouse.

Otherwise, I'm leaning on some errors regarding power state,  USB getting suspend is like a sleep state issue.

Also, some installation mediums don't always contain all the proper libraries for newer chipset revisions.

Adept I

Thanks, y'all--you've given me a LOT of good ideas! (Sorry for my 'noobieness' ...)
I'll try these when I finally get home and straightened out tonight. Y'all ROCK!