cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

cadunka-chug
Adept I

battlefield 1 says i dont have ANY drivers installed and wont even try to launch. but i have as of this post 18.5.2 an it says i need 16.x.x or grater. it says i have 0.0.0 driver version....please help

sorry if this is the wrong place to ask this but im running out of options at this point. so i just bought BF1 and i let it install all 60-ish GBs and its now giving me a error that says i have driver version 0.0.0 installed and that it only works with 16.x.x or higher, i have the latest 18.5.2 installed so im really quite lost. iv uninstalled both game and drivers and tried the old trick from the open beta but it dose not do a damn thing. iv contacted EA and they tried their best but that didn't end up getting me any where. im hoping someone will have the brains to help me out! i have a almost brand new system with all updated drivers and windows 10 pro. i have a radeon RX 580, AMD ryzen 3 2200 g OC, MSI tomahawk B350 and the rest is normal hardware... im really at a lose here guys and galls. any help is appreciated!

0 Likes
3 Replies
pokester
MVP

Re: battlefield 1 says i dont have ANY drivers installed and wont even try to launch. but i have as of this post 18.5.2 an it says i need 16.x.x or grater. it says i have 0.0.0 driver version....please help

I answered the other thread you asked this in. It is against forum rules to ask the same question repeatedly. Please see your other thread for the suggested answer.

0 Likes
cadunka-chug
Adept I

Re: battlefield 1 says i dont have ANY drivers installed and wont even try to launch. but i have as of this post 18.5.2 an it says i need 16.x.x or grater. it says i have 0.0.0 driver version....please help

Ill go delete that then... Sorry im a noob to forums

0 Likes
Matt_AMD
Community Manager
Community Manager

Re: battlefield 1 says i dont have ANY drivers installed and wont even try to launch. but i have as of this post 18.5.2 an it says i need 16.x.x or grater. it says i have 0.0.0 driver version....please help

0 Likes