Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

B650M Chipset USB dropouts on cold boot

Hope this is the right subforum to post this on. I recently treated myself to a new computer build after ~3 years, and I’ve been having nothing but trouble with USB dropouts. Had I done more research prior, I would have known about this issue that seems to have been prevalent since the AM4 days. Thing is, I’ve had great success with my prior build (AM4, Ryzen 7 3700x, 32GB 3600, RX 5700XT, Asrock Steel Legend mATX), so I wasn’t thinking there’d be issue. Been nothing but frustration.

  • Asrock PG Riptide mATX
  • Seasonic Focus GX Gold 80+ 750W
  • Ryzen 7 7700 AM5
  • G.Skill Trident Z 32GB DDR5 6000 (Samsung chips) - Used at both stock 4800 and 6000/5800/5600/5400 XMP
  • Asrock RX 7800XT 16GB
  • 500GB Inland Pro NVMe (OS) - 2TB Samsung NVMe - 1TB Crucial MX500 SATA - 1TB WD Blue HDD - 4TB WD Blue HDD
  • Windows 11 Pro
  • Thermaltake Core v21 Case

So to start it off, the USB dropouts have been… odd. They only seem to happen from a cold boot. It starts with a simple stutter where both my KB+M (wireless 2.4GHz) start lagging and stop any input, then pick back up. Then comes the audio stutter. Slowly but surely, within about 3-5 minutes, the whole system locks up, and twice I've had a BSOD after just waiting (I'll find what each error code was ASAP). Upon having to hit the reset button on my case (as everything seizes up), everything works as if there’s no issue whatsoever. Nothing in event viewer to coincide any Windows problems. Hell, I played Starfield for ~6 hours almost non-stop the other day with nary an issue (although Akila City decided not to load in at once point). I've put a total of 25hrs in that games thus far without an issue and max settings.

Since then, I've done the whole barebones testing. Pulled all non-essential parts, and every boot I ran ~10 minutes of Prime 95 and had Vivaldi up in the background. Saturated the CPU & RAM. I then shut down, killed power to the rig via PSU switch, hit the power button to exhaust any residual power, and then added one piece of hardware back in at a time. Tried both RAM sticks individually with no issue, then two sticks, then SATA drives, and finally the video card. No issues whatsoever. 

I've also tried all stable BIOS variants that Asrock offers, and currently on v1.28 with AGESA No changes in settings or defaults in the BIOS seem to change anything.

I've also turned off Selective Suspend and disabled power management on all USB Root Hub devices.

Of course, letting it sit overnight and trying this morning... 3-5min into Prime95 and USB glitches, sound cuts out, and BSOD after ~10 min. I'm truly suspecting the chipset or the whole board at this point. The last thing I did was use the AMD driver cleaning utility, and I also purged the chipset drivers. I'll be reinstalling them all tonight to see of any change.

Any insight would be helpful, and hopefully this doesn't result in mobo replacement, though I have a Gigabyte mATX board in my Amazon cart just in case.

3 Replies

Have you tried disabling 'usb selective suspend'?


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Oh crud, I knew I forgot to add something. Yep, I have tried turning off Selective Suspend, as well as disabling the Power Management feature in Device Manager for all USB Root Hubs (and basically anything under them) to turn off power to the device when not in use. I'll update the post to reflect that.

Journeyman III

Weird that I can't edit my post. I think I resolved the problem, and I'm beating myself over the head realizing how daft I was.

It was the Bluetooth adapter plugged into one of the USB ports. Dug into Event Viewer again and found the driver was being disabled upon attempt to load. That explains why the issue went away upon restart. It also explains why it worked fine when going into Safe Mode, running from a Linux Live USB, and loading up Hiren's Boot PE. Still ever so often have small hitches, but nothing in comparison to this headache.