Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

b450 Fatal1ty USB Drop out

So I bought a B450 board for my VR computer a little while ago, and I threw my old 1700 into it, and it's been working amazing, until recently. I don't know exactly what could have caused the issue, and I have tried quite a few different things to get it working...


Asrock b450 Fatal1ty (gaming)

Ryzen 1700

16GB 2400MHZ (8x2)

RX 470 4GB Gaming X

1x NVMe 500GB 


750 W Rosewill (Bronze 80 Plus)

I have been using this VR computer for a little while now, I used to have it hooked up to the internet VIA ethernet, and I had an RX 580 8GB DUAL in it. But with the massive silicon shortage, I needed a GPU to put into my computer, and I had another RX470 lying around. So I used DDU, and AMD Cleanup tool to make sure everything was cleaned off the system and swapped the cards. Right after I did that I went to install all the drivers. And I noticed windows had just updated, so I let it do it's thing. Once everything had been updated I went ahead and tested the computer on games like Overwatch, and Modern Warfare. And it had no issues. So a week later, when I had time, I hooked it up in a new VR space that I could not run an ethernet cable to, so I was using the WIFI built into the board. And I also needed a new USB 3.0 Extender, so I bought one of those. And now the USB ports cut out whenever it is trying to comunicate with my sensors. And whenever it cuts out, everything will cut out. the computer will be still running, but not a single USB port will respond.

I've tried updating the BIOS to the latest version supported for this processor, and it didn't change anything. So I went and tried to reinstall all the drivers, and it seems to happen more often. And so I looked it up, and people were saying to turn down the PCIe  to gen 3 from auto, and turn off C-States. So I went and turned off C-States. And I tried to change it to PCIe Gen 3, but the only options I had other than Auto were Gen 1 and Gen 2.

Any help with this would be greatly appreciated, I heard that a new BIOS is coming out for the 3000-5000 series, but I wont be able to use those with my 1st gen ryzen. Unless somehow they squeezed it all in there, or are there going to be more than one update for other Generation Ryzen processors? 

5 Replies
Adept I

I went ahead and set the VR setup on my Ryzen 3000 series computer. And it seems to be working flawlessly so far. It might have something to do with my windows install and REG files, I did just reinstall windows on this computer. I think I will try reinstalling windows on the VR computer for more troubleshooting. 

Specs of Ryzen 3000 machine:

MSI b550 pro-vdh wifi

Ryzen 3700x

32GB Viper 2666mhz (8x4)

RX 580 Dual 

EVGA 650W Modular 80 Plus Gold certified

1x 500GB Samsung MZVLB512HAJQ-000L2 (NVMe Drive)

1x 2TB Sata SSD

1x 1TB HDD


My other suspicion is maybe the RX 470 is causing issues. But that could also MAYBE be fixed with a new windows install.



I'll see if maybe I have it. But I haven't had blue screening issues, it's just usb drop out issues.


I couldn't get the computer to roll back, so I reinstalled windows with the same install that worked perfectly on my computer, and the drop out issues are still persisting. It was working fine on anything else, but whenever I hook up all the sensors and VR headset it just has all the USBs drop out.


I contacted ASRock today to see if they could tell me if I can use the new update. So hopefully they'll be able to get back to me soon.