Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Audio Completely Gone After Updating Graphics Driver


I'm not super tech savvy, but I can generally follow along instructions to get whatever I need done. So, I will just list out all the steps I took. This ALSO happened to my S.O. who has the same PC as me. We both updated our graphics driver at the same time, and now both of our audio is gone I've been searching all over the internet to try and find out what's going on, but I'm having no luck.

We both updated our graphics driver. I simply went to the AMD Drivers page, selected Windows 10 - 64 bit, and used their "Auto-Detect and Install". It recommended one of the more recent updates, so I clicked on that. It did it's things and it told me to restart my PC, so I did. The driver hadn't been updated in over a year according to the date I saw prior to updating.

Now, my Graphics driver is updated, but I have no audio. The little speaker icon in the bottom right has a red X on it, and when I hover over it, it says "No Audio Output Device is installed". Most websites have me check under Device Manager for Sound, video and game controllers, but that option is not listed anymore. Under System Information, I open Components, and click on Sound Device, and it's simply blank. In the DirectX Diagnostic Tool, I click on the "Sound Tab", and it's also blank. No device is named. Under notes, it says "No sound card was found. If one is expected, you should install a sound driver provided by the hardware manufacturer."

I looked up my Motherboard Gigabyte Technology Co, Product: GA-78LMT-USB3 R2. On their support page, it shows Realteak HD Audio Driver with a Download button. I clicked on that, but instead of installing anything, it just brings up a bunch of files, and I have no idea what to do with those. So, I just went to the realtek download page and started downloading the Realtek HD Audio Driver (Vista/7/8/8.1/10) 64 bit. It took about 2 hours, and once completed, nothing changed. So, I clicked on the download, and it took me into Realtek High Definition Audio Driver Setup (4.21). Went through the steps and told me to restart. When I came back, nothing changed. My friend told me to open those files I downloaded from the motherboard website that I didn't know what to do with, and told me to look for a Setup option and run that. So, I did, and it took me through the audio driver setup again, I restarted, and nothing changed.

To also add: my load times in game has increases pretty drastically after updating my Graphics Driver. I hopped on WoW and my load times went from 4-5 seconds, to 10-15 seconds. The audio is the bigger priority, but the load times definitely are a bummer too!

I have no idea what to do. This has affected both of us. I googled for hours trying different things. I don't know what more information is needed, but I'm happy to provide whatever may help. I don't know how to post pics (first reddit post), but any help is greatly appreciated!!

GPU: AMD Radeon (TM) RX 560 Series

Manufacturer: CyberPowerPC

Processor: AMD FX 9(tm) - 6300 Six - Core Processor 3.50 GHz

RAM: 16 GB

1 Reply
Journeyman III

I have the same exact problem! Everything always worked perfectly with my Roku TV until I updated to the latest AMD driver (20.9.1). I don't know what driver I had previously. But right when I did the update I started to have the same exact audio issue as you. No sound device is detected, and all I get is a red X on the audio icon.

I have tried restarting my computer and TV. Windows Tech Support recommended rolling back to a previous version of the Radeon software, but I don't know how to find what previous version I was using.

@ntaylor6372, can you link the reddit post you made?

Microsoft Windows 10 Home:10.0.19041 Build 19041
AMD Ryzen 3 1200 Quad-Core Processor, 3100 Mhz, 4 Core(s), 4 Logical Processor(s)

Radeon RX 580 Series