cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

benchart
Adept III

Anybody here suffering from Audio Desync on Relive?

Hi there.
I'm just here to ask if somebody is suffering audio Desync.
I have a benchmark channel on youtube for quite a while but usually videos are short and so it seems that there is no problem with them.
But recently, since there aren't too much releases now, and I wanted to find an excuse to complete old games that I have on my Steam account.
I decided to start a new channel for playthroughs, so videos are now much bigger since I usually separate the videos by levels, so it's easy to reach >20 minutes per video, sometimes even 1 hour.

And I started to notice that audio starts to desync from the video.
I make commentary so sometimes either it's the game's audio that desyncs from the video, other times it is the mic's audio that desyncs and sometimes even both.
This have been happening in all drivers so far, but in this latest release (17.7.2), it pretty much happens much more often.
This happens very randomly, so I can have a video with 1 hour with no desync problems, like I can record another one with 20 minutes, where everything is desynced.

I want to know if anybody here is suffering from this problems too?
I already reported this on the report form, but I want to know if I am alone in this..
Cheers

My system specs:
AMD Phenom II X4 945 @ 3.6GHZ
(4x2GB) 8GB DDR III 1600MHZ
Gigabyte HD 7850 2GB
WD 500GB
Corsair TX-650W
Windows 10 Home X64

0 Likes
7 Replies
spikeypup
Elite

Re: Anybody here suffering from Audio Desync on Relive?

I am also experiencing de-synch issues particularly noticeable when using webcam capture, audio seems to be just a shade under a second early so meaning video is behind slightly, game capture audio seems relatively in sync however for the majority of the video, I usually record with OBS, but since 17.7.1 I cannot use OBS at all.  Most videos I have done of late with Relive are over 1-2 hours and sync maintains the whole way, except vid cam audio is definitely out of sync, capturing audio through MIC input on my Sblaster X-fi.  A few vids I have done though I can see some slight audio-desync and like you it starts at any given time, sometimes late in the vid sometimes early on, but it doesn't have a continuous slide in time.  IOW if it is about 1 second off, it usually stays that way from the point of start of de-sync, to the end of the video, it doesn't get worse.  I use HEVC/60FPS/1440P and an audio rate of 256/230Kbps and a target bitrate from 20Mbps up to 60Mbps, seems to happen across all different variances of settings.  17.6.2 was the most stable for me, but I haven't really wanted to downgrade because the performance in 17.7.2 is much improved, plus Enhanced Sync is so valuable to me, but stability and compatibility have been bad.  I don't think it is all AMD's fault, Microsoft has done a lot of lower-level updates to Windows in the last couple weeks, coincidentally pretty much when 17.7.2 came out and I think it's added a lot of instability.  I've also been experiencing weird clock behavior since said updates in regards to my mainboard BCLK and weird voltage spikes to my CPU Vcore.  I'm just making sure that I'm submitting problem reports and driver reports through the web as much as possible to ensure they have everything the need to see what's been going on...  I hope things get fixed up soon for both our sakes, but I know things are super busy for AMD and MS right now so I'm just trying to be patient.    Unfortunately my fans are really bummed as I haven't been able to Livestream in weeks. 

benchart
Adept III

Re: Anybody here suffering from Audio Desync on Relive?

Yeah, I will submit the videos anyway, It's bearable, but annoying at the same time.
Hope they don't mind too much with the fact that some of levels are desynced.
Anyway the channel is super new, not even 10 views per video, so I'm not giving to much attention into this issue.
As for the other main channel where I have almost 2.5K subs, since the videos are usually small, I haven't encounter too much this issue, so my fans from that channel don't suffer XD

0 Likes
spikeypup
Elite

Re: Anybody here suffering from Audio Desync on Relive?

Are you using Relive to record, or OBS, or?  Sync is not so bad with OBS, Relive is kinda issue laden right now, seems there are some mass DPC/ISR right now, but I'm still tracing, and I will run a GPU Perf profile later to see what's going on, let me know more about your setup, and I'll try to help best I can. 

0 Likes
benchart
Adept III

Re: Anybody here suffering from Audio Desync on Relive?

I'm using Relive, I don't like too much of OBS, not because of being good or bad but because of not being too much user friendly.
Relive is easy to set up and go.

I have a AMD Phenom II X4 945 @ 3.6GHZ

8GB DDR III 1600MHZ (4x2GB)
Gigabyte HD 7850 2GB (GCN 1.0)
WD 500GB
Corsair TX-650W

Windows 10 64 bits fully updated and original.

But I'm recording old games and also newer ones, so the system ends up being irrelevant especially for the old games

spikeypup
Elite

Re: Anybody here suffering from Audio Desync on Relive?

Do you have your Game DVR under Xbox settings set to OFF, all the settings, be sure.  Also Game Mode doesn't play nice at times.  Also, check to make sure your recording devices in Audio are not set to crazy bitrate/sample freq, since you mentioned old games, good old fashioned 16Bit/44.1Khz should be fine, also depending on your system you may try using HPET and setting your system timer to a .5ms resolution, this will result in some further interrupts but they will be for the video and the audio and the timer, this may add .02-.10% to your total system interrupts but they are rapid and don't typically lead to major ISR or DPC issues with other drivers, it really depends on how the timers are setup on your board.  You will want to set your TSCPOLICY in BCDEDIT to Enhanced, and set /useplatformclock true variable in BCDEDIT, if all this sounds crazy and bizarre, let me know I will go into detail and tutorial for you.  Again, this is a mileage may vary situation, sometime HPET makes it worse, sometimes improves it a lot, it also has to do with how your MMCS (Multimedia Class Scheduler) is set in the registry.  And of course, the drivers are already kinda not working well right now under 17.7.2 for some folks, such as ourselves, and we'll just have to wait, or you can try 17.6.2 and give that a whirl, you will lose the new enhancements, but performance is close to the same.  Since you mentioned you are using older games, like DX9 or below, note that I have noticed some regressions with the improvements to DX9 and DX11 in the new drivers, I have submitted debug reports and bugchecks/codepages but I'm sure it will take some time for AMD to find them and iron them out.  17.7.2 was a massive update with so many changes and enhancements, so there was bound to be anomalies for a good bit of us, some benign, others not so much, Driver lottery as I call it lol.  Anyway, also ensure that your bitrate is set accordingly, you are using an older GCN, you should use VCE performance test to see if you are having an issues there, that will be a good start.  I know it sounds like a lot, but if you are like me, and want your channel to be great for the viewers, I know you will invest the time and sure you already have invested a good bit already.  For bitrate, the more you throw at the card, the easier the encoding will be and the less chance that delays in the encoder as it hands it off to VCE will result in desync in the Mux process, if the compression is tight, ie. using a lower bitrate, and the encoder stalls slightly or has to wait for frames in color conversion on the DirectCompute side, it is easy  for it to fall out of sync as the buffer time for audio, if set to lets say 50ms or so, I'm not sure what AMD uses as an audio buffer in Relive, and let's say your encoder skips 3-6 frames, if you are at 60FPS, then you are talking 60-80ms of stall, causing delay in audio, and if the muxer isn't aware of the delay, then audio will become out of synch and continue to slide as you go further and drop more frames, so throw more bitrate at it and deal with the longer upload time to YT, besides your quality will improve anyway, if you are at 30FPS, then you have more breathing room for the stalls, but it can still slip if you stall 50-100 frames at once (about 3 seconds of video), even if it tries to catch up it is possible the audio buffer has already dumped the last few seconds of audio and it just has to grab new audio, or if it does grab the buffers in time, they will be behind resulting in your mouth moving and then audio coming behind it.  Typically its behind and not forward.  Sorry for the rant, I hope it gives you some food for thought, let me know what's up.

Cheers.

Spikeypup

0 Likes
benchart
Adept III

Re: Anybody here suffering from Audio Desync on Relive?

Damn.. Big big reply
Game DVR is disabled (I don't like it)
My audio bitrates are around that yes, but this happens in both new and old.
I need to try that HPET to see what happens..
Yes I noticed that the 17.7.2 are actually worse comparing to old ones, but I need to install the old ones so I can compare.
VCE is fine, it can record at 1080/60FPS no problems

One big confusion. using lower bitrate makes the GPU to work more?
Shouldn't it be the contrary?
I mean, more bitrate... more demanding..
Always though it was the contrary, I don't need to much big bitrate, I use 30Mbps, my upload connections is 768kbps, so it uploads around 76.5KBPs, around 250MB/h

0 Likes
alza77
Adept I

Re: Anybody here suffering from Audio Desync on Relive?

I'm getting an audio desync issue on 17.12.1 where the audio is about 5 seconds out of sync with the video.

My ReLive settings are:

Resolution: 1080p

Max Recording Bitrate: 50Mbps

Recording FPS: 60

Encoding Type: HEVC

Audio Bitrate: 192kbps

Instant Replay: 4 minutes

0 Likes