Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Antialiasing is not taking effect in DirexctX®9 applications on RDNA graphics

Antialiasing in Radeon Software graphics settings is not taking effect in DirexctX®9 applications on RDNA graphics products. Antialiasing settings dont work with 5700xt and DX9-Games. AA work fine with non Navi-Cards RX580 and Vega56. Bug is already figured out in these threads:

Anisotropic filtering under Adrenalin 2020 - Page 5 - AMD Community

[Bug] Graphic corruption w/ AA, and AF setting not... - Page 2 - AMD Community

Anisotropic Filtering bug has solved in 21.1.1, but Antialiasing still dont work.

1 Solution

What the hell - I never thought this would happen: AMD, you did it, you fixed it!
Problem solved in 2021.3.1 driver - Supersampling works like a charm in DX9 on 5700XT!
Thank you very much AMD!

View solution in original post

19 Replies
Adept II

@Matt_AMD: These users confirmed that Antialiasing is not taking effect:

@johnhardyiv , @ftwd , @curse127 , @temurzyn , @lcountach : Please use the bug report tool from amd, i have already done it.

Reported via the Radeon tool.

As of 20.1.1 AA does seem to be working in most games for me, just not exactly as expected.

SSAA only seems to work properly in OpenGL 1.0 games, in DX games it seems to only apply 2x MSAA instead (no transparency filtering and lots of missed edges but it is doing something at least with *some* games, F.E.A.R. for example)

Adaptive MSAA doesn't filter transparencies, I haven't really tested basic MSAA

MLAA doesn't seem to work

I get that MSAA might not work on a lot of games which use differed rendering elements but that's expected, however SSAA and MLAA should work on every game regardless (although I can forgive MLAA not working in OpenGL as it's an injected post process) as it stands, injecting SMAA via ReShade and the like or using VSR seems to be the only reliable methods (although VSR often causes UI scaling issues or just can't be applied because the game doesn't support such high resolutions)

To be fair, a lot of these issues were present on my RX480 too but with that I could use RadeonPro which would *always* work (sometimes even if it broke the game it still applied the effect, differed engines like Unreal Engine 3 often didn't render properly with MSAA applied) but that option is lost to me as RadeonPro doesn't work with this RX5700 and is no longer supported by it's developer.

Prior to 20.1.1 those driver toggles didn't seem to do anything at all, now they're hit and miss and when they hit they seem to be missing the bullseye

@Matt_AMD @Ray_AMD : Are you investigating this issue? Can't find it as a known issue in 21.2.1 release notes. 

@kahless_uk : "...a lot of these issues were present on my RX480..." - Seems to be different problem. We miss AA only on RDNA graphics, other cards are fine.


I actually haven't tried changing the global setting just the game profile settings for each game.

As of 21.2.1 these issues still exist.

F.E.A.R. supersampling doesn't work correctly (missed transparencies, several missed edges, looks like 2x MSAA), Adaptive MSAA also doesn't effect transparencies, MLAA doesn't work.

S.W.A.T 4 No settings work

Tron 2.0 (another DX9 lithtech game) no settings work (although anisotropic filtering does seem to work now)

Left 4 Dead 2 no settings work (tried override and enhance)

Vampire the masquerade: Bloodlines no AA but AF works

The Saboteur the only example of MLAA working, superssampling doesn't work, AF works

Dark Forces (DarkXL port using DX9) No settings work

Dark Corners of the Earth (Call of Cthulhu) AA settings don't work AF does

OpenGL games seem to work just fine (ST Voyager Elite Force and EF2, Chronicles of Riddick  Dark Athena, Return to Castle Wolfenstein, Doom 3 and D3 BFG allow enhance to apply SSAA, Quake 4 enhance applies SSAA, Quake 2 , Quake 3, GLQuake , Soldier of Fortune works but only if the game executable is renamed to Mohaa.exe which is the only way to make that game run anyway)

As I said these driver toggles didn't always work on GCN cards either (but some did ,VTM Bloodlines and L4D2 for example did work) but there was a simple solution to that in RadeonPro which would ALWAYS work even if it broke the game's rendering. This isn't a new problem unique to RDNA, a quick google search (or any other search engine) will find you plenty of examples of people saying driver AA toggles don't work on AMD cards going all the way back to terascale GPUs (and I can personally attest to that from experience with a 5770 back in the day), the RDNA issue of the AF toggle not working IS a new problem and that one seems to have at least been fixed for most DX9 games as of 21.1.1. What's galling is that green team GPU's don't seem to have ever had this problem (at least according to my mate and my own experience with them from TNT2 through to FX5000 series GPUs) and they can even choose from 3 different kinds of supersampling.


That's... interesting. Seems like a major driver glitch.

Also, there are no "three types of supersampling" on nV cards, only options are normal MSAA (no transparency detection), transparency multisampling (similar to analytical MSAA, but worse transparency detection - doesn't work in quite a few games), transparency supersampling (analytical SSAA for transparencies, works everywhere where there is antialiasing) - those are available through Control Panel; there's also sparse grid supersampling, but you need nVidia Inspector to enable it. The third one is, I think, traditional SSAA, also only available through nV Inspector app, but it rarely works, and even when it does, it frankly blows in comparison to, say, 16xS or even 32xS modes available through, once again, nV Inspector, especially when 16xS AA is paired with 4x transparency supersampling. 


Problem continues in 21.2.2 driver - reported via the Radeon bug reporting tool.

Problem continues in 21.2.3 driver - reported via the Radeon bug reporting tool.

Can confirm for at least some games: FEAR and Postal 2 don't receive antialiasing when overriden. That sucks royally, since P2 has no in-game AA at all, and FEAR cant handle both soft shadows and AA simultaneously. Some people suggest using FXAA through ReShade or MLAA from driver, but I hate how they often miscalculate object edges and there are random miscolored pixels here and there on the edges, that's gross. So I have to play without AA at all, and that's vile. I can only imagine what torture people with 1080p/1440p monitors have to endure. 

Driver 21.2.3.

OpenGL games like Minecraft are suffering from the same issue. AA isn't getting applied at all. The problem is not just in games, its affecting everything else. There are weird graphical issues in video as well.

I'm playing games at 1080p and its absolutely awful. Its either the software isn't working as intended or the drivers are unstable.

It seems like reverting to an older driver doesn't work either.  

"It seems like reverting to an older driver doesn't work either."

AA in DX9 on RDNA never worked since release of RDNA graphics.

"AA in DX9 on RDNA never worked since release of RDNA graphics. "

Apparently, AA doesn't work regardless of the type of graphics or DX version at the moment. The culprit is either the drivers or the software.

What the hell - I never thought this would happen: AMD, you did it, you fixed it!
Problem solved in 2021.3.1 driver - Supersampling works like a charm in DX9 on 5700XT!
Thank you very much AMD!


That's great! Can anyone confirm that for old and non-DX9 (OpenGL) games like Half-Life, Unreal, Quake 2, Postal 2 etc.? Also, did you try FEAR with soft shadows on? 


Not fixed here.

OpenGL still works but AA has no effect on FEAR with or without soft shadows

OK so just so you know: AA still doesn't work if overriden in Postal 2 and FEAR, neither in multi- nor in supersampling mode. In-game AA works just fine, checked with FEAR (but you can't have both soft shadow and AA simultaneously, and in 4K, I can kinda sorta live without antialiasing, but it's still far better with it), PainKiller and Crysis (although Crysis is a DX10 title, technically). This is really annoying, it's been literal months since 6900XT launch, and we're still at square 1 with the issue. Just make it work. Use ordered grid supersampling if you can't fix yours, just get it done. 


And here I was wondering why overriding application setting for FEAR doesn't work. Also, do in-game AA modes work at least? Or is it a global antialiasing issue? 


Most (all?) DX9-Games have no in-game AA mode settings, switching is only possible global in Radeon Software graphics settings.


I know, but some later ones have, e.g. Half-Life 2, FEAR, FarCry 1/2 (in DX9 mode), Alan Wake, even Crysis under DX9 render path. It seems to work just fine in-game in Alan Wake for me, and I only tested FEAR yet of other games, but since it can't handle both Soft Shadows and AntiAliasing within in-game options, I didn't check thoroughly - I always relied on Override feature. 

Also, not the first time I encounter something similar. I used to have lots of nVidia cards in the past (GTX480, GTX Titan SLI, GTX 1080, RTX 2080Ti to name a few), and one day, in the new version of driver they removed possibility of using both in-driver FXAA plus Override feature together, it became only one of the two. I think it was when I still had those two Titans. And it never came back. Also, it was impossible to Override AA with Soft Shadows enabled in FEAR since I don't remember exactly when, so I had to use compatibility bits in nVidia Inspector to allow it back. Which makes me think, maybe configuring it through RadeonMod app will do the trick? But I'm very new to this, this 6900XT is my first Radeon GPU, I never had ATI/AMD videocards before, since MX440 up to the week before I only used "team green", so I don't think I can figure stuff out on my own in short term. 

On a brighter note, I finally figured how to up the Power Limit through MorePowerTool, so now my card can "eat up" up to 357W of pure POWER when needed and handle a rock solid frequency of 2550~2650MHz (set to 2670 in MSI Afterburner). This is close to the limit for reference design (2x8-pin = 2x150W + PCI-E can supply up to 75W), and also seems to be the limit of my card - when I raise it up to 2750MHz in Afterburner it crashes after 10~20 minutes in Unigine Heaven benchmark.