Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

Anisotropic filtering under Adrenalin 2020

Under new driver forcing AF seems not working at all. Even in case of DX9 games (tried to set it for Oblivion).

Cant revert to older driver because there is none (5600xt here).

What to do?

49 Replies
Adept III

No go in 20.11.1.  I joked in my other thread that maybe we'll have to see if the functionality jumps a generation from working in Polaris to not working in NAVI to whatever is next.

I've actually got my 590 and 5600XT installed in the same box and bounce back and forth whenever there's a new driver hoping the 5600 will finally work w/ AA and AF.  Sigh.


Same here new drivers no luck, Trying GTA III that has mipmapped textures with the mod i have on it, It always worked with NVIDIA when putting x16 Anisotropic filtering and it's a requirement for this now since all the textures are mipmapped wich means i have to put x16 on. But now the switch on AMD is useless so might as well leave it off. @AMD please take notes on the software functionality for the RX line

Community Manager

Thank you for the post, we are investigating this issue.

Thank you for your feedback.

In Release Notes of 20.11.2 we now can read in the Known Issues :

  • Anisotropic Filtering in Radeon Software graphics settings is not taking effect in DirexctX®9 applications on RDNA graphics products.

Thats fine, but the Anti-Aliasing is also not taking effect!

You guys get your issues w/ anisotropic handled w/ 21.1.1?  My issue w/ Links 2K3 was resolved with it, though other issues remain. :) (anti-aliasing not working in windowed mode, random white polygon shooting out from player's ankle).


anti-aliasing not working in 21.1.1

To separate from the resolved anisotropic filtering bug, i opened a new thread:

Antialiasing is not taking effect in DirexctX®9 ap... - AMD Community

No I can't say 21.1.1 solved all my issues but it seemed to do something. In my favorite driving game TDU (Test Drive Unlimited) it still doesn't work. Several Steam VR games (Not DX9) still seem to be using Bilinear Filtering. Not sure why many driver versions have a note "Only affects DirectX 9 applications" when it clearly affects DX11 games and almost never worked on DX9.

However to test the driver further. I tried Aliens VS Predator and Chivalry and they both responded to the Anisotropic Filtering override.

It is nice to see they did some work but... they still seem to have some more work to do.


New driver still does not work as pre 2020 era drivers.

In Oblivion setting AF does something, but:

- the texture filtering when works seem like trilinear filtering at best, not AFx16

- what is way worse: the texture filtering randomly pops in and out mid game - in one second textures are sharp, then you move your character a little - boom filtering is lost, then it pops in later again.



Better yet:

In Oblivion anisotropic (trilinear?) filtering randomly pops in and out as I switch between first and third person camera.

This is so odd I am convinced this required extra programming work to implement. How texture filtering setting can be not consistend once game is launched and switch on and off depending what is happening on the screen is beyond me.