Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMDuprofPCM says Missing configuration file - unsupported processor model

Trying to capture performance counters, however, I could not get AMDuprofPCM to run. I am using the version 3.5 and am on AMD Ryzen 9 5950X. Appreciate help to address this.

root@amd-ryzen:/opt/AMDuProf_3.5-671/bin# ./AMDuProfPcm
Missing configuration file - unsupported processor model.

8 Replies

Might be better to ask in the Dev. section


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

I am using the same CPU and received the same error on Manjaro Linux. I also tried running the same application on Windows 11, but it would not launch. AMDuProf launches on both Linux and Windows on the same system.

I checked the  official release notes, and Ryzen processors are listed as supported for AMDuProf, but not specificially for AMDuProfPCM, which is a separate application. I'm not sure if that's perhaps the reason, and this application and it's utilities are only supported on EPYC perhaps.


All questions concerning AMD uPROF should be opened at AMD SERVER GURUS:

@swarup @santosh_zanjurne 

AMDuProfPcm does not support client parts, but let me check if we can add support for client platforms as well.  I shall get back to you on this.

Any updates on this? I'd like to use AMDuProfPcm on client hardware as well.


I have filed a feature request for to have AMDuProfPcm functionality enabled on client parts.

I will keep posted on this.


I'm resurrecting this as the new uProf does indeed support Ryzen 5000 series client parts but there is no support for 7000 series client parts.

The reason why this is important is that actual SW development tends to be made with workstations that do use client parts. Also when developing game style applications for consumers that do use AMD client CPUs it's important to profile with the actual target HW.

Have you solved the problem with uperf running on 7000 series machines