cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

esos
Journeyman III

AMDRewards Refusing to detect my RX Vega 64

Jump to solution

I've gotten my GPU in December, and have been working on and off to solve this problem. Every time I enter in my correct coupon code from Newegg, the message: "A qualifying AMD product was not detected in your system. Please install the qualifying AMD product and try again."   

I already have my RX Vega 64 as my Discrete, primary GPU. I have proof attached to this post. I have troubleshooted many times. I already had hardware acceleration turned on in Chrome. I tried Firefox and Opera to no avail. I was really hoping to play The Division 2. I've contacted AMD Rewards support twice, first time I got a stupid automated response telling me to do the things that I've already done. I haven't gotten a response for my second one, it's already been a week. 

I've also tried the Product Verification Tool, but that program literally does not even launch. It shows up in task manager for like 2 seconds and crashes immediately. 

If anyone has a possible solution that I have not tried, I will try it with no hesitation. I've offered to give proof and everything they need to AMD Rewards, no answer. Please help me, I am desperate. 

0 Likes
1 Solution

Accepted Solutions
esos
Journeyman III

Re: AMDRewards Refusing to detect my RX Vega 64

Jump to solution

I finally figured out the solution. Hardware acceleration was not being turned on even after overriding the thing in chrome://flags, and everything would show as disabled in chrome://gpu. I just installed Waterfox and it worked perfectly. If anyone has the same problem, just use waterfox to redeem the code. You won't have to enable anything first or whatever, just do it and works perfectly.

View solution in original post

0 Likes
1 Reply
esos
Journeyman III

Re: AMDRewards Refusing to detect my RX Vega 64

Jump to solution

I finally figured out the solution. Hardware acceleration was not being turned on even after overriding the thing in chrome://flags, and everything would show as disabled in chrome://gpu. I just installed Waterfox and it worked perfectly. If anyone has the same problem, just use waterfox to redeem the code. You won't have to enable anything first or whatever, just do it and works perfectly.

View solution in original post

0 Likes