Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AmdGPU drivers for 6800xt in linux ubuntu machine cant be installed.

Good morning guys i have been trying to download the amdgpu drivers for  ubuntu from the official page:   but it seems like I can't get it to be installed. I first tried by uninstalling any version i ahad, reboot, install trough the ./amdgpu-install or ./amdgpu-pro-install scripts either with --opencl=pal or --opencl=legacy or -y options, following the instructions in , but nothing worked, then someone said that amd drivers didnt work in my kernel version so i downloaded 5.6 and consequently the 5.4 versions of the kernel, also did not installed. Always everything goes right until this error:

"Building for 5.11.0-051100-generic
Building for architecture x86_64
Building initial module for 5.11.0-051100-generic
ERROR (dkms apport): kernel package linux-headers-5.11.0-051100-generic is not supported
Error! Bad return status for module build on kernel: 5.11.0-051100-generic (x86_64)
Consult /var/lib/dkms/amdgpu/ for more information.
dpkg: error processing package amdgpu-dkms (--configure):
installed amdgpu-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of amdgpu:
amdgpu depends on amdgpu-dkms (= 1:; however:
Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu (--configure):
dependency problems - leaving unconfigured
Setting up xserver-xorg-amdgpu-video-amdgpu (1:19.1.0-1188099) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up mesa-amdgpu-omx-drivers:amd64 (1:20.1.6-1188099) ...
Setting up libegl1-amdgpu-mesa:amd64 (1:20.1.6-1188099) ...
Setting up libegl1-amdgpu-mesa:i386 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-glx:amd64 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-glx:i386 (1:20.1.6-1188099) ...
Setting up amdgpu-pro-core (20.45-1188099) ...
Setting up libgles2-amdgpu-mesa:amd64 (1:20.1.6-1188099) ...
Setting up libgles2-amdgpu-mesa:i386 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-dri:amd64 (1:20.1.6-1188099) ...
Setting up libgl1-amdgpu-mesa-dri:i386 (1:20.1.6-1188099) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-rocr-opencl:
amdgpu-pro-rocr-opencl depends on amdgpu-dkms (= 1:; however:
Package amdgpu-dkms is not configured yet.

dpkg: error processing package amdgpu-pro-rocr-opencl (--configure):
dependency problems - leaving unconfigured
Setting up vulkan-amdgpu-pro:amd64 (20.45-1188099) ...
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up libosmesa6-amdgpu:amd64 (1:20.1.6-1188099) ...
Setting up libosmesa6-amdgpu:i386 (1:20.1.6-1188099) ...
dpkg: dependency problems prevent configuration of amdgpu-pro:
amdgpu-pro depends on amdgpu (= 20.45-1188099); however:
Package amdgpu is not configured yet.

dpkg: error processing package amdgpu-pro (--configure):
dependency problems - leaving unconfigured
Setting up comgr-amdgpu-pro:amd64 (1.7.0-1188099) ...
No apport report written because MaxReports is reached already
Setting up hsa-runtime-rocr-amdgpu:amd64 (1.2.0-1188099) ...
Setting up ocl-icd-libopencl1-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up clinfo-amdgpu-pro (20.45-1188099) ...
Setting up hip-rocr-amdgpu-pro (20.45-1188099) ...
dpkg: dependency problems prevent configuration of amdgpu-pro-lib32:
amdgpu-pro-lib32 depends on amdgpu (= 20.45-1188099) | amdgpu-hwe (= 20.45-1188099); however:
Package amdgpu is not configured yet.
Package amdgpu-hwe is not installed.
amdgpu-pro-lib32 depends on amdgpu-pro (= 20.45-1188099) | amdgpu-pro-hwe (= 20.45-1188099); however:
Package amdgpu-pro is not configured yet.
Package amdgpu-pro-hwe is not installed.

dpkg: error processing package amdgpu-pro-lib32 (--configure):
dependency problems - leaving unconfigured
No apport report written because MaxReports is reached already
Setting up libglapi1-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libglapi1-amdgpu-pro:i386 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-dri:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-dri:i386 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-appprofiles (20.45-1188099) ...
Setting up libegl1-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libegl1-amdgpu-pro:i386 (20.45-1188099) ...
Setting up libegl1-amdgpu-mesa-drivers:amd64 (1:20.1.6-1188099) ...
Setting up libegl1-amdgpu-mesa-drivers:i386 (1:20.1.6-1188099) ...
Setting up libgles2-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libgles2-amdgpu-pro:i386 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-glx:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-glx:i386 (20.45-1188099) ...
Setting up opencl-rocr-amdgpu-pro:amd64 (20.45-1188099) ...
Setting up libgl1-amdgpu-pro-ext:amd64 (20.45-1188099) ...
Setting up amdgpu-lib (20.45-1188099) ...
Setting up amdgpu-lib32 (20.45-1188099) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)"




(Despite this being for 5.11 version of the kernel the exact same error "ERROR (dkms apport): kernel package linux-headers-5.11.0-051100-generic is not supported" would happen in any kernel version.)

So next, in the first link i mentioned, where i downloaded the amdgpu drivers for ubuntu i see there is an extra step saying:

MD has been working with the open source community and provides an out-of-the-box experience for the majority of Linux users, by having its driver upstreamed. This means that you do not have to download a driver to make your graphics card work; the support should already be there when you install your favourite Linux distribution. AMDGPU, our all-open graphics driver for Linux, can be used with all our Radeon HD 7000 series or newer. To get support for our latest graphics cards (Radeon RX 6x00 series), here are the components that you will need:"

Kernel 5.10 or newer
Mesa 20.2 (or optionally, Oibaf mesa 21.0 from here:
llvm 11.0 or newer

So that is why i installed the the new kernel version 5.11:

Kernel version 5.11Kernel version 5.11


And the mesa 21.1 version:

mesa versionmesa version


 And the llvm 11 version:

llvm versionllvm version


And then i followed all the steps mentioned to add the amdgpu-dkms-firmware version to my download, since i have the radeon 6800 series that would be, as mentioned in the instructions the sienna_cichlid*. If i check my /lib/firmware/amdgpu/ I now have all versions including the one i need: 



If i know do the download trought the ./amdgpu-install or ./amdgpu-pro-install scripts either with --opencl=pal or --opencl=legacy or -y options i would have the same error. 


If anyone can help me i would be very happy. Thank you in advance



2 Replies
Adept II

First, you need the Ubuntu 20.04 following kernel version.

piotr@HaniaPC:~/cifar$ uname -a

Linux HaniaPC 5.4.0-66-generic #74-Ubuntu SMP Wed Jan 27 22:54:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

than you need 


that you have to

sudo usermod -a -G render $LOGNAME


ls -l /dev/kfd 

crw-rw---- 1 root render 511, 0 mar  2 09:16 /dev/kfd

than you should install by:

sudo ./amdgpu-install --opencl=rocr

than you may look on very useful documentation at

and for example in /etc/default/grup have such lin

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.debug_evictions=1"

if you do not know what means amdgpu.debug_evictions=1 mentioned documentation will tell you

unfortunately IT DOES NOT WORK! :-).

in my dmesg as an example I have

[   40.196978] ------------[ cut here ]------------

[   40.196981] Scheduling eviction of pid 2581 in 0 jiffies

[   40.197156] WARNING: CPU: 10 PID: 2581 at /var/lib/dkms/amdgpu/ kgd2kfd_schedule_evict_and_restore_process+0x104/0x120 [amdgpu]

[   40.197157] Modules linked in: snd_usb_audio snd_usbmidi_lib joydev mc intel_rapl_msr intel_rapl_common x86_pkg_temp_thermal intel_powerclamp coretemp amdgpu(OE) kvm_intel kvm crct10dif_pclmul ghash_clmulni_intel nls_iso8859_1 snd_hda_codec_realtek snd_hda_codec_generic ledtrig_audio snd_hda_codec_hdmi snd_hda_intel snd_intel_dspcfg snd_hda_codec snd_hda_core snd_hwdep aesni_intel amd_iommu_v2 amd_sched(OE) crypto_simd snd_pcm amdttm(OE) cryptd glue_helper rapl snd_seq_midi snd_seq_midi_event snd_rawmidi intel_wmi_thunderbolt intel_cstate eeepc_wmi asus_wmi wmi_bmof sparse_keymap video snd_seq snd_seq_device amdkcl(OE) snd_timer input_leds mxm_wmi drm_kms_helper fb_sys_fops snd syscopyarea mei_me sysfillrect mei sysimgblt soundcore mac_hid sch_fq_codel parport_pc ppdev lp parport drm ip_tables x_tables autofs4 uas usb_storage dm_mirror dm_region_hash dm_log hid_generic usbhid hid crc32_pclmul igb ahci i2c_algo_bit i2c_i801 lpc_ich libahci dca e1000e nvme nvme_core wmi

[   40.197208] CPU: 10 PID: 2581 Comm: darknet Tainted: G           OE     5.4.0-66-generic #74-Ubuntu

[   40.197209] Hardware name: ASUS All Series/RAMPAGE V EDITION 10, BIOS 2101 07/10/2019

[   40.197319] RIP: 0010:kgd2kfd_schedule_evict_and_restore_process+0x104/0x120 [amdgpu]

[   40.197322] Code: 5e 5d c3 4c 89 e7 e8 8b 8b 9c dd eb e7 49 8b 45 60 48 89 ca 48 c7 c7 98 55 89 c1 48 89 4d e0 8b b0 c0 08 00 00 e8 87 ff 2f dd <0f> 0b 48 8b 4d e0 eb 9f 41 be ea ff ff ff eb ba 41 be ed ff ff ff

[   40.197324] RSP: 0018:ffffb23342097b00 EFLAGS: 00010086

[   40.197326] RAX: 0000000000000000 RBX: 0000000000000001 RCX: 0000000000000000

[   40.197327] RDX: 000000000000002c RSI: ffffffffa039a5cc RDI: 0000000000000046

[   40.197328] RBP: ffffb23342097b20 R08: ffffffffa039a5a0 R09: 000000000000002c

[   40.197330] R10: 0000000000000000 R11: 0000000000000001 R12: ffff8d6d74941180

[   40.197331] R13: ffff8d6d53a72c00 R14: 0000000000000000 R15: ffff8d6d74941180

[   40.197333] FS:  00007fa4c926c080(0000) GS:ffff8d6d9fa80000(0000) knlGS:0000000000000000

[   40.197334] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033

[   40.197336] CR2: 00007fa2a2b39dec CR3: 0000000fd9fba004 CR4: 00000000001606e0

[   40.197337] Call Trace:

[   40.197456]  amdkfd_fence_enable_signaling+0x30/0x40 [amdgpu]

[   40.197461]  __dma_fence_enable_signaling+0x52/0xb0

[   40.197464]  dma_fence_default_wait+0x9a/0x1f0

[   40.197468]  dma_fence_wait_timeout+0xe7/0x100

[   40.197473]  amddma_resv_wait_timeout_rcu+0x165/0x2e0 [amdkcl]

[   40.197568]  amdgpu_vm_wait_idle+0x2d/0x50 [amdgpu]

[   40.197661]  amdgpu_flush+0x36/0x50 [amdgpu]

[   40.197666]  filp_close+0x37/0x70

[   40.197669]  put_files_struct+0x6d/0xc0

[   40.197672]  exit_files+0x49/0x50

[   40.197676]  do_exit+0x350/0xaf0

[   40.197679]  do_group_exit+0x47/0xb0

[   40.197683]  get_signal+0x169/0x890

[   40.197687]  ? free_inode_nonrcu+0x20/0x20

[   40.197691]  do_signal+0x34/0x6c0

[   40.197696]  ? putname+0x4a/0x50

[   40.197698]  ? do_unlinkat+0x8e/0x2d0

[   40.197703]  exit_to_usermode_loop+0xbf/0x160

[   40.197707]  do_syscall_64+0x163/0x190

[   40.197712]  entry_SYSCALL_64_after_hwframe+0x44/0xa9

[   40.197715] RIP: 0033:0x7fa4d501ae3b

[   40.197717] Code: f0 ff ff 73 01 c3 48 8b 0d 52 80 0d 00 f7 d8 64 89 01 48 83 c8 ff c3 0f 1f 84 00 00 00 00 00 f3 0f 1e fa b8 57 00 00 00 0f 05 <48> 3d 01 f0 ff ff 73 01 c3 48 8b 0d 25 80 0d 00 f7 d8 64 89 01 48

[   40.197719] RSP: 002b:00007ffc18450938 EFLAGS: 00000246 ORIG_RAX: 0000000000000057

[   40.197721] RAX: 0000000000000000 RBX: 00007ffc18450960 RCX: 00007fa4d501ae3b

[   40.197723] RDX: 0000000000008000 RSI: 00007ffc184509e0 RDI: 000055d2a30151f0

[   40.197724] RBP: 000055d2a30151f0 R08: 0000000000000001 R09: 0000000000356988

[   40.197726] R10: 00000000603df483 R11: 0000000000000246 R12: 0000000000000001

[   40.197727] R13: 00007ffc18450ad0 R14: 000055d2a32b2d60 R15: 00007ffc18450ae0

[   40.197730] ---[ end trace 6da5327e722160ce ]---

I contacted to AMD support because it does not work! no good answer so far... I am mean after 10 days I was asked for more info and no resolution, maybe next driver version will solve it

gdb for my case shows

Thread 2 "darknet" received signal SIGABRT, Aborted.

[Switching to Thread 0x7fffe9535700 (LWP 4426)]

__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50

50 ../sysdeps/unix/sysv/linux/raise.c: No such file or directory.

(gdb) where

#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:50

#1  0x00007ffff55aa859 in __GI_abort () at abort.c:79

#2  0x00007fffe959d773 in  () at /opt/amdgpu-pro/lib/x86_64-linux-gnu/

#3  0x00007fffe95dc18f in  () at /opt/amdgpu-pro/lib/x86_64-linux-gnu/

#4  0x00007fffe95a1a4b in  () at /opt/amdgpu-pro/lib/x86_64-linux-gnu/

#5  0x00007ffff7e43609 in start_thread (arg=<optimized out>) at pthread_create.c:477

#6  0x00007ffff56a7293 in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

It is definitely a BUG!

There is one more thing...

after change in /etc/default/grub run the

sudo update-grub


sudo reboot


if you are really hacker of GPU drivers after you installed it you may go to the

cd /usr/src/amdgpu-

to change anything you need and to rebuild it and try run two commands

sudo dkms remove -m amdgpu -v -k 5.4.0-66-generic

sudo dkms install -m amdgpu -v -k 5.4.0-66-generic

and you fix the AMD driver wizards error :D... unfortunately I am not so smart

so I am waiting on the fix :D.