Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD USB 3.0/3.1 Issue B450M

Basic Specs: 
AMD  Ryzen 5 2600 Processor 

Ram: Vulkan TForce 8GBx2 DDR4 @3000mhz

Motherboard: ASRock B450M Pro4(AM4)

Graphics: Sapphire RX580 Graphics Card. 

WiFi Adapter: Realtek 8812BU Ac 1200 Wifi Dongle
SSD: Intel 660p 512GB NVME m.2 PCIEx4

OS: Windows 10 64bit

PowerSupply: Rosewill Hive 550W PowerSupply 80+ Bronze

I am having an issue getting a WiFi Adapter to work on this Desktop properly. It does not have full throughput @ max ISP speed of 150Mbps. I only get half of that at ~75Mbps. I have updated the Bios to the latest version 3.50 that my CPU supports. I have updated the chipset drivers to no effect. I have tried the USB 3.1 and 3.0 ports front and back to no effect. Tested this dongle on my Intel Laptop and I get the speed I should be getting at 150Mbps. Both the AMD Desktop and the Intel Laptop are using the same WiFi Driver version 1030.27.425.2018 with the same settings.

The only difference between the Intel Laptop and the Amd Desktop is the USB Drivers. The Intel Laptop has Intel Drivers vs AMD Desktop using Microsoft Drivers for the USB Controllers. I have tried finding drivers for the USB controller of this motherboard but there are none. I only see AMD made drivers for older motherboards before Zen Architecture. It seems AMD has left the drivers for newer motherboard models to Microsoft.

Is there something I can install driver wise to remedy this? 

*Note: When I tether my phone to the Desktop for internet I can get faster speeds almost to max bandwidth available through my ISP. Though a USB driver is installed to support this -> Samsung Mobile USB Composite Device under USB Controllers.


0 Replies