Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Software Installer not launching

Had some problems with the drivers on my pc and had to reinstall them, I used the cleanup utility tool to delete the drivers and restarted my pc. Everything had gone smoothly so far, but when I tried to re-install my drivers the installer never launched. I've tried with the auto detect and install tool but that still doesn't start. Can anyone help me?

2 Replies
Journeyman III

I have been having the same issue ever since I upgraded to windows 11 two months ago. I have contacted support numerous times and have not heard back. I know this isn't helpful, but I am also having the same problem. I will keep checking this forum to see if any fix has been found. Good luck!


It will be helpful to know your PC information including Make & Model of your GPU, CPU, Motherboard, and both AMD and Windows versions you have installed or tried to install.

Also you need to post whatever error is showing when the AMD Driver failed to install.

Look in Device Manager and see if you spot any errors there.