cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ming019
Journeyman III

AMD software cannot launch

After installing the AMD Software, it is able to start.

However, there will be an item "Advanced Micro Devices, Inc. - Display" REQUIRED in Windows Update.

And when it is updating, the screen starts blinking then turns out black. Yet it is not frozen as it responds to Caps Lock(Tho I have to force shutdown it)

And, every time I start AMD software it will say "Radeon Software and Driver version does not match"

All I can do is reinstall it. However, the Windows Update will appear again and AMD Software will also unavailable again

I've tried editing the version number in Windows regedit while it won't work even after a reboot.

I'm using ASUS TUF A15, with 4800H and 2060.

0 Likes
2 Replies
hrpuffnstuff
Adept II

Re: AMD software cannot launch

 I run a 5800h/ rtx 3060 combo and I use the amd radeon control center 21.5.2, same as my desktop, along with the nvidia laptop gpu drivers suite that I get via geforce experience.  In the past when the control center stopped working I ran the amd removal tool to get all of the gpu drivers out and then reinstalled it.

You might even check to see if you have corrupt system files and have windows repair them.

0 Likes
ming019
Journeyman III

Re: AMD software cannot launch

Thanks for your reply, I know but it could be solved by reinstalling but is problematic!

Every time I installed the driver from AMD, Windows Update will get another version for the driver, which results in AMD Software, not opening.

I have to pause the Windows Update that I won't need to reinstall.

Is there any alternatives?

0 Likes