Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

AMD Software Adrenalin Edition not compatible

New with you, François I am 64 years old
When I bought this pc 1 month ago there was AMD Radeon Software installed, yesterday I installed AMD Sotware Adrénalin Edition without any particular problem and it worked well but this morning when I wanted to open AMD Software Arenalin Edition that tells me that it is not compatible with my system ???
1) AMD readon software and AMD Sofware Adrenaline Edition is the same thing.
Could you help me. Thank you

My pc: Device name LAPTOP-V47TPK47
AMD Ryzen 5 4600H processor with Radeon Graphics 3.00 GHz
Installed RAM 16.0 GB (15.4 GB usable)

System type 64-bit operating system, x64 processor

Windows 11 Home Edition
Version 21H2

1 Solution

It is probably Windows update has installed a driver..

It is a common problem, I just downloaded and reinstalled AMD Adrenalin over the top..

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.

View solution in original post

18 Replies
Adept I

Check windows update, reboot, Reboot... check chipset driver update.. check firmware for motherboard. Go to AMD and roll back ur driver... basically reinstall an older version of the radeon software. Sometimes the updates dnt pertain to the games or is you use and are specific but fixes that are for like 10 people on some dumb game that's not halo. Also check under applications/ additional app features... there an AMD security addon/update. Non of that works, uninstall adrenaline, reinstall...  make sure it bios is tpm 2.0... route tpi to fpm. Uninstall last windows 11 update.... join with dows insider and upgrade. Ummm one of those should have you back on track. Reset with windows, windows 11 is a little unstable just keep mashing that system update button. And clear the tpm module.


It is probably Windows update has installed a driver..

It is a common problem, I just downloaded and reinstalled AMD Adrenalin over the top..

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.

Thank you and what solution to solve the problem, many moreover among other things the mouse for example


 I update to 22.5.2 nothing works it not compatible so I go back to  22.5.1 which works the best but even though I have it set to manual updating from AMD Software Adrenalin Edition and turned off the  Windows 10 updater as well the AMD software will always updates me regardless to the version that's not working which is 22.5.2 

What I want to know is do I need to have this soft ware in my laptop since it's for my IGPU? I run a RTX 3060 for the gaming.

Adept I

7/14/22, Radeon 6600M on an MSI Alpha 17 laptop, Windows 11.  

This problem started happening to me with the newest update, 22.6.1. I've applied the official fix of stopping Windows auto update and reinstalling the drivers, described here:

The official fix is a workaround and is very onerous, as uninstalling and reinstalling the drivers can be very time consuming. What I've done that works is by reinstalling JUST THE DRIVER, NOT THE ENTIRE PACKAGE. 

You can do this through the following steps on Windows 11:

1. Right-click the Windows icon and select Device Manager 

2. Look through the list of devices and click on Display adapters. You should be looking at the name of your graphics card, in my case it would say AMD Radeon RX 6600M. 

3. Double-click on the name of your graphics card. A smaller window will pop-up that contains the graphics card properties. There are 5 tabs at the top, click on the second one that says Driver

4. The Driver tab will show the name of your graphics card at the top and a bunch of information about the currently installed driver. There are 5 wide buttons on the bottom-left with descriptions to the right of them. Click on the second button, Update Driver

5. A new window will pop-up asking "How do you want to search for drivers?" Click on the second option, "Browse my computer for drivers". 

6. The next window that comes up that says "Browse for drivers on your computer". At the bottom of this window, it will say "Let me pick from a list of available drivers on my computer". Click on this option. 

7. This next window says "Select the device driver you want to install for this hardware". In the middle of this window is a box that says "Model" and will probably have multiple listings here. You can tell which driver is which by the driver version number shown and the date. There will probably be at least 2 drivers showing, pick the one with the newest date and click on Next. THE DRIVER YOU SELECTED WILL BEGIN TO INSTALL. Windows may freeze or flicker for a few moments, depending on your particular setup. Once it finishes, you can close out the window. AMD Software: Adrenalin Edition should have started up automatically and should be running now. 

This will probably keep happening until AMD corrects the issue, but my solution is a lot faster and does not require multiple reboots or downloads. 

Hope this helps. 


DUDE!..... You have taken a process that was taking me hourse to do every couple of days, to 5 minutes. 
This makes the entire issue SO FREAKING EASY!   AMD should have you on payroll, why couldn't these instructions be
anywhere in the 5000 pages of information I have been reading to find a work around?!   Thank you so freaking much!  

Thanks! So far I haven't had the problem return since I did this. I hope you have the same results. 

Even after 2 years this solution has helped me so much. This is way faster than redownloading this software. Thank you.

Journeyman III


I was facing the same issue and tried all the solutions in this post and many other ones I found on the internet (some involving tweaks in the registry) too but none worked for me and I was really frustrated because this problem started occurring in a new laptop I bought less than a week ago and this was my first computer with an AMD processor. Luckily I came up with a solution which is a combination of some of the solutions I found from all over the internet. So just some background info, I am running an HP Pavillion 15 laptop with an AMD Ryzen 7 5700U processor with AMD Radeon graphics on Windows 11 Home 22H2 (dev channel). The problem that I think is happening is that Windows 11 update is incorrectly choosing the AMD drivers for my hardware, therefore the update installs a driver not compatible with my AMD hardware. Now let's get to the solution 

1. Got to Settings, then Windows Update then click "Pause updates" with the option selected "Pause for a week."

2. Download and install AMD Cleanup Utility and run it.  It will ask to allow it to reboot your computer in Safe Mode, allow it and follow all the prompts, and allow it to complete its task. 

3. Now download and install wushowhide.diagcab this tool is provided by Microsoft to stop windows update from updating certain drivers. You can find it here

4. Your browser might try to block you from downloading it saying this might be dangerous but don't worry this is completely safe and provided by Microsoft.

5. Once you run it select the option "Hide Updates" and then check all the boxes that have anything to do with AMD. After that click "Next"

6. Now restart your PC

7. Go to AMD Drivers and Support website and download and install "Auto-detect install for Windows 10/11"

8. Run the AMD Adrenaline and let it automatically detect and download the appropriate drivers for your computer. 

9. When everything is done restart your computer once again and go to Windows Update and click Resume Update and that should solve your problem. 


I have the same problem,when i first got this PC it had Radeon Software in it,it was not adrenalin edition it was just radeon software,when i updated to win11 i downloaded adrenalin edition and it has this compatibilty issues. I want the old radeon software back,in adrenaline version i cant see my fps by doing ctrl+shift+o and it does not work after some time. I just want the old software back where can I find it please? I do not want the adrenalin edition

Journeyman III

 I downloaded the updater and got "AMD Software not compatible."

Turned off auto updates  Control Panel/ System & Security/System/Advanced System Settings/ clicked No Updates still AMD window pops up.


Adept III

I had to reinstall and older version to get mine to work, I don't look forward to doing updates which is the reason I am on and older version of the software.

Journeyman III

Please point me in the right direction. This is terrible. I don't think I use the Radeon Graphics since I have a  NVIDIA GeForce® RTX 3060 Ti 8GB PCI Express Video with its own driver.


I have

Device name StudioDesktop

Processor AMD Ryzen 7 5700G with Radeon Graphics            3.80 GHz

Installed RAM 32.0 GB (31.4 GB usable)

Device ID A9C8AFAC-814A-419D-A259-7C071E111BA2

Product ID 00355-60710-53065-AAOEM

System type 64-bit operating system, x64-based processor

Pen and touch No pen or touch input is available for this display


Display Driver NIVIDIA GeForce RTX 3060 Ti


On a 


PowerSpec recommends Windows.

PowerSpec® G709

Use the links below for in-depth information on the specifications shown.


AMD Ryzen™ 7 5700G processor

OS Windows 11 Pro 64-bit

System Board ASRock X570 Pro4 System Board

System Memory 32GB DDR4-3200

Hard Drive 1TB NVMe Solid State Drive

Video NVIDIA GeForce® RTX 3060 Ti 8GB PCI Express

Sound Integrated 8 Channel HD Audio ALC1200

LAN Intel® Integrated 10/100/1000 Ethernet

LAN Dual Band Wireless B/G/N/AC/Bluetooth

Software ESET Internet Security Trial and Microsoft Office 365 Trial

Power Supply 750 Watt 80+ Gold Modular Power Supply

Keyboard Standard Keyboard

Mouse Optical Scroll Wheel Mouse

Warranty 1 Year Limited Carry In Warranty


Two possibilities here, one is Win overriding driver & and the other is updater can't see AMD graphics with the 3060 in use.

Post an image of the error pop up. 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

AMD Popup.jpg

Thank you.


yes we all get that and usually the link goes to nothing.


As you're not using the 5700G graphics, uninstall the amd software (not the chipset software) from windows uninstall a program.

If you're wanting to update chipset drivers it has its own standalone installer (unless you prefer only drivers from mobo maker). 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
Journeyman III

I uninstalled the 


and the pop up stopped. Thank you.