Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Software: Adrenalin Edition 22.3.2 & 22.3.1 crash during install


i tried to install the Driver Pacakge on the Website from AMD, and have every time the same issue, during the installation my PC restarts and try to repair it self. I should every time start with secure boot and uninstall all display drivers.  


1. i tried autodetect and install the new adrenaline driver. -> same issue

2. install Win 10 - 64Bit adrenalin driver 22.3.1 -> same issue

3. install Win 10 - 64Bit adrenalin driver 22.3.2 -> same issue

4. install Win 11 - 64Bit adrenalin driver 22.3.1 -> same issue

5. install Win 11 - 64Bit adrenalin driver 22.3.2 -> same issue

6. install only driver of the different versions -> same issue

7. complete new install Win 10 Pro 64 Bit -> update all windows Updates -> Version 21H2 Build 19044 1620

After this i tried all steps and version from 1 to 6. -> same issue

8. Mainboard ASrock Z390 Extreme4 Bios Version 4.30 -> reseted to default settings and tried again the steps above -> same issue.


My GPU is a Sapphire 6900XT, with GPU-Z i see only microsoft display driver. 

5 Days ago all worked fine, with old driver from last year.

Do you have an idea what can i try next? 


Thank you. 

14 Replies
Adept I

I'm having the exact same issue with an RX 6600 8GB, i7-11700f, ASRock B560m-c motherboard.

I had the same issues with the 22.2.x "optional" updates as well. The only solution i have found is to remove the drivers and re-install 21.10.2.


As this is an Intel motherboard, before installing the new AMD driver package..

Check if there are any intel drivers and chipset drivers that need updating..

Go to the Intel: Intel® Driver & Support Assistant

Also check motherboard manufacturer website for chipset drivers etc.. 

AMD Ryzen 7 3700x, Asus Tuf Gaming RX 6700 XT, Asus TUF Gaming x570 Plus, 32gb G.Skill TZ neo 3600mhz, Samsung 980pro 1tb NVME, Samsung 970 EVO Plus 1tb NVME, Lian Li Galahad AIO 240mm, Antec Titanium 1kw.
Journeyman III

Hello, i have fixed the issue for the first.

So what i have made since the last steps:


9. Install Win 11 -> try to install the adrenalin driver -> first time i see a black screen

Memory Management Issue

10. Check drives  with different tools -> no issues on drives

11. try to play Dying Light 2 (because win 11 have installed a driver of the last year) -> dying light 2 crashes with a blue screen after 5-10 sec. i started so after the techland screen. 

Memory Management Issue

12. tried only with one RAM Module -> so i can play Dying Light 2 without issues

the i added 2nd RAM and can play, added 3rd RAM and can play, added 4th RAM MOdule and can play. no issue

So all RAM MOdules are installed and no issue. 

13. i try to install Adrenalin and it works without issues.


and now i tried to connect my 2nd display during the game -> bluescreen. memory management issue.


At the moment i think the Adrenalin driver have issues with two displays, because after the issue a changed the display and tried again. the issue is with 2 displays, AMD should look on there driver. 

Give me your feedback, for the first i can play until a solution comes from AMD.


Thanks for the update. I only have one monitor connected via HDMI . I still can't get it to work but did make a little progress.

Starting at 21.10.2 I updated each optional update one by one:

21.10.3: Installs & Works

21.10.4: Installs & Works

21.11.1: Installs & Works

21.11.2: Installs & Works

21.11.3: Installs & Works

21.12.1: Installer causes display to go black (my display shows an "out of range" message), PC shuts down on its own, and then restarts several times (boot-loop) until reaching the blue troubleshooting screen. Then I enter safe mode and uninstall with DDU and all works again.

So whatever the issue is, it was introduced in the 21.12.1 optional update and still has not been resolved.

Please, AMD. Fix this!

I have an rx 580 and an rx 550 I was working in the last one with OBS in extended screen, then I returned to a screen and opened OBS then the 22.3.2 driver crashed completely, I restarted and the driver did not load I had to uninstall it and reinstall the version 22.3.1, now I am testing this version on double screen.


For anyone wondering, these 22.3.X drivers are absolutely fu***ng terrible. So many reported issues.

I rolled back to 22.2.1 and everything is cool for now.


Another issue I found, with the newest Adrenalin driver I cant run my RAM with xmp 2.0 Profile. 


edited: nevermind, just dont see the button to delete the message

Adept II

Hey guys, i share the same problem!

6800XT and since all drivers above 21.11.3 my windows crashes within the installation process and it tries to repair and i have to reinstall windows LOL...


Please AMD see this -.-

Adept II

did you find any fix yet? im tired of trying and having to reinstall windows everytime


Hello, I dont Know hiw I fixed it. 

1. Checked every RAM Module seperatly 

2. Disconnected 2nd Monitor 

3. Installed win 11 

Now it worked and I have no issues. 

AT the moment I think one of These was fixing my issue. 



Disconnecting 2nd monitor fixed it!!


Unfortunately, I only have one monitor connected via HDMI. It's a cheap 1080p Sceptre monitor I got about four years ago.

I tried updating again today with the latest 22.5.1 recommended update but, this time, I also tried disconnecting the monitor once the installation began, but it would not complete until I plugged the monitor back in and then same old boot-loop issue.

Does your secondary monitor work once reattached after the driver update? Is your secondary monitor connected via HDMI or DisplayPort? I wonder if the issue is something to do with the monitor itself, perhaps the way my monitor communicates via HDMI. That's really the only thing I can think of at this point.


Just a somewhat positive update: the issue seems to be the way the driver updates beginning my with 12.21.1 interact with some monitors.

I first experimented using a HDMI to DisplayPort adapter to see if the issue was with the HDMI port on the card, and had the same boot-loop issue.

I then hooked up an old Apple Display with a DVI to DisplayPort adapter and it updated with absolutely no problem. As soon as I reattach my Sceptre monitor with HDMI the PC crashes and enters the boot-loop and the necessary removal of the driver in safe mode.

So the good news is that it’s not the card or anything to do with Windows; it’s something wrong with the driver. The bad news is that I guess I’m stuck with 21.11.3 unless I get a new monitor OR AMD fixes the issue.