cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

jarellano
Journeyman III

AMD Setting won't open

Hello,

I recently purchased Vega 56 and updated drivers to 18.12.3 from the website. Every time I try to launch AMD Settings an icon will appear on the system tray and when I mouse over it, it disappears. Does anyone have the same problem? I've thought of rolling back drivers, but I've no clue on how to do so.

0 Likes
6 Replies
dannyboyqw
Journeyman III

Re: AMD Setting won't open

Hey man, I have the same issue, I updated my 460 to 18.12.3. now I can't open the settings. :/

0 Likes
meyerrlf
Journeyman III

Re: AMD Setting won't open

Hi,

same problem here with RX 580 and driver version 18.12.3

0 Likes
kingfish
MVP

Re: AMD Setting won't open

Driver issues should be reported to AMD > Online Service Request | AMD

0 Likes
mlxg56
Adept I

Re: AMD Setting won't open

uninstall the drivers via ddu and in windows safe mode ---> disable your antivirus ---> install new drivers

Fixed the issue for me

0 Likes
taxus
Journeyman III

Re: AMD Setting won't open

Just fixed this (AMD settings not working / opening) after a lot of trial and error on my system (i5 9600K, Vega 56 &  MSI Z390 Carbon AC)  and the only fix for me was to alter 2 BIOS settings:-

  • Initiate Graphics adapters: [PEG] to [IGD]
  • Internal Graphics: [Auto] to [Enabled].

Not sure which of the 2 changes above fixed the issue, so only one change may be needed. But as all is running fine so I’m loathed to change anything else.

dannyboyqw
Journeyman III

Re: AMD Setting won't open

Hey, thanks for looking into this, I decided to take a look into this again and it seems for me enabling IGPU multi-monitor in the bios fixed the issue. 

Thanks!

I5-6600k, Radeon RX 460, Asus LGA1151 

0 Likes