Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Ryzen Master Threadripper Setting Don't Work After ReBoot

my problem is after applying Gaming Mode or Creator Mode after reboot setting don't apply keep telling me same thing over and over again.

how you fix ?

1 Reply
Journeyman III

Re: AMD Ryzen Master Threadripper Setting Don't Work After ReBoot

- Have you made any manual changes to settings in the UEFI?

- Which motherboard do you have?

- Which BIOS version do you have?

- Have you tried clearing your board's CMOS?

- Do you have the latest threadripper chipset drivers? X399 Drivers & Support | AMD

- You said it keeps telling you the same thing over and over again, what does it tell you?

- Ryzen Master asks you to reboot when you change profiles, then it applies the profile at the next boot and that profile will stay applied until your next reboot. If you reboot once more without using Ryzen Master again to set the profile, your CPU will boot with the default settings (or with the settings configured in your UEFI). So Ryzen Master, unlike the UEFI, does remember your profiles but does not automatically apply them. So is that the problem you're having, or are you saying that Ryzen Master never applies the profile at all to begin with? How exactly are you testing that? When you enter Ryzen Master, regardless of whether you have a profile applied or not, your current stats will still be displayed under the Current tab. So it might be hard to tell if the profile worked or not, if the profile you applied isn't very different from the default configuration. If I remember correctly it doesn't show you that you applied game/creator mode. But if you didn't change any settings in UEFI and you have the correct drivers and a working BIOS, then you should be able to tell by the CPU clock speeds. By default the threadrippers have precision boost enabled, and with windows' balanced power plan you should see each core alternating frequently. Not sure about the 1900x and 1920x but my 1950x alternates between 2.2 and 3.7ghz on balanced power with default settings, and some cores will briefly jump to 4 or 4.1ghz. If I set one of AMD's premade profiles in Ryzen Master then I should not see any alternation at all because this method of overclocking disables precision boost. I think the default rate is 3.6 or 3.7ghz? So that should be stable if it's working.

- Anyway, in my opinion Ryzen Master isn't really the best way to overclock threadripper. Unless all you're trying to do is turn on "legacy mode," which disables one of the dies, your UEFI settings should be both faster to configure & test and far more powerful/extensive. For example you may want to change BCLK frequency which should, depending on your board, allow you to increase clock speeds without disabling precision boost. Or if you want to manually increase clock speeds and voltages then you may want to increase the BCLK even if you're going to have to disable precision boost anyway, because increasing BCLK usually increases the stable cap for clock speeds on threadripper. And another thing, this has gotten a lot better over the last 2 months with AGESA updates but threadripper can be really finicky with memory profiles. When I first built my system I had to run my 3733mhz memory at 3200mhz, because the XMP profile was totally unstable with the BIOS version I had. Later on I figured out a memory setting that would let me increase to 3600mhz. And then just this week a BIOS update let me get a stable 3733 with the same settings. Couldn't do that in Ryzen Master, I think it allows you to change XMP profiles but like I said, it seems like you need to manually change some settings to get higher speeds to work, and you can only do that in your UEFI. I think the only thing Ryzen Master is good for is the legacy mode, since there is no setting like that in any UEFI I know of, you'd just have to manually disable half the cores, which is totally doable but takes longer than just ticking legacy mode in ryzen master.