Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

AMD Ryzen Master VBS Error

I have installed an update from AMD Ryzen Master version to When I start the program I always get the error message:

Ryzen Master VBS Error.PNG

the old version did not have these problems and starts immediately. Only the update of Ryzen Master has been installed.

System Parameters:

Mainboard: ASUS X370-Pro @ BIOS 4008,

CPU: AMD Ryzen 1700,

Windows 10 1709 (10.0.16299.371)

Microsoft Hyper-V installed

188 Replies

use your motherboard bios. Ryzen master is not the only way you can overclock and you can monitor system temps with hwinfo.


sharktooth do you think nobody knew that?    Ryzen-Master presents a option to overclock in real-time. 


well, you can also use p-states overclock if you're concerned about power consumption while the pc is idling. there is almost no need to have a real-time oc if not to fast-find good values for a stable overclock.


I think most of us here know how to overclock, but that is not the point.

The point is AMD is advertising features and software of the TR that are useless if you do virtualization.

We all know how to OC thru BIOS but we just want AMD to fix RM.

Even if overclocking is not working with VBS enabled for some (yet to be known) security reasons, some functionalities should work (dynamic mode for TR, CPU monitoring).

Having to use 3rd party apps like ProcessLasso to do this job is not great

the problem probably lies in a windows update... solo better ask Ms to fix their stuff


In which world does this have to do with windows updates ? VBS is a security isolation feature making use of Hyper-V to ensure OS integrity.

have you  read the thread?


It's not MS responsibility that AMDs software doesn't run because MS tightened VBS in an update.

If AMD were willing to fix this, they could have done so in corporation with MS a long time ago. But I'll bet they haven't event startet on a fix and much less contacted MS.

excuse me for expecting the software provided by the manufacturer to just work.

In my job, I loose money if I have to debug and read threads on why a thing that should just work, no longer does. 

This is a lack of respect towards the buyers

Adept I

Still rather annoying that it did work, and still does work with Hyper-V and VBS enabled if you run version 1.2.0540.

Even more so when I was trying to use TR desktops as a way of getting my firm interested in moving to Epyc based systems to replace our older Xeons. This bug did quite literally make our CIO pass and stick with Xeon, since the logic was "if they can't even make their own software work with one of the main uses of their hardware, why would we trust them with our production systems?". I'm aware that a few million is neither here nor there for AMD, but still.

Adept I

Lets go over some things since today is inbox spam day!


1: if the moderator's aren't properly enforcing guideline #7 and a specific user is being disrespectful/trolling/spamming*, you can do like I did use an addon in your browser of choice and filter out his comment box's, then create an email filter if you are subscribed to email reply's for this thread, to delete any with his name as the subject, problem solved!

Now for the facts (as we currently have proof regarding*) that matter!

2: This impacts MORE then just developers, so using the argument that it shouldn't be used by developers is pure ignorance, this also impacts 1 existing major security feature (Windows Defender Application Guard)  and one upcoming major security feature (currently called windows 10 security sandbox, which is  much like sandboxie), BOTH fall under the VBS or Virtualization Based Security umbrella.

     Consider any arguments on Ryzen Master having this issue and working "as intended" as pure FUD and ignore until PROOF is provided.

3: To further my statement above, with my old 1600 and Ryzen Master v1.2, I was using Hyper-V for testing, and had the SECURITY feature's enabled and encountered ZERO ISSUES, to further this fact, I have attempted to scour the web after AMD's reply about there being an issue between the two, and I have not found a single shred of evidence of an actual PROBLEM between the two, so, at this point, I am treating AMD's reply as FUD.

4: Ryzen Master is an Application + Driver combo, so any posts saying it isn't, well, that's simply someone who doesn't know what they are talking about replying in order to troll/spam/disrespect and should get deleted if the moderator's are following guideline #7 for the fourm's

5: Ryzen Master controls more then just overclocking, and over half of those features are NOT able to be set in BIOS!

6: Forum moderator's will moderate posts without following the guidelines to inform why a post was moderated in the first place, thanks for the insider who tipped me off to what MIGHT be causing the moderator's to do this, I can only hope they soon enforce guideline #7 for the forums so posts like mine don't start off with extreme annoyance! EDIT: Then when I fix it, one moderator approves it, then another reject's it 2 hours later... still no reason given...

*I welcome information that would allow me to replicate an issue with Ryzen Master v1.2 and Hyper-V or any of the VBS feature's to change the facts as we know them.

Adept II

So with the trolling out of the way, maybe we can focus on how to get AMD to fix this instead of ignoring the problem?

Look, all I want is a proper way to read CPU temperature off my Ryzen 2700X and TR2990WX CPUs. HWInfo is not compatible with either CPUs or the X399 or X470 chipset. The BIOS is giving me scary 60-80 degrees celcius readings and I don't know what to believe. I've been told to subtract 20-30 degrees but I don't know who to trust. I just freaking want a way to make sure my 8000 Malaysian ringgit CPU isn't going to spontaneously melt. But I need Ryzen Master just to get a temperature reading, and Ryzen Master isn't going to work at all, not even just to give me temperature readings of the CPU, with Hyper-V installed. Which I do need because apparently you need Hyper-V if you develop Android apps using Visual Studio.

That's it. All I want to know is the CPU's current temperature. I don't want to overclock. But apparently even getting a temperature reading is too much.


Hwinfo64 has had support for 2nd gen Ryzen since December 2017, a full 4 months before they even released and they often add support for cpus while they're still engineering samples long before release. I'm using it with my 2950x and x399 MEG Creation right now. Are you sure you're installing the right application?


There's 2 temp readings for Threadripper, Tctl and Tdie. Tctl is +27C offset over Tdie. The offset is something that AFAIK is baked into Zen in general to keep servers that may have very dumb fan control in BIOS from overheating due to not responding quickly enough to multiple 8 core dies on the same package hitting 100% load.

Somehow I have a feeling that the Ryzen Master VBS problem is coming from the need to access something low level to actually apply Precision Boost Overdrive settings. VBS sort of segregates the OS from the hardware so I wouldn't be surprised if that is interfering with Ryzen Master. The problem is I sort of need to use Hyper-V and I would vastly prefer to use PBO over an all core manual OC because:

  • I'm losing single threaded performance
  • PBO tries to keep temps under 67C and that must be for a reason
  • even with coolant temps at 26C(over a meter of radiators) I can't keep CPU temps below 75C @ 1.38v
  • I've had an 1800x degrade the the point of being almost useless from what was considered the upper end of safe voltages

But when I apply PBO in BIOS it doesn't actually set the EDC limit to what I set it to, it just reports to Ryzen Master that X amps is what the board can support. I still have to actually open Ryzen Master and set the EDC to the max limit from the 280 amps that it boots up at. So yeah, I can't get the most out of this CPU while Hyper-V is installed.


hwinfo is working pretty well.

Tdie is the correct core temp.

just completely ignore Tctl.

Journeyman III

The latest also still  throws the error message.

Adept II

And another month passed without AMD resolving this issue


It's not a issue. It's documented properly on their reference guide. Does it suck? Yep. 

It's officially stated in their QRG: "Windows 10 Virtualization-Based Security must be disabled for Ryzen Master to function."

2018-12-20 10_21_49.png

You need to find another competitor, if it matters that much.

Who are you to judge if this is an issue for me or not?


It's in the QRG - hardly a place anyone looks for serious incompatibilities. 


And what other software vendor would you recommend? I really can't see how a new software would help me in any way.

Edit: Oh, now you actually edited your reply so it makes sense: Recommending a competitor instead for new software. 


Ya, its pretty sad...

Not to mention the question on WHY this is AN ISSUE with versions AFTER v1.2, is NOT actually answered, I will make it easier and break it into two that only requires one to be answered:

Why does Ryzen Master v1.2.x with Ryzen 1st gen STILL work fine with VBS and Hyper-V (this is the issue BTW, the unanswered one).

What does Ryzen Master v1.3 and higher BREAK that disallows us to have a system that cant use Windows VBS?

Right now the WORKAROUND is, go to "a competitor" or stick to Ryzen Gen1 with Ryzen Master v1.2 (which again, is till working fine for me in Windows 10 1809 with VBS enabled an in use!), does AMD hate security that much seeing all the different things that VBS offer's (to plug Microsoft's already existing vulnerable platform, but still, its SOMETHING for security!)

Security AND Ryzen Master all thanks to the older version, is just a disappointing tag-line from AMD

Adept I

After updating to Adrenaline 19.2.2 for my RX580, I could no longer OC my 1950X to 4GHz.  System freeze/hang on every try.  I've been using the old v of Ryzen Master since I occasionally use Hyper-V.

So I finally upgraded to the latest version of Ryzen Master, configured everything and rebooted, saving a setting profile in my BIOS, uninstalling and reinstalling Hyper-V.  Sadly, I still cannot set the ceiling of my cpu to 4GHz.  Before, it would automatically still handle voltage accordingly.  I'm using an Enermax Liqtech TR II 360, so cooling is not an issue.  Furthermore, I leave my Windows Power Profile set to Balanced.  While I rarely see a core clock to 3.9GHz, most of the time the ceiling is 3.7GHz.

Ultimately, the greatest lament is not being able to run lastest Ryzen Master while Hyper-V is installed.  It's very silly to spend such great amounts on pro-sumer hardware and be limited in such a manner by Ryzen Master.

My MSI Pro Carbon AC motherboard came with some utility called Command Center, but it doesn't seem to actually apply any settings I attempt to test.  Are there any other Threadripper clocking utilities?

Adept II didn't solve it...


I have noticed this thread is fairly idle.

Just curious, Ryzen Master is generally considered to be the best software to monitor your Ryzen Processor.  Since you can't install or activate Ryzen Master with Hyper-V activated, how do you all monitor the Ryzen Processor's temperatures and voltages? 

Has anyone found a Hardware monitoring 3rd party software that gives accurate Ryzen temperatures similar to Ryzen Master?


hwinfo is your friend. 

for temperatures look at the Tdie value

Adept I

Does anyone have a working link for 1.2? I've searched for a while and everything that pops up is either a download for a newer version or links right back to the AMD site for the latest version, and unlike most of their drivers, there's no link to older versions of RM on the AMD site.


I am also looking for

Someone must have that file archived somewhere, this is the internet after all.


I found three sites (one in French) that had downloads for that particular version of RM

All three websites when I click to download I received the error "No File Found".

The only way, in my opinion, is if someone from this thread uploads a copy to a file sharing website so others can download it.

I have personally used File Sharing Website : Simple File Hosting -  which is free so far to use. It is a little bit slow but very useful.

You upload the files your want. You can even put a limited time span for downloading. Once the file is uploaded, the Website give you a link to download it automatically.

I have used it several times here at AMD Forums.

NOTE: My Anti-Virus and Browser security extensions (McAfee & WOT) shows no warnings for this website.


I got this from some "old versions" website last August 2018 and have used it without any discernable issue.  Scanning at shows nothing on 15 antivirus engines.


MD5: c890e993b20db20b081b23f424c04322

SHA-1: 86ec829b31e2553096a0b30474d86f998d2f2484!dg1DxQQY!2FaXMH_dWUEapsU8-3JxHXURN3HvZpZEn-I74mEMMGk


Currently, I just disabled Hyper-V, made my settings on latest Ryzen Master, rebooted to BIOS, saved a profile there, then booted back to Windows and enabled Hyper-V.  On the rare occasion I have a crash, my settings are defaulted to basic memory speed, so I'll just boot to BIOS and reload the profile then it's back to Windows for business as usual after momentarily confirming with HWinfo64 everything is where it should be.

I'd still prefer AMD would allow latest Ryzen Master to be run again while Hyper-V is enabled.
If it was some big security issue, that would be more acceptable, but we haven't heard anything to that effect.

Just tested the first link, Media Fire, and it downloaded the version the other User wanted.

At least, now other Users can download the last version that worked with Hyper-V enabled. But it may not work for all Ryzen processors which may require a newer version.

Journeyman III

Built a 2950x, installed Hyper-V, got tech support, this. Just adding myself to the list of people irritated by this...

Adept II

Based on the new feature of 1903, I see that enabling the Sand Box virtual feature without having Hypervisor installed will also block Ryzen Master .

Seems like Windows Sandbox uses Hyper-V for its function according to this article: 

Good observation. But I imagine once RM is fixed and works with Hyper-V and will also work with Sandbox. Unfortunately if Sandbox is not a feature you can disabled, then that means RM won't work for anyone with the latest version of Windows 1903 that has installed Pro version and above.

Sand Box feature is not installed by default, I enabled it myself through the additional software control panel. So you can disable it as well again. 

But since quite some Windows security features depend on Hyper-V, it would be great to have Ryzen Master support this. 

Journeyman III

I run windows 10 pro for workstations x64 and I don't have hyper-v enabled at all

and version still gives me a vbs error

widows insider 18396.1000

amd ryzen 3900x

gigabyte x570 utra


You're running an Insider build. First check if there is yet another new feature based on virtualization activated in this build (like Sandbox). 


I got it to work by disabling windows sandbox

then changing the secure boot setting in my bios from custom to standard

it opened after that

Journeyman III

I am joining in on this. Maybe it will be fixed some day.

Just built a 2950X and am bummed Ryzen Master and Hyper-V do not get along. I use VMs during the day for work and game a little at night and thought Ryzen Master looked like a nice feature.


As a developer and gamer, it sucks for me as well, but I doubt we'll ever see a solution. 


Going on over one year without being able to use ryzen master :/

Virtualization is mainstream now, so are security features. AMD need to come up with a solution.