Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

AMD RADEON switchable graphics not working in recent updates of Windows 10


I have an ASUS N551ZU notebook with switchable graphics, an AMD Radeon R7 integrated GPU and a Radeon R9 M280X discrete GPU. I have the latest version of Windows 10 as well as AMD software installed on my laptop. Unfortunately, for months I couldn't have my games run on the discrete high-performance R9 graphics, even though I have set the power option to High performance. Clean installation of drivers and Windows, updating BIOS, and installing older versions of drivers have not resolved my problem. I've also sent an email to ASUS, and they responded the problem is not of their making. Please help, it's really annoying.

Some system specs:


System: Notebook

OS:Windows 10 Pro v.1909 x64

CPU: AMD FX-7600P 12 Compute Cores 4C+8G GPUs: AMD Radeon R7 graphics (Integrated DDR3) + AMD Radeon R9 M280X (Discrete GDDR5)

Driver version: Adrenalin 2020 Edition 20.4.2 Display: 15.6" 16:9 IPS FHD (1920x1080)

Motherboard: ASUSTeK COMPUTER INC. N551ZU BIOS: N551ZU.307

RAM: 8GB Single-Channel DDR3

P.S.: I guess the last time I had no problem dates back to Windows 10 v. 1511. I can attach more detailed information and screenshots if required.

93 Replies

Windows 10 version 1511 is long out of support. I use version 1909 as redmond has been slow with releasing version 2004.


What happens if you go into Windows device manager and disable the AMD Integrated Graphics? 
Lets assume my PC were a laptop and the Laptop iGPU were an RTX2080

It might be that case that the mux part of the iGPU would still function and disabling the IGPU would force Windows to use the Discrete GPU on the Laptop - In my case one of the RX Vegas or the R9 390X... 

On the other hand you might just end up with a black screened laptop. 

It might be worth a try once you have AMD drivers supporting Enduro installed? 



yes i tested it. no black screen but it's like i don't have any gpu installed just showing 7GB of ram.

proove wrote:

yes i tested it. no black screen but it's like i don't have any gpu installed just showing 7GB of ram.

some memory is reserved for integrated graphics, for example, my R5 2400G uses some 

I currently have 32GB installed so that devices have anything they need. The 8GB VRAM on my video card is placed above the main memory in a 64-bit address space.

Integrated graphics have no dedicated memory so they use some of the main memory.

Adept III

yes it did no effect

Can I ask if you have checked your laptop power plan settings please?
I think you need to make sure you have laptops set to high performance power plan.
I believe there is also an additional setting in the Advanced  Settings options of the Power Plan relating to switchable graphics options.
I forget what it was at the moment. - I will try to find it again. Meantime it might be worth you taking a look since you have the laptop.


i always run my laptop with high performance settings with charger plugged in.

i double checked everything and still i have problem.

OK - sorry I could not help.

Sounds like your N551ZU | Laptops | ASUS Global laptop is put into an unsupported GPU drivers dumpster.
It does seem your laptop was originally designed to work with Windows 8.1.

AMD don't support that OS.
They dropped it years ago with no warning or notice or care in the world.
The laptop drivers were probably designed to work on Windows 8.1 and you have now upgraded to Windows 10.

The APU has a GCN 1.1 iGPU according to this: AMD Kaveri FX-7600P Notebook Processor - Tech

The Discrete mobile chip is also GCN - exaxt version not specified but I think it is also GCN 1.1.
AMD Radeon R9 M280X - Tech 

Maybe time to upgrade to a new AMD Ryzen 4000 series laptop.


thanks such things happens


Yes unfotunately they do.
Laptop support for GPU drivers can be bad especially once new OS is released.
This article might be of some use:
AMD’s Enduro Switchable Graphics Levels Up 


AMD stopped support for Enduro with the 19.5.1 drivers. Previous drivers do support it.

Support for AMD Enduro™ technology switchable graphics mode has been discontinued starting with Radeon Software Adrenalin 2019 Edition 19.5.1. Users who wish to continue to use AMD Enduro™ technology switchable graphics mode may do so with prior supported Radeon Software releases.

This may have changed with the new WHQL drivers (Adrenalin 2020) as the 'switchable' function has been removed from the graphics is now located under 'Display' options of your computer.

Sure - I was just posting the article for some background info into the history of switchable graphics.
Trying to find out what technology was used on that Asus Laptop at launch.

Check out that post I linked to....since the laptop is older, it very well be Enduro controlled. I would try installing the 19.4.3 and see if that works...if so, then a "Hybrid" could possibly be made.

AMD Radeon Adrenalin Edition 19.4.3 driver download 

Thank you for your time and guidance colesdav. Do you think we have any chances if we keep reporting the issue to AMD, ASUS, and Microsoft? It is understandable if a notebook is no longer supported actively, but it is unacceptable to leave it useless and full of bugs.

This review: Asus N551ZU Notebook Review - Reviews 
The laptop uses AMD Enduro technology.

See the quotes in the review
It seems there were problems with the Graphics Card working with Windows 10 in the review of the notebook at launch.

"Graphics Card

The integrated Radeon R7 graphics unit (512 GCN Shader, dual-channel DDR3-2133 memory controller) performs calculations when power has to be saved, i.e. in battery mode and when the user wishes. Although graphics switching is automatic, the graphics can be set manually for every application or game. The iGPU was wrongly enabled 2 to 3 times in our benchmark tests, and thus the GPU selection should be checked regularly. We also tried the Windows 10 Consumer Preview. Catalyst 14.12 enabled the iGPU but not the M280X."

I think you might have to revert to running Windows 8.1 on your laptop and install the original drivers from the manufacturer if you want your laptop to run with the M280X again.

Otherwise you may want to try to install a very early version of AMD Crimson Drivers as a starting point or try last supported versions of the drivers that support Enduro technoloy as kingfish kindly pointed out. 

I had to save whilst editing - will correct - typos later - but you should be able to get the meaning...


17.11.1 WHQL broken Enduro/Switchable Graphics 


FX-7600P GPU with R7 Graphics and a R9 M280X Discrete GPU

Adept II

same problem, same laptop!!!!
This laptop only detects R9 M280x GPU on Windows 10 V1511. On later version of windows 10 it can not detect R9 GPU. I also checked installing windows 10 V 1607 & 1709, but no remarkable result. Hope AMD fix this major problem.photo_2020-05-02_07-16-32.jpgphoto_2020-05-02_07-16-29.jpg

If you do try the older driver don't forget to clean install it with the laptop disconnected from the internet...reconnect only when you have uninstalled and installed the drivers and rebooted.

I have been on several different forums and switchable graphics problems are pervasive. This technology surfaced back with WDDM 1.0 and Windows Vista. Back at this time machines were still largely using separate graphics soldered to the motherboard.

Adept I

Same as you....glad to know i'm not alone.

Can I join that telegram group? this is driving me nuts...ive done "everything" in my power....

ok the link just posted in one of the threads but there isn't any good news for that the only thing that worked is:

windows 10 x64bit version 1511

radeon crimson 15.11 win10 64bit

and your numbers should be like this:

Screenshot (20).png

as you can see dedicated video memory should be around 5GB

Just double checking - did you install latest ATK for Windows 10?



yes as long as there isn't any other driver for windows 10 in download center we download and install drivers for windows 10 then installing other drivers from 8.1 tab.

we also install GPU drivers from AMD for windows 10 but latest driver shows clock speed 0 and temperature at 511 with 0 activity.

i mean the drivers which are listed for windows 10 in asus site, we install for windows 10 but for sound driver and such things we have to install driver of windows 8.1 on 10.

we also download and install Adrenalin 2020 Edition 20.2.2 for windows 10 x64 which is WHQL and the latest version listed in the link you mentioned.

i also tried to install latest driver of 8.1 on 10 in the link you've mentioned but simply says i have to download correct driver for windows 10.

Ok...I got confused...I thought you had reinstalled which case I was going to recommend driver version 19.4.3


thanks, I'll tell the people on the telegram group to test it for windows 8.1 and give you reports.

can you please give us version 19.4.3 for windows 8.1 link?


thanks. they say it works very well on 8.1 .


DSon't you need to install Windows 7 version of 19.4.3 on Windows 8.1? 


The above link still works and will let you download Windows 7 19.4.2 3 version of the driver if you do want to try it out and see if it will work on Windows 8.1 and give you more up to date drivers.


thanks we'll try it.

Ooops...I gave you the wrong link...this is 19.4.3 for Win7/8

AMD Radeon Adrenalin Edition 19.4.3 driver download 


never mind, i gave them correct link they say it's ok

Adept I

Hello everyone, I had this issue and after doing a Reset PC and installing and uninstalling the driver more than 5 times....somehow I managed to get it working.

I did a clean uninstall of all AMD drivers and then installed the latest one from AMD (not the WHQL).

And it is switching when I get inside the game now. Its not lagging for sure but inside the game or graphic settings it still shows the R7 instead the M280x.

I made sure this was happening with the task manager sticked on top and it was showing the discreet GPU working instead of the integrated GPU....

hopefully this helps somehow...all of this with Windows 10 latest version.

Which AMD driver please. Are you saying it works with Adrenalin 2020 20.4.2?
And your latest Windows version is Windows 10 19.09 (Pro?) updated today?


Did you use latest version of DDU to uninstall the AMD Driovers or did you jsut relay on windows driver uninstall (amdcleanuputility.exe?).
You should have stayed physically disconnected from the internet at all times during driver install.


have you restarted windows?