cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

TheLatinRanger
Journeyman III

AMD Radeon Software Failure to load

Hello,

I've been experiencing issues with the AMD Radeon Software for months now, unfortunately, and even though I thought I had found a permanent fix, I apparently have not.

I have an MSI Radeon RX580 Armor OC (8GB version) and, according to Device Manager, am currently running the "27.20.12033.1007" version of the AMD Radeon Graphics Software on Windows 10. I've had the graphics card and my personally-build PC for a little over a year now.

Probably until the summer, I had never experienced any issues with the graphic software, but at some point a couple months ago, I noticed the software would no longer work. Previously, I could access the software either by finding it in the Windows 10 start menu, by finding the icon in system tray, or (more often than not) right-clicking the desktop to open the software through the desktop pop-up menu. Any of these options would prompt the software to open after a couple short seconds, and I could use it like a normal person.

Problem: Unfortunately I cannot remember when the issue first occurred or which version of the driver software I was on at the time. However, a couple things happened: (1) the AMD software icon no longer appeared in the system tray, (2) the software no longer showed as running in Task Manager (as far as I can tell), and (3) opening the software either from Start menu or the desktop menu only went so far as to turn the mouse into the loading hourglass for a few seconds, at which point the loading sign would go away and nothing would happen. My graphics card continued the work correctly, other than the fact that I could not access the software and interact with settings there.

Potential fix: once I got around to actually fixing the software, I used DDU to get the clean uninstall and reinstall of the latest software version at the time (this was maybe a month ago). DDU did the job and fixed the software; the icon appeared everywhere as it should, and I could access the software properly.

Problem again: This fix lasted a couple of weeks, and now the software has broken again, with the same symptoms as before. I'm really not sure what has changed on my PC since I ran DDU and fixed the issue, other than applying Windows 10 updates about a week ago. It's possible OS updates have caused the issues, but I cannot confirm given I didn't try to open the Radeon software after the updates until today.

If need be, I will either live with the issue or run DDU again, but DDU is inconvenient, and I'm sure there's a real solution somewhere, so that would be preferred if anyone has any ideas.

0 Likes
1 Reply

Sometimes driver corruption can be Windows Fast Startup messing things up. You might want to disable hibernation/fast startup and DDU and re-install and see if that helps.

For what it is worth the 2020 drivers on Polaris are problematic for many of us. I have found returning the the early December driver 19.12.3 the last 2019 one is the only way to get Polaris working right again. 

If you want to give that a go, you can still get that old driver from guru3d dot com. Run DDU before reverting.

By all means please do report the issue to AMD as reporting it here does not do that. 

Contact them here and maybe they will eventually get the current drivers working on Polaris a supported card that is still being sold. 

https://www.amd.com/en/support/contact-email-form

 

0 Likes