Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD Radeon Software 18.5.1 freezes my computer every 5 seconds

Hello, everybody!

I'm having issues with the newest version of the AMD Radeon Software, which is currently 18.5.1. I decided to reinstall the OS from scratch because of some issues with the computer itself and for some cleanning up, then I decided to install the most recent drivers of my devices (because I don't trust Windows 10's drivers update). The moment I install the AMD Radeon Software, my computer freezes for 1 second every 5 seconds I move the mouse, it's incredibly annoying and I can't figure out why. I restarted multiple times, but the issue is still there, so I decided to uninstall it. Once I restart, it works just fine, no stuttering nor freezing, even Windows 10 "updated drivers" work without any issues. But then again, whenever I play a game, it recommends me to update the GPU drivers.

To give you an idea, here's a gif'd video I recorded with my phone on a pitch-black picture and the cursor, drawing small circles and capturing every single stutter:


Despite happening with the cursor itself, it actually freezes my entire computer. I played a video and the moment I move the mouse, EVERYTHING gets stuck for a second and so on. I've checked my PC performance and there's no process consuming the entirety of the CPU, RAM nor GPU, and it happens right after I install AMD Radeon Software 18.5.1. I haven't tried with a previous version, but if there's anything I can change on the settings to fix this, please, let me know, this issue is very annoying.

My PC specs are as follows:

     - OS: Windows 10 Pro x64;

     - CPU: Intel i5 7600K 3.80GHz;

     - GPU: ASUS Radeon Rx 580 8GB;

     - Motherboard: Gigabyte H270-Gaming 3;

     - RAM: Corsair Vengeance 16GB (2x8GB) 3200MHz;

     - Storage: Corsair MP500 M.2 240GB + WD 3TB 7200RPM.

If I'm missing anything, please, let me know and I try to provide what you need as soon as I can.

Thank you very much in advance!

395 Replies

Got the same problem with an AMD A6 processor.

Try an older version like 17.11 or below.

You can also use the WDM drivers from. Windows update.

If you use DDU, please keep in mind, that you also have to reinstall de

Chipset drivers. Also use the APU download not the graphic card on amd


Am Mo., 31. Dez. 2018, 09:52 hat craigsuddo <>


Community <>

Re: AMD Radeon Software 18.5.1 freezes my computer every 5 seconds in *Drivers

& Software*

Adept I

Interestingly, I have just installed the driver with device manager rather than the installer. Whenever my laptop would freeze was also the same time Windows would refresh device manager, so is some background polling of hardware changes potentially querying the graphics card and this is what is freezing the machine up?


Have a look in the Windows error log. There you should be able to see that

the the driver tries to reinstall itself several times until windows stops

the process and roll back to the standard display driver.

Am Mo., 31. Dez. 2018, 15:48 hat craigsuddo <>


Community <>

Re: AMD Radeon Software 18.5.1 freezes my computer every 5 seconds in *Drivers

& Software*


OK so I have only installed the 18.12.2 driver without the AMD Adrenaline software and the issue still occurs, so the issue is actually in the driver itself.

Is anyone aware of a way of reverse engineering the driver so we can take a look inside? Literally every 2 seconds my screen freezes for 1/4 of a second.This screams coding problem.

I'm now in the unfortunate position that I can't install the older drivers as I've just done the 1809 Windows update to my laptop and the older drivers do not work any more with this version of Windows.


dude - its simply a broken HDCP support
just disable it in Display tab

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS

If only it was that simple. Read my post again, It's a laptop. When I go into the Display tab, there is only one display and I can't override anything. Besides which, it says HDCP is disabled under the Specs button.


Big Boss

mh, maybe try a fresh windows install

PC: R7 2700X @PBO + RX 580 4G (1500MHz/2000MHz CL16) + 32G DDR4-3200CL14 + 144hz 1ms FS P + 75hz 1ms FS
Laptop: R5 2500U @30W + RX 560X (1400MHz/1500MHz) + 16G DDR4-2400CL16 + 120Hz 3ms FS
Adept I

giorov92​ mentioned, that it could be an encryption driver that causes our problems.

Here ist the thread


Well... after waiting and waiting and holding onto 18.3.4 I decided to swap in a new monitor.

My HDMI monitor was a TV/monitor and would actually power down when not in use.

My new HDMI monitor stays in standby and I can control the HDCP (shut off).

Therefore AMD owes me a monitor replacement fee. Do I dare hold my breath waiting for it?

ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASRock 6700XT Challenger, Antec Truepower new 700w. 32GB

that's sad you had to do that just to disable HDCP

Adept I

Has anyone tested the new driver version 19.1.1.?


gnampfi wrote:

Has anyone tested the new driver version 19.1.1.?

I've re-enabled HDCP on all monitors and so far so good on 19.1.1. No mouse lag.

ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASRock 6700XT Challenger, Antec Truepower new 700w. 32GB

I'll test it when I switch back to Windows, fortunately for me, I use Linux most of the time


What's your setup? Are you running the Windows 10 October update?


I re-enabled HDCP with the 18.x.x drivers (can't remember which) just to test that I was still getting the stutters, which I was. I then gave 19.1.1 a go but unfortunatly, I still have the issue. Forced to disable HDCP again.

Journeyman III

Running 19.1.1 at the moment under Windows 7 64-Bit. Decided to try it after my last post as they said they fixed this issue. Unfortunately.. they did not. HDCP issues are still cropping up. It is forcibly disabled on all 3 of my monitors, yet one of my screens says that it is enabled. and there is no content on it that would warrant such.  Granted that is the only display not going through an active DP adapter, but still. Hate to say it but while AMD is good for the wallet, I've never had a single issue with my history of Nvidia cards.  Next build is team green


If you have windows 7 in 2019 , you will also have problems even in green-yellow-blue-purple team

Adept I

Updated to 19.1.1. It is not fixed. Freezing problem immediately returned. It can be removed by disabling the HDCP support. When I looked at the monitor settings, it said that the current HDCP status was disabled. Still disabling the whole HDCP support fixes the freezing.

In my case this problem has nothing to do with multi monitor setup. I have only one monitor. Acer BE270U connected to Gigabyte RX460 2GB by DisplayPort. Other hardware: i5-4670K, Asus Z87I-PRO Mini-ITX

With the previous drivers, I noticed that the problem may also have something to do with the Virtual super resolution function. I was able to get rid of the problem also by turning on the VSR. Tried turning it on and off several times, and it consistently removed and returned the freezing problem. Could someone else try that?

@jam sadly disabling HDCP on both of my monitors does not fix it.

Maybe someone can work with my description:

Describe your system:

AMD Graphics Card: AMD VEGA 56 (Sapphire Pulse ED.)

Desktop or Laptop System: Desktop & Laptop (Lenovo E485)

Operating System: Windows 10 Pro 64bit 1803 (fully updated)

Driver version installed: Radeon Software Adrenaline Edition 19.1.1

Display Devices

- acer XF240 1920x1080 @144Hz DP

- SAMSUNG SyncMaster S24B350 1920x1080 @144Hz HDMI

Motherboard + Bios Revision: AsRock AB350 Pro4 5.40

CPU/APU: AMD Ryzen 7 1700 (Stock) / Ryzen 2500u

Power Supply Unit  Make, Model & Wattage: BeQuite System Power 8 500w

RAM: 2x 8GB @3.000MHz

Describe your issue:

Starting any Application that uses the GPU/Driver to (i assume) enumerate display resolutions and refresh rates, leads to the whole system "lagging".

Most notably symptom: Mouse movement is lagging. People on VoIP Applications say "while this happens, your voice is cut off a lot"

Applications where this happens:

- League of Legends (as soon as a Game starts, e.g. the Launcher hides and the Ingame Client is started)

- Grand Theft Auto San Andreas (Moddable Version 1.0 / 2.0) (As soon as i run the Game)

- Minecraft (when launched from the MultiMC Client launcher)

- many more applications ...

Video of the issue:

Explainaton: I start up the game by double-clicking it. Immediately the system starts lagging, mouse responsiveness shown in the video.

Radeon Settings:

- Display Settings:

- Global Settings:

- Disabled HDCP for both Monitors

Issue did NOT occur with my previous NVidia GTX 1050 TI

Edit: Links fixed


I can't access your vids/pics.  

I don't know if your's is the same problem. This thread's issue is with one monitor off, moving the mouse on desktop and every 5 seconds or so, it will stop for a bit and then continue to move some more for another 5 seconds etc. etc..  If you turn the monitor on, it works fine. This is on desktop at startup and before launching any programs.

If that's not what you have I'd suggest copying your post and start your own thread where it will get more attention.

ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASRock 6700XT Challenger, Antec Truepower new 700w. 32GB

For some reason the links lead to respectively, copy and pasting the URL from the text does work fine.

Not at a PC/home right now, can't fix the formatting

Am 14.01.2019 10:27 schrieb Hardwood <>:

Community <>

Re: AMD Radeon Software 18.5.1 freezes my computer every 5 seconds

in Drivers & Software


Can't change any of them.

I also have only one monitor, can't change the HDCP option (it's defaulted to Disable anyways) but I can't change the VSR either. It's grayed as 'not supported'.

Funny because the stock driver that comes with the OS works fine, it's just 4 years old.

Journeyman III

Just bought a new XFX 580.

Same problem. Stuttering every 5 seconds. Video playing or not.

Only happened AFTER installed AMD drivers.

Rollbacked to default Windows driver.

Date: 4/24/2017

BIOS Version:

Now it works.

Really don't want to use a 2017 driver. Will return if I don't figure it out by return period (45 days).

note: AMD Settings wouldn't open either when I was on the latest drivers. Clicking the tray icon would close the program immeditely and the icon would disappear. Right-clicking on the desktop wouldn't open it neither.


Try 18.3.4   It worked fine for me.

With a new monitor and 19.1.1 my issue with drivers 15.7.1 to 18.12.2 is now fixed.

Always do a clean install when down-dating the driver.

ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASRock 6700XT Challenger, Antec Truepower new 700w. 32GB

Tried with 18.3.4, same problem.

Also I tried with almost the whole line of 18.x.x drivers, 17.12.1, and I couldnt test with 17.1.1 due to an installation loop with them.

Had to go back to the stock one (15.201.1101.0, that's a 2015 driver; HP notebook with a Radeon R5 M330 running Win10, single monitor laptop)

Also I have been in contact with support and their answers suck to be honest, they basically told me that the whole issue is due to hardware being incompatible with the drivers but that's a funny statement considering the amount of feedback in this thread.


Yes their answer there is complete BS. Obviously their card works with some of their drivers so obviously it is the driver issue. amdmatt​ maybe you can look into this support question s.alonso​ filed and find out why AMD is blaming other hardware for something so easy to prove IS the drivers? Isn't it time to start getting some problems fixed instead of continuing to introduce new features that only break more things that did work?. You know like the 2019 drivers and the fan curve that now doesn't work correctly either. I could list a page of crap that is still broken in these drivers for well over a year now.


I've looked into your ticket, and apologize for the response.

Unfortunately, while we fix the issue in several configurations in the test lab, there still remain some cases where the issue continue.

Having said that, there are two details that are slightly different in your case:

  • You are reporting this issue with an HP Laptop - all the reports we have received have been against desktop systems
  • You say you have experienced this issue for over 4 years. This issue has only been reported towards the middle of last year.

However, this issue is currently being investigated at the highest priority.

I recently bought a Lenovo IdeaPad Flex 15D (Model name: 20334) (Second hand, no other issues) & the last stable update i’ve been able to use for the A6-5200 APU is 17.4.4 (Crimson ReLive Edition) released on 13/11/2017. Any update after that I suffer from screen freezes every 3-5 seconds, so I can confirm with s.alonso that it also effects laptops!

ill upload a dxdiag in a bit when I’m back home.

Edit: Was not sure which driver to take a DxDiag report of, so I took one for 17.4.4 (Stable Driver), 18.12.3 (The recommended driver for my system (When 17.4.4 is installed)) and 19.1.1 (The latest driver release). Hope this helps!

Hey @ray_m Same as clouis‌ mentioned, same APU. Posted my dxdiag and windows error reporting protocol a few comments earlier. Model is HP 15-ad118ng

Hi Ray,

This reply must be for someone else. I don't have a laptop or a 4 year

old issue.


ASUS TUF X570 wifi, AMD Ryzen 5 5600G, ASRock 6700XT Challenger, Antec Truepower new 700w. 32GB

The response was to  s.alonso

Journeyman III

This issue is still present for me after 19.1.1.

I have to rollback to 18.9.3 for the system to not experience any stuttering. There's a similar issue listed as 'fixed' in the release notes for 19.1.1 so I was pretty excited, but it looks like it's not the same thing. It isn't really 'mouse lag,' anyway, as videos will freeze for a second, also. Every 5 seconds or so, the whole system hangs for about one second.

Without any AMD drivers installed or with 18.9.3 the issue does not exist. This is really bad. I should be able to update my drivers without having to worry about them completely breaking performance on my system. It'd be one thing to experience a small hitch or a driver crash like once or twice during an entire release period for a driver, especially if it's an optional one. But for the recommended drivers to not work at all is really, really sad.

Adept I

Well, well, add me to the list.  I just recently got an RX 580 and a new freesync monitor - and am experiencing this issue on the latest drivers (19.1.2).  Exactly the same pattern , 5 seconds of normal behaviour, 1 second of mouse freeze, then 5 seconds of normal behaviour...wash, rinse, repeat.

I've found something interesting - the problem happens *after the monitor wakes from sleep*.  If I turn off the monitor, wait a few seconds, turn it back on, the problem goes away. so this appears to be a some type of issue after waking from sleep...for me, at least.

Any ideas why this is happening?

Make sure to report it to AMD:

Online Service Request | AMD 


Adept I

For the love of GOD AMD. Can you fix this. I just tried Adrenalin 2019 Edition 19.2.1 Optional hoping this would be "the one". 

Every time I have hope and every time I have to go back to my CD from Gigabyte to get a known driver without this bug.

I took a chance and said try a radeon, better performance and price... well now my boss is even more skeptical. Great going. This has been going on for months. FIX IT.

That means we are running version: 17.4.4 - pathetic.

Adept I

Well.  seems to be getting worse.  pausing even after turn off/on.  also seems to be an issue with my 2nd monitor hooked up to either HDMI port (Radeon 580).  Tonight, it wouldn't output a signal to the 2nd monitor after turning the freesync monitor off and on.  I really don't want to have to do major troubleshooting (e.g try different monitors, try different connectors, take out video card to confirm problem is associated with 580, etc....).  Ugh. Try to save a buck and not go with Nvidia 1060/ I'm rethinking...

I suppose it could be hardware (defective card)...but..with so many others having the same problem....I'm inclined to think it is a driver issue.....

With my previous Nvidia GTX 660, I literally plugged in the card and never had an issue with the hardware or drivers.  For years. And years. This is mind-boggling.

Also, why is this thread 'Assumed Answered'?  I don't see any answers here......


I have a 1080Ti at home and it turns off HDMI if I have DVI plugged in, whereas at work here on a RX560 I'm dual monitoring with 2 HDMI monitors via HDMI and a HDMI to DP cable just fine. (this only has 1xDP 1xHDMI 1xDVI).

I'm actually quite unimpressed to pay $1200+ for a Ti to find that "feature", I wouldn't hold your breath for better support for dual monitor in nv land...

This is on both the lastest and the old drivers. Do you have a spare cable to see if it's anything like that? Maybe a dvi or different port type etc, anything to isloate that issue.

Are you also suffering from mouse / whole system freezes like OP 5 seconds ok, 1 second solid lock, recursively?


Thank you for replying.  Regarding NV - well I'm sure you can tell by the fact that I was running a 660 that I am on an 'extended' upgrade cycle.  Admittedly, I have no experience with newer NV cards, but that 660 and each iteration of the Geforce drivers up to the most recent never caused me issues like this in my dual monitor setup.

Yes, I do have spare cables, and as mentioned,  I can go through the arduous process of isolating the problem -  cable, monitor, port, card, drivers, system, and probably will this weekend to eliminate all those issues.  However, also as mentioned, considering that my base problem is identical to the OP's (yes, the recursive 5sec OK, 1 sec freeze, 5sec OK, 1sec freeze problem), I was jumping to the hypothesis that it was not just a simple hardware problem, but a driver problem independent of hardware, due to the varied configurations in this thread also suffering the identical problem....

I'm no AMD hater - My current desktop in which the RX 580 resides is a good ol' Thuban 1055T which has served me very faithfully over the the last ~10yrs......and paired with a good MB (Gigabyte 890FXA-UD5) and EVO SSD, is still fast and responsive in most everything I do...

I guess when I finally decide to upgrade something, I want to be 'Wow'ed"...not "Huh, why is that happening"  (as when I discovered the beautiful and rocket speed world of solid state drives vs. mechanical.....   )


Likely a driver issue. AMD has had numerous issues with multi-monitor setups since the Wattman drivers came on the scene.