cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

juliannb
Adept II

AMD Radeon Software 18.5.1 freezes my computer every 5 seconds

Hello, everybody!

I'm having issues with the newest version of the AMD Radeon Software, which is currently 18.5.1. I decided to reinstall the OS from scratch because of some issues with the computer itself and for some cleanning up, then I decided to install the most recent drivers of my devices (because I don't trust Windows 10's drivers update). The moment I install the AMD Radeon Software, my computer freezes for 1 second every 5 seconds I move the mouse, it's incredibly annoying and I can't figure out why. I restarted multiple times, but the issue is still there, so I decided to uninstall it. Once I restart, it works just fine, no stuttering nor freezing, even Windows 10 "updated drivers" work without any issues. But then again, whenever I play a game, it recommends me to update the GPU drivers.

To give you an idea, here's a gif'd video I recorded with my phone on a pitch-black picture and the cursor, drawing small circles and capturing every single stutter:

ezgif-1-c4f5a71d33.gif

Despite happening with the cursor itself, it actually freezes my entire computer. I played a video and the moment I move the mouse, EVERYTHING gets stuck for a second and so on. I've checked my PC performance and there's no process consuming the entirety of the CPU, RAM nor GPU, and it happens right after I install AMD Radeon Software 18.5.1. I haven't tried with a previous version, but if there's anything I can change on the settings to fix this, please, let me know, this issue is very annoying.

My PC specs are as follows:

     - OS: Windows 10 Pro x64;

     - CPU: Intel i5 7600K 3.80GHz;

     - GPU: ASUS Radeon Rx 580 8GB;

     - Motherboard: Gigabyte H270-Gaming 3;

     - RAM: Corsair Vengeance 16GB (2x8GB) 3200MHz;

     - Storage: Corsair MP500 M.2 240GB + WD 3TB 7200RPM.

If I'm missing anything, please, let me know and I try to provide what you need as soon as I can.

Thank you very much in advance!

394 Replies

Hi there, I can make a video,instead.

However I did noticed something,yesterday I was playing with overclocking via MSI afterburner. I launched MIS Kombustor,to have some high load on the card.And I noticed that on no overclocking the core frequency was going up and down.So I thought that by adding more to the power limit this will be fixed, but the same thing remained,it kept going to the default core frequency of 1268 to 800 or to 300 which is the lowest.Changing the core frequency did not change anything in this behavior.The only setting that, by changing, that gave an effect on this behavior was lowering the power limit.Basically it shortened the difference between the high and the drop in core frequencies.On -50% power limit it became stable....I suppose mainly because the limit is not allowing it to go to higher core frequencies thus it stays at 300mhz. So when I removed the pointer trails for the process explorer,this reminded me of the effect I saw in Kombustor.At the lower power limit the Kombustor (freeze/frame drop/GPU shut down or whatever) behavior was almost unnoticeable.The GPU usage is constantly jumping up and down.

Just tried to remove the pointer trails and lower the power limit to -50 to see if the mouse will stop this freeze but it was still there.GPU usage even in idle is jumping up and down.

0 Likes

I used Process Explorer's graph and found the following: [see Screenshot_2]

When my TV is turned on, CPU usage is almost 0, mouse doesn't freeze.

When my TV is turned off, CPU usage goes up a bit, the only process I saw spike was the System process itself, during this time the mouse would freeze every few seconds. All other processes showed no noticeable difference in CPU usage. The child processes of System (Interrupts, smss.exe and Memory Compression) do not spike.

In the GPU tab there wasn't any difference either, GPU usage was constantly at around 0.5-0.7%.

As for the additional info:

1. Disabling anti-virus didn't help

2. Disabling Windows Focus Assist didn't help either.

3. Logitech G9, tried with both default drivers from Windows 10, and the one from Logitech website [see Screenshot_3]

Hope this helps. I'll be happy to provide more info if necessary.

Cheers!

Ray_AMD
Community Manager

Thanks !

0 Likes

I apologize for the lateness of my response, but here's my update of the matter.

I have updated the drivers to 18.6.1, I decided to do a clean install and the issue hasn't been resolved yet. I paid attention to what has been said here and proceeded to use one monitor (the main one), but without disconnecting them, just selecting to project in one monitor, and this issue doesn't happen.

I decided to try the same thing with the other monitor and... not only it happens, but it happens without the need to do anything, and even the screen freezes and turns completely green for a fraction of a second.

Then I tried disconnecting the first monitor, leaving the possibly faulty second monitor alone, told the system to re-detect them, so it would go back to normal. The issue does NOT happen, scratching the possibility the issue is in the monitor.

All of this while running Process Explorer as we've been told, the GPU usage wouldn't go past 3% at any point, no matter the setup. The CPU has some random peaks, but none of them caused by the stuttering, or at least, none that I could detect while it happened.

I attach two screenshots, since I don't see any mayor difference between the other screenshots I took. In the meantime, I'll revert back to the version that works for me, 18.3.4 (beyond that, it's unusable).

2018-06-15 17_54_08-System Information.png

2018-06-15 17_53_19-System Information.png

If there's anything else you want me to try, let me know, because I don't know what else to do.

i use an rx 480 i tried 18.6.1 and 18.5.1 same issue after ddu uninstalling my mouse is a mad catz rat 3

0 Likes

17.12.1 runs good tho :/ wierd

0 Likes

mine is 18.7.1 still the same issue

0 Likes

With your help, I found "razerhid.exe" to have I/O graph peaks at the same time, my mouse freezes every 5sec or so. This only happens, when my PC had been on standby before. Killing the razerhid.exe prcoess resolves it (for me). Thank you!

0 Likes
rushrvt
Adept II

i select all gpu things tell me if right.

Matt_AMD
Community Manager

That's better thanks.

Btw, DX12 is handled by the developer so if CrossFire performs poorly you'll need to contact the developers of the game. 

check screenshot3, there runing a game in window mode i got a pic that u need!

amdmatt

0 Likes
Matt_AMD
Community Manager

Unfortunately so far only one user has provided the information i requested. If anyone else can provide the information i mentioned above it would be appreciated and will help us to try and reproduce the issue.

I have no GPU usage at all when the freezing happens so a screenshot wont give u any information.

Turning on the mouse trail option or turning on my TV on the HDMI port seems to reduce the issue, i.e. I dont notice any stuttering in Desktop anymore with mouse trail or second monitor turned on.

Edit: When I turn my second monitor on and off again the stuttering even stays gone until I reboot the system.

0 Likes

I'll go back to the faulty driver and provide screenshots as well.

0 Likes
juraj_m_
Adept II

Regarding reproducing this issue, for me it doesn't start right after PC starts. Usually it starts after playing some video in MPC player.

0 Likes

i think about the 4 last updates they did, messed up entire vga cards, i got a game archeage, when that game loads, everything freeze on mine screen, the mouse move slowly like a turtle, just after game entire load, the mouses back to normal... i think the last driver good was from december!

looks like ATI Lost A LAB, they should test verywell before realease problem for US, i miss the time when ATI was not INTO AMD company! im realy sad with them,i wished not have wasted 900USD in 2 Rx580, i could be bought TOP Nvidia card!

Well,yes...

as I said I'm a new user and had a Nvidia GeForce GTX 750. Had it for about 5 or 6 years now.And I can't remember a time when I had such issues with drivers.The only thing that bothered me was the GeForce Experience software,since I really didn't used it.I do like AMD's software,however I bought my first ATI card mainly for mining,but was greeted with driver issues and not working atiwinflash (because of which it decided to go with AMD).

But let's be fair here....Windows 10 is also to be blamed...whatever Microsoft are doing,they are causing all sorts of problems for driver and software developers all around.And it would appear that they are doing this exactly starting from last December. I know I started having windows issues from around that time.Forcing updates on people and all.

Iam ATI costumer since VOODOOS company falls , since years 2000 more or less, i always loved ATI, on that time, NVIdia was a garbage company trying rise up on market, but today seens Nvidia card's have a big advantage at ATI, nvidia looks like in another generation while ATI stuck... i think after AMD bought ATI, they focused in development of AMD processors and dont do priority to ATI cards anymore, it is what i feel!!

so sad

0 Likes

amdmatt

i recorded one game launching and mine mouse totaly freezing while it loads, it only back to normal after games full loaded!

0 Likes
dmajchrzak
Journeyman III

Count me in too.  I have the exact same issues... with 2 monitors, latest BIOS and Latest AMD drivers,  video stutters for 0.5 second about every 5 seconds.

Also,  as a previous poster noted, turning on mouse trails seems to mostly mask this issue.

My setup:

AMD Ryzen 1800X, 16GB @ 2933MHz

AMD RX480 8GB.  Adrenaline 18.5.2

When I run "process explorer" per the directions,  I notice no change in CPU or GPU usage.. everything is over 98% idle.

Help us AMD support, you're our only hope!

Regards,

Dave

0 Likes

can u share information that amd/ati coder asking above to help speed up process and solve it faster!! only me shared info that he needs>> rollback the post and share ur dxdiag and screenshot of process use>

1. Download Process Explorer.

2. Launch Process Explorer and go to View > Set Columns > > Process GPU and tick GPU Usage and clock Ok.

3. Please monitor the system to see if you see any usage spikes on the CPU/GPU whilst the system pause/stutter occurs and note down what process it is.

4. If users can capture several screenshots to show all the processes running on their system and attach them to this thread, that would be very helpful. You may need several screenshots to capture all the processes. Example taken from my system below.

Example screenshot

Ray_AMD
Community Manager

Can all affected by this issue provide details of :

Mouse model

Monitors connected and connection type.

Thanks

0 Likes

like myself i have tryed 3 mouses all got same issue, sorry is not mouse fault.

but there is corsair gaming, microsoft side winder x8 mouse, razer naga mouse

monitors conect on dvi port, mine tv conected on hdmi port, i also got another monitor on hdmi port..

0 Likes

I have been following this thread. How old are the three mice that you are using? Are all three older than three years?

I had a very similar situation with my computer with a Non-AMD Gpu card. I was using a five y/o Logitech Mouse which will constantly every few seconds freeze from anywhere from a couple of seconds to 15 seconds. I updated my GPU drivers several times without any resolution. This started in December or January 2018 when the Windows Updates were installed. When my mouse froze, my keyboard was unaffected which is also wireless Logitech. I was unable to update my mouse driver since Logitech doesn't support Setpoint anymore. Finally while trying to clean the laser Lens I damaged the mouse. Went out and purchased another wireless Logitech Mouse that now uses Options which included the latest Mouse driver.  No more freezing and mouse has been working great ever since. Mind you I went to Logitech Forums and post about the problem. Another person also said he had the same problem.

In this case it could be a GPU driver issue, but just to show that it could  also be a mouse/Windows 10 issue.

Yes 2 of them are older, but mine Corsair Mouse have less than 4 months VENGEANCE M65 PRO RGB

(if you look in this thread, i have shared i video , when one of mine games load entire screenfeezes, music keep up and all things works fine but the vga graph freezes making mouse freezes too just after entire game load, it backs to normal)

i will share again..

0 Likes

its driver related since it works with older driver atleast in my case

0 Likes

Mouse: Cheap chinese USB one...the brand appears to be something called "Pravix"

Monitors

Main monitor:SamsungS23B300 ; Connection HDMI from monitor > HDMI to DisplayPort adapter > DisplayPport of VGA

Second Monitor: Eizo FlexScan L795; Connection DVI > HDMI of VGA

0 Likes
Ray_AMD
Community Manager

Can you confirm if the problem continues with a single monitor connection ?

0 Likes

I will try it now, and update this reply

Ook, it would appear that I was wrong on my connections ...I mean which monitor was connected to which port of the VGA.... But it is meaningless because as soon as I disconnected the monitor it started running without any issues. I tried both...firs the Samsung monitor alone...then the Eizo...on both the mouse worked fine.

0 Likes

to double post a bit, but that issue with MSI Kombustor constantly dropping GPU usage, thus the constant freeze...well tried it with only one monitor,and no issues what so ever...I even tried mining and hashrate came up from an average of 660h/s to 870h/s for monero.

So if it is a driver issue it might be connected to multiple monitor setups, as you suggested

0 Likes

sorry you going on wrong way, since january the ati driver, are messed up! look above, i shared a video where mouses freeze when load a game, it's not mouse fault.

can be windows10 maybe! but not mouses fault.!! as i told i have 3 different mouses here!

0 Likes
Ray_AMD
Community Manager

Thank you for your feedback, but we are trying to root cause the issue. If you can provide the information requested, that would be appreciated.

0 Likes

Mouse model is Sharkoon shark force, but as said before I don't think its related to the mouse itself but maybe to drawing the mouse curser (the mouse trail workaround really helped).

Monitors are a Acer 233 on DVI and an older Philips FullHD TV (model unknown) on HDMI.

0 Likes
juraj_m_
Adept II

Mouse:

A4Tech XL-755BK

Two monitors:

Dell U2713HM

Connection:

Both connected using DP to DVI active adapters:

http://www.akasa.com.tw/search.php?seed=AK-CBDP15-20BK

If you ask why would I use DP to DVI adapter when both of my monitors has DP input, I tell you it's because of the st*pid DP power-off detection and the bug that everybody knows about, but nobody wants to fix it - by nobody I mean Microsoft, AMD, nVidia and Intel. If you are interested, there is one bug here as well:

RX 480 monitor connected with DisplayPort gets reconnected when turned off and on

Anyway back to this bug - when I disconnect one of the screens, the bug is gone. However if I connect it back - the bug is still gone, but it will probably appear soon. For me the freeze interval is 6 seconds and ONLY if mouse moves. Else there are no freezes and I can watch a whole movie without any tearing. But once I start to move mouse the whole PC stops every 6 seconds (and by whole PC I mean only GPU output - the music still plays).

There is no spike in CPU or GPU activity and the turning on mouse trail fix it.

EDIT:

One more thing - since we know it's related to mouse I feel like I should mention that I'm using StrokeIt and StrokesPlus gestures programs.

EDIT 2:

One more thing - the bug just appeared again right after waking up my PC from sleep. Using 18.6.1 driver on RX 480.

0 Likes
okuma_10
Adept II

Just to note, that the latest 18.6.1 drivers do not solve the issue.

Edit: I've given up on 18.6.1 and reverted to the beta blockchain drivers which I think are 17.3.1. Having no issues both in mining and with the mouse. Also, I was having constant hiccups with the card, which as I said was visible in MSI Kombustor. Now I don't have those but I can't check in Kombustor since it does not load with these drivers. An interesting thing to note, however, that using Kombustor I had the hiccups/freezes when I used the OpenCL version of the stress test, but with Vulkan  it was running with no issues.

The reason that I reverted back from 18.6.1 is that after about 6 minutes, the drivers will crash and my memory clock will go to 300, and not go back to where I had it. With 17.3.1 I don't have that issue and it runs smoothly. So maybe the driver developers should look at 17.3.1 and see what they had there and find why in 18.6.1 the drivers underperform.

0 Likes

just to note, i give up of ATI, i'm selling mine 2 VGA card's to buy an Nvidia 1080ti! GG

0 Likes
aovaron
Journeyman III

Hello,

i have the same Problem.

When my 2nd Monitor is connected the Mouse freezes.

When i turn my 2nd Monitor on all is fine. If he is turn off the Mouse freeze.

So fix this please. I dont use always my 2nd Monitor.

Both are connected via HDMI on a Radeon RX480

Thx

0 Likes
Matt_AMD
Community Manager

When folks say we turn a monitor off, do you mean press the power button or physically disconnect it from the back of the GPU?

0 Likes

Physically disconnect from the GPU.

By me Press the Power Button. When its off the Mouse freeze.

When its on no Freezes.

Or disconnect complete

0 Likes