Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Radeon Settings not working , PLEASE NEED HELP !

Okay so I'm running Windows 7 64-bit, got AMD Radeon HD 7970M GPU as dedicated GPU and my integrated one is Intel HD Graphics 4000... I'm on a laptop and the app whenever I try to launch it says "No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware."

I have tried EVERYTHING, cleaning out everything with DDU and downloading fresh driver, downloading the auto-download application, updating in device manager, updating integrated gpu in device manager and from online intel's site. Running cc2 installer in CIM folders in AMD directory as someone suggested, deleting CN in appdata and trying to run, deleting host processes in task manager and directory before trying to run. Multiple reinstalls etc etc and it still does not work, someone please for the love of God help... Once again been up the whole night with this **bleep**ing thing frustrated as I can't play anything or revert my laptop to how it was before, I have also tried turning off windows automatic updates, and updating it fully, everything, even changing regedit driver to match AMD driver as people suggested online, nothing works... Once again someone please help.. I got no clue where to go from here, before I went to update AMD driver because it was suggested since path of exile's Vulkan feature supports my GPU but it wasn't an option so I did and lost the Catalyst center + switchable graphics options I had and seemingly replaced it with AMD Radeon Settings which don't work now. Thank you all in advance.

0 Replies