Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Radeon RX 5600 XT , Black screen, freezing, and a lot more - possible solution

Helllo! I may have a solution for you

Warning!!! try this after all this:

DDU uninstall clean -> clean install

Mother Board update

Cpu check

cpu and gpu temps check -> if they okey

then try this:


Try this sollution after 

This is my build:

MB -  ASrock B550 Pro4

CPU - AMD Ryzen 3700X 8core

GPU - AMD Radeon RX 5600 XT Phantom Gaming D3 6G OC

Ram - 16 Gb hyperx idk



            I was having problems while playing video games. The crashes depended on which game i played but at the final every single game crashed to 30 mins. Of course i was trying all stuff like clean drivers uninstall with DDU and clean install ...blah blah blah. My computer was not overheating and had any strugglles.


               Possible solution:


This exact GPU is AMD As Rock Phantom gaming... and the solution was for me updating the GPU VBios from their home page.


->ge to your card and go to support

     There are two VBIOS updates L10 and L12. For me the L12 was buggy as well, but after updating to vBios L10 i had no single freeze. black screen or any problem. So for me it wasnt any driver issue, overclocking or so. 



I looked a bit into a sapphire and they have som evbios updates aswell so u can try it as the last help guys


I am really sorry if this doesnt help, cause i know how it feels (3 months of pain)

Good luck guys

if anything ask ♥♥♥♥♥♥♥


3 Replies
Journeyman III

I was having the same problems with the GPU is AMD As Rock Phantom Gaming version of the card. For a while I thought it was heat related, after reading your post, I tried downgrading to the L10 vBios and that seems to have solved it!

Journeyman III

I have Sapphire rx 5600xt pulse 6GB so which bios is the last version ? that i need to download.


i dont have Sapphire GPU, but u can try the newest version of vBIOS in the link i posted. The newest may not solve it, but for me the newest didnt work as well. So if the newest one doesnt wotk, try the other one