Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


AMD Radeon desktop app not loading

The past week or so I've been experiencing Apex Legends crashing to the desktop (all video settings disabled/low). Naturally, first thing I did was check/update my drivers in the AMD app, but halfway through the update, it stopped and I got a notice/error that only half of it was installed. This is where I noticed more problems began. I tried to investigate, so I restarted my computer, click my GPU settings again (the AMD Radeon desktop app that controls all your settings, like Wattman, Relive, etc.) but it wont even load up now. This is my current problem. it shows the loading circle but nothing happens. I've uninstalled/reinstalled the drivers/system a couple times but still the same problem. can't access the desktop app. and still crashing in Apex. If any more information is needed please let me know. Any helped appreciated. thank you.

AMD Radeon RX 480

Intel Core i5 7400

Windows 10

0 Replies