cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

ryanhutchinson
Journeyman III

AMD R9 295X2 Crossfire Support for Current Titles

Hello, I have been looking online regarding crossfire support with newer games using my R9 295X2. Is AMD no longer adding Crossfire support for these cards anymore? I play games such as Monster Hunter, Remnant, Kingdom Come etc. and I see that others with newer cards have Crossfire support while I do not. Am I missing something?

Thanks,
Hutcheh!

Tags (3)
0 Likes
1 Reply
8-fingered
Adept III

Re: AMD R9 295X2 Crossfire Support for Current Titles

Crossfire is DX11 and older only. DX12 has explicit mGPU (heterogeneous or homogeneous). For homogeneous DX12 mGPU the drivers need to do some initial setup and this happens when you enable Crossfire.


Useful link:

Crossfire Game Compatibility List | AMD Crossfire Wikia | FANDOM powered by Wikia