cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

mufassa
Journeyman III

AMD NVMe bootable raid 0 Windows installation error

Hi,

I spent all night last night trying to get Windows 10 to install on a NVMe raid 0 array configured from the bios of my Asrock Fatal1ty X399 Professional Gaming motherboard. I keep getting the same errors, no matter what I try. I am completely out of ideas, and hoping someone from either the AMD community, or maybe the Asrock community can give some insight as to what the issue could be.

Motherboard: Asrock Fatal1ty X399 Professional Gaming 
Bios: 3.70 (Latest) which I believe runs AGESA 1.1.0.2

CPU: AMD 2950x

Drives: Samsung evo 970 1TB + Samsung evo 970 plus 1TB

I have tried: 
Windows builds: 1909, 1903, 1809, 1803

Driver versions: 9.3.0.38, 9.2.0.127, 9.2.0.120, 9.2.0.105, 9.00.00.088

Bios settings: CSM on/off, secure boot on/off, destroy and rebuilding array, both initialise and not initialise drives prior to building the array, both using write cache, and disabling write cache when building the array

I load the drivers in this order

1. Bottom driver

2. Raid controller driver

3. Config driver (have tried both loading, and not loading this driver)

The raid drive shows, but after I select it and click next, this error pops up. Sometimes immediately, sometimes after a few minutes. But the installation never passes 0%.

pastedImage_1.png

if I re-enter the installation after this, I can see the drive is partitioned, but the following error is shown when I attempt to select the partition for installation.

0 Likes
1 Reply
mufassa
Journeyman III

Re: AMD NVMe bootable raid 0 Windows installation error

Looks like this error is a little generic. in that quite a few problems can cause it. The problem was not with AMD, nor the drivers.

In my case, the problem seemed to be with the method I compressed the Windows install.wim. As of 1809 - the install.wim file is too large to fit on fat32 filesystem as is - and requires recompression. I followed a supposably supported method of recompressing the file, but this seemed to have been the cause of the issue.

I borrowed a friends windows computer, and wrote the Windows ISO to the same flash drive using Rufus, and the install completed successfully. it looks like Rufus formats the flash drive as NTFS to avoid this issue, it's likely you could get around this issue on Linux by formatting as NTFS rather than Fat32, but I have not experimented.

It's also worth noting that having a secondary flashdrive plugged in when selecting the partition for install can cause this error as well. Once the drivers have loaded, ensure you remove the flash drive with the drivers on, before selected the raid partition for install.

0 Likes