Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Link "Unavailable"

I'm going to start by saying, yes, I searched and realize there are many topics regarding this.  I'll follow up by saying, no, none of those "fixes" did anything.

ASUS R9 390 Strix


Win10 64 Home

Radeon Software 18.5.1

BenQ XL2411

MSI z370m Gamping Pro AC, American Megatrends Inc Bios 1.2


EVGA SuperNOVA 750 G2


I was able to get AMD Link to work a few months ago, but then tried again last month and couldn't get it to connect.  Didn't care so gave up.  Upgraded from my i7-920 to the 8700k yesterday, figured I'd give AMD Link another go.

Still same issue:  AMD Link "Unavailable"

Desktop hardwired to modem+wifi, phone, obviously, wifi on the same network.  Opened up Radeon Settings, went to AMD Link, enabled, opened it on my phone, clicked "add computer", option for QR Code.  Scan code, and it just keeps scanning it over and over and over.  Little message starts popping up on the bottom (delayed), showing the Server Name, IP, and Port, so I know it's getting the info, but immediately after, it says "Unavailable".

This led me to search far and wide in the realms of google where everything is saying "firewall/antivirus is blocking it!".  I have a completely fresh install of Win10.  I only have Defender, which already had the exception for Radeon on both private and public networks.  Unchecked, applied, rechecked, applied.  Still doesn't work.  Totally disabled Defender, still doesn't work.  I even tried searching my phone for any kind of antivirus or firewall on it.  Nothing.  On top of that, I've tried 3 different phones.  Uninstalled, reinstalled AMD Link.....

Manual Input just tells me "Unavailable" after inputting all the correct information in the correct spots.

Am I missing something?

EDIT:  I'm sitting 2 feet from my modem+wifi, so signal strength is not a factor.

Tags (1)
1 Reply
Journeyman III

Re: AMD Link "Unavailable"

Service not available or PC Unreachable.

same wifi network

windows firewall off

inbound rules created on port 58888 tcp and udf

windows defender exception created for file radeon settings.exe, process RadeonSetting, Folder AMD CNEXT CNEXT

windows defender live protection off

malware byte off

mobile data off

rebooted windows multiple times

enabled, disabled, enabled amd link server multiple times

tried QR scan and manuel many times

quite simply wont connect......