Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Link Controller Emulation not working

I've updated all my drivers on my MSI B450 Tomahawk MB.  Chipset.  Software Adrenalin.  Realtek.   It appears something's amiss in device manager with the AMD Link Controller Emulation item.  It has a yellow exclamation mark by it, and the dialogue box for the item says:  "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

Driver version:

driver date: 7/7/2021

Windows 10 64-bit PC build


Is this something to ignore or need fixed? 



1 Solution

Rolling back the driver in device manager seems to have worked for me. Worth a go.

View solution in original post

6 Replies
Journeyman III

I also have the same issue with the same driver version.

Rolling back the driver in device manager seems to have worked for me. Worth a go.


Looks like the rollback did work, thanks!!!!!!


I do not get the rollback option in the device manager, probably because I selected the option to do a clean install of the driver - nothing to rollback to. I manually rolled back to 21.7.2 from 21.8.2, but the controller emulation is still not working.

Do I need this Link Controller Emulation?


Adept II

I've got the same issue showing up. I wonder how long it will take for AMD to fix their faulty drivers.


I just installed 21.4.1 (approved by Microsoft :-)) with the full factory reset and after the install, the AMD Link Controller Emulation is working.  I also uninstalled the AMD Link Controller Emulation before I did this install.

I don't know if my system needs this AMD Link Controller Emulation, but it least it is functioning now if needed for something.