cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

jcliu0
Journeyman III

AMD IGPU driver causes Steam overlay/context menu in taskbar to lag

I am having problem with the inbuilt IGPU driver where if i enable the driver in device manager, it causes steam context menu when you right click it in taskbar to not instantly lauch friend/library or anything in the list.

 

0 Likes
5 Replies
Anonymous
Not applicable

you might have OTHER OVERLAYS enabled and the several of them fighting for which one goes top/bottom.. like a trashy gay erotica web novel. So you wanna disable steam overlay and test with just Adrenaline overlay with ENHANCED SYNC ENABLED and vsync enabled/disabled test all the different types of vsync off/on enhanced sync off /on freesync off /on 

reset edge browser and toggle on hardware acceleration in system and performance in edge browser settings that applies to games too but might make netflix software renderer give error code

Check you have mouse acceleration and hardware video decoding enabled

bit like previous.rar ~ pixeldrain

my config.ini text file helps with that. but its so many thousands of words to turn on that you may need a code editor or EMeditor64 free trial from windows app store to edit the .ini file. 

i game with a dozen copies of the .ini file and i run the dxfeaturelevel reg file each reboot. remove all hidden devices in device manager after toggling show hidden devices and going through it.

0 Likes
jcliu0
Journeyman III

I don't use the IGPU at all, it is not a steam overlay problem itself, it is the context menu you get from right clicking steam in the taskbar image.png like this.

While the IGPU is enabled in device manager it causes it to lag, and around 15 ~30 seconds delay on what ever you click in there

0 Likes
Anonymous
Not applicable

Check in bios if your onboard integrated GPU in ryzen APU is set for HYBRID GRAPHICS mode. and AUTO for between gamemode or other. I figured out in my steam settings theres a downloads page. At the very bottom there is a toggle for shaders cache and use VULKAN shaders I turned those off for a while then enabled them both on. and it seemed a bit better. You maybe also wanna disable vsync in apps/games or it might be your adrenaline software isnt configured right. You maybe have more than the IGPU and a discrete GPU sometimes if you set them both to use a function it conflicts depending on that function. Maybe turn all on for one and lower for the other. Toggle all your AMD global graphics to be set so antilag is on then nothing else. But when testing with vsync off or on you will want to also toggle ENHANCED SYNC in global graphics settings. Then go beneath the global graphics at the bottom (this is on windows desktop while playing youtube in edge browser or something so its not IN GAME SPECIFIC TO THAT ONE GAME adrenaline settings but ALL OS) You will want to BRANCH OUT THE ADVANCED > tree of additional settings its very small writing scroll to the bottom of global graphics. You will turn on EVERYTHING overiding max supersampling set them all on and highest for all things just leave CAP FRAMERATE OFF and leave TRIPLEBUFFERING OFF. CAP FRAMERATE is only used for specific vulkan titles or situations several directx games most things dont require it as most dev people arent messing up the output methods. 

There is also some options you might wanna disable in steam settings like allow broadcasting and remoteplay or other such things. Maybe if you dont have or use VR disable steam VR theater or if you dont use big picture mode disable that. If you ONLY have IGPU the 8xEQsupersampling might tax FPS/performance a tiny bit try a lower value. ENSURE the AMD adrenaline overlay is enabled i think its in the far right selection system of the SETTINGS cog in the top right corner. Set your display OVERRIDE to disable HDCP if you dont have a bluray ROM in your computer. When on adrenaline in the windows desktop in advanced global graphics settings there SHOULD be a enable 10bit display panel output. It will not show if you are in a game as its an OS setting. be sure to turn that on if you've a 10bit capable display panel.

0 Likes
jcliu0
Journeyman III

I appreciate your input, but this is clearly an driver issue, i have another friend who didn't have this problem and only started having this when updated to the latest IGPU drivers.

For the igpu settings, everything is literally turned off, I have this problem when no display is plugged into the IGPU, everything you talk about steam settings has nothing to do with the problem AT ALL.

I just hope the AMD team look into this already, altho it is completely just an an nuisance since it has a work around by going to right click from the bottom right icon instead from taskbar, but it shouldn't even be happening to begin with.

0 Likes

You & friend should send a bug report.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, NM790 2TB, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..
0 Likes