cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

hipoalergeniko
Adept I

AMD HD Audio Device disappears with new driver

I´m experiencing this issue with every driver after 17.2.1 including the new 17.9.1

GPU Model: Gigabyte Radeon RX 460

Make and Model of the display:  Samsung SB23B300B

Secondary display: HD TV (HDMI)

Type of connection to the GPU: DVI-DVI

Cable Model Number: none

Display Adapters: none

Amplifier: If yes, which model number? none

When does the issue occur? After restarting the PC

My pc is a desktop using windows 7 x64. I have done the clean reinstall with DDU too.

OS: Windows 7 x64 Ultimate

CPU: Intel Core i3 4150

RAM: 12GB

Motherboard: ASrock H81M VG4

Graphics: Samsung SB23B300B (1920 x 1080),  Gigabyte RX 460 4GB

Current Driver Version: 17.9.1

2017-09-15 14_24_33-System.png

However, I have found a way to bring back the AMD HDA device, but it only lasts until the next reboot:

1. Change the driver for the pci express port used by the video card to a version made by intel, the AMD HDA device appears again then disappears after rebooting.

2. Change back driver to version made by microsoft. HDA device re-appears the disappears after rebooting.

3. Do step 1 again.

2017-09-19 10_27_03-Update Driver Software - PCI standard PCI-to-PCI bridge.png

2017-09-19 10_27_47-Device Manager.png

0 Kudos
2 Replies
elstaci
MVP

Re: AMD HD Audio Device disappears with new driver

Make sure you have the latest BIOS for your Motherboard. I believe what is happening is that your computer is going to the Default audio which belongs to your Onboard VGA on your motherboard. If you go to Windows Control Panel - Sound, Check the AMD as Default Audio device. Most likely your Default Audio Device is the Realtek Audio and not AMD HD Audio. I imagine that you have in your BIOS check marked Use Dual Graphics on Auto. I don't use a Motherboard with Internal VGA on it. So, I am just taking a stab here, if you checkmark the AMD HD audio as default, you will probably lose your internal VGA Realtek audio. Unfortunately, Only one HD audio can be "Default".

hipoalergeniko
Adept I

Re: AMD HD Audio Device disappears with new driver

Please read the entire post and look at the pics i uploaded. The AMD HDA driver is not even present in the device manager, and if it is not present then it wont appear in the control panel playback device list. And no, the bios dual graphics setting is set to disable.

But it does not matter right now, i changed the pci bus driver by amd to the default supplied by microsoft and the amd hda device problem is gone.

0 Kudos