cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

djsteve
Adept I
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I confirm that even me managing devices is missing this: AMD Driver audio device! So no sound is heard. I tried in all the ways, but I could not solve the problem. I think it's due to updating windows 10 redstone 2, i've installed it with formatting 3 days ago. Before I've ever had audio problems now with the 17.4.3 and with the 17.4.4 the audio does not feel So, I hope microsoft and amd resolve soon with a fix patch.   Thanks!

0 Kudos
bvrned
Journeyman III
Journeyman III

Re: AMD HD Audio Device disappear with new driver

Jump to solution

None of the workarounds mentioned in the thread work for me and I don't even Creators Update installed yet. I have build 1607.

Just installed 17.4.4 and I don't see my audio device in the settings at all.

I'm using Powercolor RX 480 Red Devil.

0 Kudos
djsteve
Adept I
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I have a (sapphire nitro rx 480 8g d5 oc). I also tried installing 1.7.4.1 the information was set by creator 2, but nothing to do, comes out a message that warns me that audio drivers have problems and conflict with those installed and will be disabled, even if the windows 'Warning me of the possibility of restoring them, unfortunately they do not go anyway. I only work with these amd high definition audio devices: 21.19.137.514. We hope to settle this conflict and put out running drivers! Ps: I also tried to install only the video drivers disabling the rest ... but nothing to do, now I think I look and I keep these drivers running!

0 Kudos
romkur
Journeyman III
Journeyman III

Re: AMD HD Audio Device disappear with new driver

Jump to solution

Thank you very much,

Worked for me.

Before using ddu I tried everything and only what I was able to get was working sound when video drivers were uninstalled but as soon as I installed video drivers and rebooted AMD high defintion drivers was in error code 45 .

HDMI audio stopped working today after expres update from 17.3.3. to latest 17.4.4.

riveryeti
Adept I
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I had the same problem after the most recent update - which I did as a full update from AMD software prompting me. I tried uninstalling (clean uninstall) and reinstalling, no fix. Dried uninstall with DDU and reinstall and still no fix. Uninstalled again with DDU and tested. HDMI through monitor works. This time I checked driver versions in device manager and updated ONLY the display driver, by using "update driver" option within device manager, then browsing to unzipped install  package folder:

\Downloads\non-whql-win10-64bit-radeon-software-crimson-relive-17.4.4-apr27\Packages\Drivers

and letting update crawl the tree to search for the correct driver. Here are my notes:

After complete uninstall:

Display Adapter

AMD Radeon R9 200 Series driver 21.19.137.514

Sound Video and Game Controllers

AMD High Definition Audio Device driver 10.0.1.0

<also Realtek Audio but that's for onboard sound>

downloaded latest driver non-whql-win10-64bit-radeon-software-crimson-relive-17.4.4-apr27.exe and unzipped, then browsed to package dir from Device Manager / Driver Update (for display driver).

Driver updated to version 22.19.162.4 and sound still works.

For now I'm going to hold off installing any other AMD software unless someone gives me a compelling reason.

0 Kudos
djsteve
Adept I
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

Even I had tried to install only the video driver, but then the audio of the monitor remains without the driver, so in my case it does not work, just update the video driver to have the problem of the AMD High Definition Audio Device vanished. I'm going with these drivers: radeon-crimson-relive-17.2.1 and it all works well ... while the later ones cause the problem of the audio. I have a rx480 8 giga and windows 10 home 64 bits with redstone 2 update, clean installation! Hope we solved this problem!

0 Kudos
tbob22
Adept II
Adept II

Re: AMD HD Audio Device disappear with new driver

Jump to solution

Same problem. Couldn't get 17.4.4 audio working at all on my 390. Clean install, still no go. Reverted to 17.4.3, everything is fine now.

non-whql vs whql?

0 Kudos
tbob22
Adept II
Adept II

Re: AMD HD Audio Device disappear with new driver

Jump to solution

Or not. Rebooted again and now audio is missing again. Manually installed the 17.4.4 without using the installer and all seems to be working fine after multiple reboots.

basti107
Adept I
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

Tried nearly everything.

deinstalled with DDU

then run Driver cleaner pe with all "ati" options

run ccleaner and regclean (amd rests were found and deinstalled)

rebooted windows system (quick start disabled)

installed newest chipset driver for my intel z77 chipset (with intel update utility)

rebooted windows

let windows download the driver for my "amd r9 nano" (display and audio)

--everything is working fine (even amd high definition audio device hdmi) and even after a restart.

As soon as i install amd driver 17.4.3 (or higher) and reboot - the problem still exists.

when i now try to change the sound driver manually, windows does not let me.

It says "driver changed successfully" (or so) and i reboot - still have a disconnected audio device and the same (newest) driver as before...

On my other computer (r9 nano (sapphire)) and socket am4 with ryzen 1700x i do not have this problem.

Maybe it only happens on asus-cards...

i give up

0 Kudos
djsteve
Adept I
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I also tried the new 17.5.1 to see if the audio problem on hdmi had been fixed, but unfortunately the problem remained as before ... if they are going to not solve the audio problem I think I will abandon amd to switch to nvidia , It may not remain a monitor that works with 17.2.1 drivers and then with the next no!

0 Kudos