cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

hipoalergeniko
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I´m experiencing this issue too with every driver after 17.2.1 including the new 17.7.1

GPU Model: Gigabyte Radeon RX 460

Make and Model of the display:  Samsung SB23B300B

Type of connection to the GPU: HDMI-HDMI

Cable Model Number: none

Display Adapters: none

Amplifier: If yes, which model number? none

When does the issue occur? After restarting the PC

My pc is a desktop using windows 7 x64. I have done the clean reinstall with DDU too.

OS: Windows 7 x64 Ultimate

CPU: Intel Core i3 4150

RAM: 12GB

Motherboard: ASrock H81M VG4

Graphics: Samsung SB23B300B (1920 x 1080),  Gigabyte RX 460 4GB

Current Driver Version: 17.7.1

laser
Journeyman III

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I updated to 17.7.2 from 17.1.1 and lost HDMI audio.  I uninstalled the old drivers per the Catalyst Manager.  Restarted in safe mode and ran DDU.  Restarted and installed the new drivers.  Restarted and had no sound.  Re-ran the process and installed the old driver, 17.1.1, and still no sound.  I have installed many drivers on this card, 270x, and never had an issue.  I am running Windows 7, 64.  Any help appreciated.

dogola88
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I still have this issue with 17.7.2-july27. HDMI audio device is always gone after restarting past the driver installation. It was available before restarting and worked. Same happens after a clean install after I removed everything with DDU. There were never any issues with the HDMI audio device prior to a certain radeon crimson version. You must have changed something that breaks it.

I'm using Win7 Enterprise SP1 x64

Gigabyte R9 270x 4GB

Intel Core i5 4570

HDMI-HDMI connected to a TV, DVI-D to BenQ screen

Gigabyte Z87x UD3H board (Intel chipset)

0 Kudos
dogola88
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

>Please provide a link to download just the HDMI driver,

This please

0 Kudos
it-wizard
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

devicemanager.png

Still having this issue with newest driver 17.7.2.

GPU Model: R9 280x

Make and Model of the display: LG 55EG910V

Type of connection to the GPU: HDMI from gpu and to tv w HDMI

Amplifier: Yamaha rx-v479

Regression: What was the last Crimson driver that worked with AMD HD Audio? Eg Crimson 17.4.x something....

When does the issue occur? Device is missing from audio devices until I remove AMD Radeon R9 200 series device from device manager and search plug & play devices. Then I get the High defination audio device back until I reboot... I have tried all the different drivers that are available for the device, it still disappears on every boot. I have uninstalled and reinstalled drivers countless times, this is getting really frustrating.

comppi
Journeyman III

Re: AMD HD Audio Device disappear with new driver

Jump to solution

Doesnt work still. Latest that works is 17.2.1. anything newer and audio is gone. Kind of pathetic really. Latest drivers I've tried are 17.7.2. Using 280x with windows 7 64bit .

brak215th
Journeyman III

Re: AMD HD Audio Device disappear with new driver

Jump to solution

CPU: AMD FX 8350

GPU Model: XFX R9 270x, and XFX R9 390 (390 is my primary, ran test with 270)

MoBo: Asus M5A97 LE R 2.0

Sys Mem: 16gn

Display Make and Model: LG M2762D TV/Monitor

GPU Connection: HDMI

Cable Model: N/A

Display Adapter: N/A

Aplifier: Sony STR K670P

Regression: I reverted to Crimson 16.7.3, Issue occurs after updated to new driver installation.(Run DDU in safe mode, uninstall previous driver, Restart)

0 Kudos
daniel_1
Journeyman III

Re: AMD HD Audio Device disappear with new driver

Jump to solution

I have the same problem.

OS: Windows 7 64

GPU: Vapor-X R9 280X 3G D5

Connected to:

Yamaha RX-367v through hdmi-hdmi (Routing to a LG PK550)

Samsung P2350 Monitor through dvi

Hdmi Audio works with driver 17.2.1 and before. Every driver past this, including the newly released 17.7.2 doesn't have working audio through hdmi connection.

What's really irritating is, when i deinstall the 17.7.2 for instance, i get immediatly after the deinstallation (through amd uninstaller) is complete (without reboot) the HDMI Audio driver back and working. Windows just finds it and Bam... there u got it.

Did a great amount of installing and deinstalling with all the suggested routines using ddu etc.

I cannot understand how this is a problem to replicate and to fix this. It is a core feature of the GPU and a common way to transport sound these days. I also have a dedicated soundcard and could bypass this problem by using that (it would only transport PCM though), but i payed like 250 euro and expect this to work out of the box (ofc with driver updates). So all in all it is 5 months broken already. I would greatly appreciate a fix for this. Other than that it is a great card and it still holds up well for my gaming things.

Kind regards

Daniel

it-wizard
Adept I

Re: AMD HD Audio Device disappear with new driver

Jump to solution

This is getting kinda ridiculous 6 months and the HDMI sound output is just a dream. I think I will buy and NVDIA card at least they can get simple things like these working....

rust
Adept II

Re: AMD HD Audio Device disappear with new driver

Jump to solution

1. Problem still egsist, nothing helps. ?@?#$@!?$ again ?

2. Where do i find old drivers?

3. Why, why, why, why, why problems witm my crossfire 7970m's exsist for couplle years now. For years now i installed only drivers first and then after restart HDMI driver separately. Now YOU made those drivers combined for some reason lately and i'M BACK to worst technical support i ever experienced, WHY?

0 Kudos