cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

set
Adept II

AMD Graphics drivers produce infinite zombie processes

The issue is present on Windows 10 and 11, from Adrenalin 23.12.1 to 24.3.1 for integrated graphics on Ryzen 9 7950X.

The issue is not present in 23.11.1 or for system with only discrete graphics like Radeon RX 6900 XT (other CPU).

 

Steps to reproduce:

1) Install clean Windows 11 23H2 on system with Ryzen 9 7950X and no discrete graphics, with no internet access.

2) Check that the issue is not present on clean system:

run FindZombieHandles.exe

run in cmd FOR /L %i IN (1,1,1000) DO cmd /c echo %i

run FindZombieHandles.exe again: the same amount of zombie processes.

3) Install whql-amd-software-adrenalin-edition-24.3.1-win10-win11-mar20-rdna.exe

4) Repeat step 2: now all 1000 spawned processes turned into zombies with no apparent owner.

 

The system with affected drivers becomes completely unusable for me after some time: the system consumes dozens of GB of RAM outside of any apparent process, as I need to run many short-lived processes.

 

I'm not sure is there any other resource leak in drivers, but the described one is apparent.

10 Replies
set
Adept II

The same issue is present in 24.4.1.

The issue persists in 24.5.1.

More than that, Windows Update now automatically pushes the buggy versions over stable 23.11.1.

evil_doer
Adept II

Thanks for doing the legwork on how to quickly and concisely show this issue. Now we just need to get AMD to pay attention. 

Ive used the issue reporting tool to point towards this thread. Others should do the same.

Soupar
Adept I

I can confirm this issue with 24.5.1 on Zen4 7540U (Windows 11 23H2) - reverting to 23.11.1 solvies the memory leaks.

 

I am frankly astonished something like this isn't solved over half a year and multiple driver versions, esp. because I'm running a very recent Zen4 APU. I've reported it to AMD with their bug report tool, too.

vhnvn
Journeyman III

I've been struggling with this bug for six months on my GPD Win Max's 7840u using the 23.11.1 driver. Every month, I tried updating to the latest version, hoping for a fix, only to revert back. Now, my 7840u device is broken, and the 23.11.1 driver won't install on my new 8840u. I have to reboot 3-4 times a day. As a coder, this is unacceptable because I rely on mass process creation (just opening VSCode spikes RAM usage).

 

vhnvn_0-1719067583179.png

 

This bug likely affects ALL new GPD devices with AMD chips. Users who only game or frequently shut down their devices might not notice it. This issue needs urgent attention, possibly even media coverage, to get AMD to acknowledge and address it, as it impacts all new gaming devices.

mbo8
Journeyman III

Here's the same issue on StackOverflow, which links to other resources and provides additional details: https://superuser.com/a/1841601/183887

 

A very bad look for AMD.

Soupar
Adept I

Concerning reporting with the AMD tool:

I reported the bug with the older driver installed, i..e it's possible it might be ignored because only reports with the newest diver versions are considered?

I had refused to install the buggy driver again just for making the tool happy - but I provided a detailed decription what driver versions are affected.

 

> Here's the same issue on StackOverflow

The latest working driver seems to be 23.11.1 - the thread on Stackoverflow states 23.10.2.

 

> This bug likely affects ALL new GPD devices with AMD chips.

How can you tell? The public reports I see are rather few considering the severity of the bug- not _all_ Zen4 systems might be affected.

Circumventing the issue by disabling the iGPU figures because this probably is often the case on desktop systems, límiting the visibility of the bug.

On my laptop, the memory leak issue was brutal even with 16GB - maybe other systems have more memory installed and the issue takes longer to fill up the pagefile and crash the system.

 

 > A very bad look for AMD.

The only look AMD is probably interested in is their bottom line.

Alas, if  jets dropping from the sky or losing parts in-flight is just another day in the office nowadays, companies might have developed a remarkable resilience concerning bad media looks.

0 Likes
mbo8
Journeyman III

0 Likes

It's the same issue, I've just did clean and precise reproduction. Wouldn't call it a dupe as neither was acknowledged by AMD.

 

Some more info: as expected, the issue is within amdkmdag.sys – you can change all the other driver files to ones from other versions and behavior will persist. (So, you can "upgrade" all the other files, though I'm not sure is there any usefulness in that.)

0 Likes