Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

AMD fTPM Causes Random Stuttering Issue

Good evening together
I wanted to ask if anyone here knows anything about the still existing fTPM Bug in Windows 11 or in Windows 10 as I have heard in the meantime.
I am affected by the bug myself and it really gets on my nerves to have to go into the bios every time I update to activate fTPM and then immediately deactivate it again so that I don't get jerks and sound problems. I have a x570 Steel Legend board with the latest bios and 32 GB Ram Trident z Royale Gold. It would be really time that one of AMD times to this but very widespread problem.
If there are errors in the text I apologize for it because I come from Germany and English is not my greatest strength.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC
145 Replies

Just stumbled upon that ViveTool Command and clearing TPM with the Microsoft TPM Manager within a link from the first page of this thread.

So I enabled fTPM again and did so, too early to tell if it fixed the issue - AGESA did NOT fix it as mentioned before.

I swapped the board for an B550M PRO-VDH WIFI (I also swapped the installed cheap Intel WIFI module with my good Intel AX210, that worked flawlessly) one since I did not get a dedicated TPM for the Biostar board. The dedicated TPM however caused issues with input lags on mouse/keyboard for some unknown reason, so I removed it. It was no original MSI part, but compatible with MS-4462 and has been detected by the UEFI without issues. Even that cheaper module was 40 Euros - a rather bad joke for that small part!

Now fTPM is re-enabled.

The ViveTool command has been mentioned here:

vivetool addconfig 31621124 1

Windows TPM Manager can be started with "tpm.msc" - on the right side, click "Delete TPM" and restart the machine.

Like I said it is too early to say if it worked or not. If I have still issues. i might send the board back to Amazon (and put the Biostar B550MX/E PRO back in since they are very similar, except the Biostar has no ARGB header, but I have a standalone ARGB controller I can use instead) or buy an MSI original MS-4462 to test.


Yes, @AW3S0ME I also have a rev. 1.0 X570 Aorus Xtreme and unlike you get the stutter, isn't this a lovely mystery, some people getting it, others not.

The latest AGESA did seem to make frametimes really consistent and the system effectively runs perfectly apart from this issue, they really did improve performance in some way. I also have a couple of top of the line PCIe 4.0 SSD's, a Radeon RX 5700XT and 64 GB of nice 3200CL14 ram, this really is the only issue I have with the system and I hope they are taking this seriously for us, even with Zen 4 on the horizon.

I think that it also took several BIOS releases before people's USB issues were resolved, therefore I'm optimistic.

@TimeTurn, I recommend that you just keep your new MSI board if you already built your system and keep the Biostar as a spare for yourself, you never know when you may need to RMA your primary motherboard and then you would be without a computer for a while. I wonder what ViveTool does, I don't feel comfortable entering some cryptic command into my system and would prefer an official fix, however, keep us posted.


Same here, i have a Aorus B550 Pro Ac and the latelast bios and still have stutters when FTPM is on, im so dissapointed with AMD, its been like more than a year and they still cannot fix the problem.


I have the Aorus X570 Elite with the latest F37d BIOS update, but still have stuttering. Which version do you have now?`Is it fixed or not? I'm searching the Internet, but I don't find anything. 

Not applicable

before updating your bios, the FTPM protects the bios flash and prevents tampering.. so to update it.. you need to go into cpu options and lower the security so you can modify it is how i understand it. then once you reboot and the bios is updated it is supposed to be always enabled by default in the CPU settings and CPU options but yes there may be some bioses it must be re-enabled on.. just check that your security is secure by setting it to ON again. 

from what i understand it you're complaining the padlock you are using needs to be unlocked to open the gate?

is that what your problem is? and locked again if you want the gate secured?? well.. i .. .. i seriously cant help you man we're all in the same boat. I was complaining and so were others that the bug was that it was on some boards or some bioses OFF by default WHICH is the bug. like "yo i bought a new fully furnished castle but the front gate is wide open and theres maybe nothing left in there quick lock that stuff down ?! is anything missing?! what the? i dont know if something was taken, was it supposed to be like this? how many or much of this was there supposed to be? i better open it up and clean it out and fill it back up with new version of bios goodies and then, oooh man did that guy do something so my new bios isnt taking effect? was this castle already breached by somebody the moment after it was built, if i lock the door up now is there a tunnel someplace in the back yard?" 

I am using BIOS F16c for Gigabyte B550 AORUS ELITE AX V2 with a 5800X and it still happens, in a single evening got it 3 times.


Agesa 1207 is useless when you have PBO edc bug it makes PBO unstable with default PBO on i get system stability issues after agesa 1203c ironicly after going back to 1203c which latest fine bios if not had tpm stutter and if had it on both discrete tpm and ftpm so perhaps its related to edc bug, perhaps go ahead and fix that ?

Right now i am stuck on agesa 1203c until its fixed with discrete tpm chip i usually get tpm stutter once after clean install in first day and then i stop getting it, if also noticed microsoft game overlay in windows 11 least causes similar sound effect and stutter when achievement pops up including the sound


Does anyone know if AMD will pull support from Asus and Asrock for their refusal to update the bios on older boards? Only Gigabyte updated there b450 board I have back in May. I have 2 more a ASUS b450 and a Asrock mini pc system based on the A300 chipset.


Asrock is just slow. They not even updated all 500 series.

I see that they releasing beta for 450\470\520. We need to wait.



You probably meant to say F15c... There is no F16* released yet.
The latest F15 versions with AGESA V2 have fixed stuttering issue on our Gigabyte motherboard.

Just for info - there is another completely unrelated stuttering problem that is up to GPU's of RX 5000-6000 series.
So, in order to get proper solution you have to determine which one exactly is this.


I used LatencyMon to help diagnose the stuttering. Basically run it for a few hours and see whether you get spikes and if so what is actually spiking and during what. In my case I could see spikes happening at regular intervals even when the graphics card was mostly idle (like sitting in windows listening to MP3s and working in a spreadsheet). That points towards fTPM.

Conversely if you don't see latency spikes until you put the GPU under load it's probably not fTPM causing you issues (though it is still a possibility).


I think the GPU stutter is related to the AMD External Event Utility in Services.  I could be wrong though but when I disabled it the stutter went away.


I tried to disable AMD External Event Utility service, unfortunately in my case it didn't fix the GPU-related stuttering issue.
So far the only way i found to get this kind of GPU-related stuttering off is to prevent the GPU from going into idle mode.


GPU stuttering effects that i observe here, unlike fTPU stuttering, affect specific devices only (such as keyboard and mouse). So, DPC latency monitors detect no any latency spikes in this case.
These effects occur exactly when the GPU is in idle state (probably, it is related to the GPU power saving modes). If GPU or at least GPU memory turns into no idle state, stuttering effects disappear.

Anyway, this is another subject, should be mentioned here just to keep this in mind when diagnosing fTPM stuttering issues...


We have completed an investigation and managed to isolate an issue. A USB stuttering was motherboard-related and caused by EMI issues, since those Gigabyte motherboards were proven to have specific PCB and/or schematics design faults their built-in USB 2.0 hub has certain stability issues that they have been trying to resolve by several BIOS updates, which wasn't effective enough though. A USB stuttering issue has begun right after PC configuration change (video card replacement), therefore investigation at first steps went into the wrong direction as we supposed a GPU was a stuttering issue culprit. In fact, unlike previously installed video card, new video card emits such EMI patterns that trigger a built-in USB hub stability issues on those Gigabyte motherboards, nevertheless their recent BIOS fixes. As a workaround we now use 4 ports of FCH-based USB 2.0 hub instead, that works flawlessly.

It's likely such/similar problems may occur with any motherboards of any other vendors as well. Such cases should be mentioned somewhere in FAQ, since there's enough of criticism towards AMD already, no need even more especially for something completely unrelated at all, like in this case.


I run a gigabyte aorus master x570 and I'm happy to report that since AGESA the stuttering issue I had disappeared.  I did, however, find that some windows changes reenabled usb hub power conservation which made my system stutter in confusion but once I disabled all of that I never had another stuttering incident.

@hrpuffnstuff wrote:

I did, however, find that some windows changes reenabled usb hub power conservation which made my system stutter in confusion but once I disabled all of that I never had another stuttering incident.

Could you describe this in more details please, what was done, step by step, to fix that another stuttering issue?

Adept I

i had my pc crash and freeze as of today multiple times with fTPM

i have the same error 

crosshair viii hero x570

ryzen 5800x


GetCACaps: Not Found
{"Message":"The authority \"\" does not exist."}
HTTP/1.1 404 Not Found
Date: Tue, 10 Jan 2023 08:25:06 GMT
Content-Length: 121
Content-Type: application/json; charset=utf-8
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=31536000;includeSubDomains
x-ms-request-id: ede6b87f-84c2-4fe9-868e-744069e2e947

Metod: GET(171ms)
Fas: GetCACaps
Not found (404). 0x80190194 (-2145844844 HTTP_E_STATUS_NOT_FOUND)

Journeyman III

same here my pc crash every game and freeze as multiple times I've tried everything and nothing


ryzen 5600x

GetCACaps: Not Found
{"Message":"The authority \"\" does not exist."}
HTTP/1.1 404 Not Found
Date: Mon, 13 Feb 2023 04:53:42 GMT
Content-Length: 121
Content-Type: application/json; charset=utf-8
X-Content-Type-Options: nosniff
Strict-Transport-Security: max-age=31536000;includeSubDomains
x-ms-request-id: be8f575c-4c1d-450c-8658-4ebd2846c421

Method: GET(531ms)
Stage: GetCACaps
Not found (404). 0x80190194 (-2145844844 HTTP_E_STATUS_NOT_FOUND)


They have never fixed this issues. I just turned off the ftpm. I tried everything, reinstalled Win 10/11 over 30 times. Next CPU will be intel again for sure.

IMHO it would seem that AMD's validation processes are inferior to their competitors allowing issues like this one to persist in their products.  And more to your point I got fed up last fall and went back to Intel and Nvidia just before Christmas and don't regret it one bit. 

It was expensive but well worth it to me for the stability alone.  All of my future systems will always have Intel CPU's and Nvida GPU's.

Last week I had to wipe my friends new Lenovo Legion 5 laptop so I could install W11 for him as it would not upgrade with AMD hardware just like every other machine I've tried running the 10 to 11 upgrade on.


I myself have just decided to buy a new PC with Intel & Nvidia hardware lol. My black screen crashes returned and the SCEP errors are back on start up too now this is disappointing i was very happy but i am buying a new PC nothing can save this one it seems like... Last Intel & Nvidia machine lasted for 7 years this one for 3 years lol!


I've tried to stick to a 5 year cycle but AMD broke it with the x570, 5950x and aib 6900xt I was running at the 3 year mark.  I expect to keep my rtx 4090 for at least that long as its really overkill for what I run.   One thing I can say about it is that it never gets hot while gaming like my 6900xt did.

The 13900k rocks and is super fast and since my mb, MSI MEG Z790 ACE has 5 nvme ssd slots it has the IO to feed my hardware.  I replaced all of my old ssd's with 990 pro's, one 980 pro and a WD SN850x 4tb for my games. 

I admit to being a former AMD fanboy rocking their merch back in the 90's after building a 5x86 pc that could beat a pentium 100 for much less.  I had a slot a athlon system and an opteron but went back to Intel when the core2duo came out. 

Last two systems were an x58 with a 930 enthusiast build and then a 4790k until I went back to AMD with the X570 on a gigabyte aorus master.   Started out with a 3900x then upgraded to a 5950x with a 5900x as a spare that I used when I rma'd the 5950x.  Built that system on a gtx 1080 amp but upgraded to a xfx rx 6900 xt black.

Its a shame but when I reached the point that I was not willing to put up with any more I went into my wallet and shelled out for a gigabyte rtx 4090 gaming oc.  I had hoped to skip this gen but I got tired of watching my 2nd monitor blank out at random intervals while I was using it.

After watching Asus and Gigabyte fall from grace I went with MSI for this build and so far this has been one solid motherboard albeit expensive.

I know that the Linux kernel recently abandoned one fTPM function because of this issue. Specidically, it no longer generates random numbers for security with the fTPM, instead using the CPU instruction RDRAND.

Adept I

This is an ongoing issue which AMD has claimed to fix many AGESA release past. It is not just a Windows issue as Linux kernel has developed a software fix that dumps certain portions of the fTPM in relation to the software side. Linux Decides To Disable RNG On All AMD fTPMs - Phoronix If you need a TPM, say for Win 11 just buy a dedicated TPM if your board supports it. I received the occasional fTPM corrupted prompt when using with a Gigabyte board, but never the stuttering reported with a 3900X. (This corruption appears to be specific to Gigabyte boards.) Purchased a $20 dedicated TPM and problems solved.