Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept III

AMD fTPM Causes Random Stuttering Issue

Good evening together
I wanted to ask if anyone here knows anything about the still existing fTPM Bug in Windows 11 or in Windows 10 as I have heard in the meantime.
I am affected by the bug myself and it really gets on my nerves to have to go into the bios every time I update to activate fTPM and then immediately deactivate it again so that I don't get jerks and sound problems. I have a x570 Steel Legend board with the latest bios and 32 GB Ram Trident z Royale Gold. It would be really time that one of AMD times to this but very widespread problem.
If there are errors in the text I apologize for it because I come from Germany and English is not my greatest strength.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC
145 Replies

When dealing with new software especially in a transition point between operating systems I find having a few USB flash drive sticks very handy.

Download your GPU drivers to the flash drive. Disconnect your PC from internet and do a factory reset install of your GPU drivers.

Sometimes installing drivers in a different way (not directly through internet) can bypass some issues.

As how this may affect TPM I have no experience there yet. My motherboard supports TPM and Secure Boot in the Bios.

I don't use either as I am running Windows 10 Pro 64 version 21H2. Only Windows 11 requires Secure Boot and TPM.

Though I have seen a lot of videos of PC builders experiencing some very frustrating issues with Secure Boot and TPM.

Adept III

This is not due to the graphics card driver but to the fTPM security mechanism. If this is activated in the bios, micro-stutters and sound disturbances occur at irregular intervals.
I have to deactivate this function to eliminate the problems. This is only quite cumbersome because I have to re-enable this function with each new Windows 11 update to get the updates. I have a link here where this is described.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC
Adept I

Take a look at this post and comments.

As far as I know, the only thing you can do right now to get rid of that, is deactivating fTPU or buying a HW Modul for it. Like the ASUS TPM-SPI Modul for Asus MBs.

Or hoping for any further UEFI/BIOS Updates to get that fixed asap, for having a chance to enable it again in the future.

I only had the option to disable it in the bios to finally get this problem under control which is counterproductive. AMD and Microsoft apparently do not deal with the problem because it does not seem important in their eyes (at least that's how it seems to me). I think it's an insult to deal with paying customers. But I have at least now found for me a temporary solution as I handle the problem without giving up fTPM. Write here times a link to how to get to the appropriate program or the solutions. In my case I have tried it with the Vive Tool and it works so far quite well.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

Very interesting...
I noticed a problem that looks similar, but didn't know it was related to some kind of issue in the interaction between Windows OS and fTPM.
In my case it occurs quite rarely and only on the PC's where Windows 11 is installed.
Once in a random time intervals (from several minutes to half a hour) a system gets completely 'frozen' for a moment (about 0.5 seconds or less), including sound and video outputs.
I'll check this out whether it occurs with fTPM disabled.

That is the big problem that you can not really isolate when the error occurs. I have noticed that it only occurs on AMD CPU's on all board configurations and mostly on Windows 11. Some users also report that it occurs on Windows 10, but then mostly only on the latest builds.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

With fTPM disabled a stuttering effects didn't occur anymore. Well, it was expected.
But then when i've enabled fTPM back expecting a stuttering should get back again, it still doesn't. It's already a second day with fTPM enabled, no any stuttering noticed so far.

The stuttering and cracking also always occurs in different scenarios. I, for example, had it yesterday very often (12 times) within 4 hours, but then again only 2 to 3 times throughout the day.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

That can also be a result of running too high of an fclk. I'd get similar if I tried to run RAM at 4000 and fclk at 2000 with a 5600x and 5800x

ThreeDee PC specs

Apart from the fact that I have not changed the FLCK value and have not attempted any further tuning, this problem occurs across the board and across processor generations and mainboard constellations. It has been reported for a long time in various forums about this problem and all solutions that are temporarily offered fail or only last until the next reboot of the operating system. I'm already glad that now someone from the technology has spoken on the part of AMD and hopefully this will be fixed quickly.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

In my case all of the clocks, including Fclk, are set by default except memory clock that is set by XMP profile to 3200MHz (with Fclk=1600MHz). Processors are 5600G and 5700G.

..generally .. anything over 3200, and then you have to manually set the fclk to match your RAM speed

ThreeDee PC specs

Disables tpm no stutter, must be fclock issue no stop spreading missinformation, many already told you the issue only happens with tpm enabled

learn to read before posting perhaps? nothing in my last post about fTPM , but thanks though.. 

ThreeDee PC specs

Maybe you should learn to read yourself because your clearly posting in the wrong topic.

I can confirm and reproduce this bug, thought I was going crazy. Lately I noticed it a lot in the game SiFu. When I turn off fTPM the stuttering goes away but then I'm left with a broken Windows update. Using an ASUS X570-P rest of my hardware is in my signature. I don't have these issues with linux, it's becoming more and more tempting to run everything on wine/photon and be done with this trash operating system for me. 

Distro: Manjaro Linux - Kernel: 5.15.19-1 - RAM: 32 GB - GPU Driver: 4.6 Mesa 21.3.5 - GPU: AMD (PowerColor Fighter Radeon 6600 8gb) - CPU: AMD Ryzen 9 5900X 12-Core Motherboard: Asus-X570-Prime

I bought a Asus tpm 2.0 spi module and it did not solve my problem, there to many placebo's with tpm stutters that only happen sometimes like once a month, and with ftpm being on default for discrete for many old bioses without chip installed there a lot of false reports of having no issues even tho these users do not even have tpm enabled.

I had the issue on my Asus TUF x570 Plus. On Windows 10 and 11, with fTPM enabled. CPU is a 3900x.

Got me a discrete TPM module and it resolved the issue. Ofc you also need to switch from fTPM to the discrete module in the BIOS.

I'm on my PC for up to 16 hours a day and I would see the stutter like maybe 3 or 4 times per day.


I am part of the Vanguard Beta GPU driver program .. this was posted over there in their Discord

"- for those of you affected by fTPM related stuttering with Ryzen CPUs, can you please try the following procedure to see if it resolves the issue: Details: Affected users may find Event Viewer Application and Service Logs\Microsoft\Windows\Crypto-Ncrypt\Operational events where Task Category is Open Provider Failure with status 0x80090030 (NTE_DEVICE_NOT_READY) indicating that the TPM may not have been provisioned correctly.

Solution 1 (Recommended): Running the TPM-Maintenance task may resolve this issue. The TPM-Maintenance task may be run automatically after restarting the PC. TPM-Maintenance may be found under Task Scheduler (Local)\Task Scheduler Library\Microsoft\Windows\TPM in the Task Scheduler App. Alternatively, run as admin: schtasks.exe /Run /TN Microsoft\Windows\TPM\TPM-Maintenance

Solution 2 (NOT recommended if you use Bitlocker): If this issue persists after running the TPM-Maintenance task, Clearing the TPM may resolve this issue. Run the Trusted Platform Module (TPM) Management console (TPM.msc) or open “Security Processor Troubleshooting” settings to find the command to clear the TPM. For more information, refer to this Microsoft article:

Warning: Clearing your TPM causes you to lose all TPM Keys. Be sure to back up your data and Bitlocker recovery keys before clearing the TPM or you may lose data. Try running the TPM-Maintenance task before Clearing your TPM.

ThreeDee PC specs

I have tried the first solution and will report in 2 days whether it has brought something. The solution I had previously proposed with the Vive Tool has unfortunately not held very long and the Mcro stuttering and the crackle at Audo occurred again today with me. I'm trying everything so that finally this **bleep**ing problem can be fixed. I find it really sad that no one from amd comments on the problem

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

I've just checked the logs on one of the affected PC's - when fTPM was enabled there were no such events with Status 0x80090030 at all. Since the hour when fTPM is turned off, these events begin to occur several times per minute, so far. And so far (all the day today) we didn't notice any stuttering on that PC with fTPM disabled.

Fortunately, we don't use these affected PC's for the tasks where this kind of issue would be critical, so i didn't pay much attention to this issue when noticed it for the first time (especially considering this was just normal thing with our old Intel PC's, where a stuttering caused by EIST occured as often as several times per minute).
Of course, for any real-time tasks, such as audio recording, this issue is unacceptable at all.

Community Manager

Thanks for all the posts.

We are currently investigating the issue and I will update this discussion when I have more information.

Hi Matt

Thanks for posting and letting us know this is being looked at.

When the issue is fixed would you be able to obtain a quick technical summary from your internal team about why this issue happens and publish it? I am just rather perplexed why there are people saying stuff like "I've run my AMD system with fTPM on for over a year and not had any stutter" and then reports of "I've had stutters every day for the past 6 months since I enabled fTPM".


Finally there is a responsible person who takes care of the situation or at least makes a statement that the problem is in progress. Thanks for the info Matt

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

I have tpm stutter with ftpm disabled and tpm set to discrete tpm with a discrete chip installed


If had tpm stutter with ftpm enabled as well, after hearing discrete chip could solve it i installed one, and within 1 hour i had first tpm stutter.


Here's hoping a fix can come in the latest upcoming BIOS updates :3

How is there still not a solution to this?

Hello i am sorry to bother you but is there any update on this issue with stuttering and SCEP certificate initialization failure ? As far as for the SCEP Certificate issues or also called Event 86 issue Seen here: Thread

it seems like its caused by the fact that whoever has control of the attestation server for attestation of fTPM has removed some certificates and the TPM or the OS calls for them and it returns a 404 and then the PC's crash. For example the user who made the Thread on this forum the certificate was removed around 15-March-2022 and my certificate was removed around August 1st 2022. I am not sure what can be done about this maybe bring the removed certificates back on the attestation server ?

But it would be nice to get some kind of status update is anyone looking at this because its kind of bothersome to have a full system crash every 2-3 hours and this laptop lasted me 2 years and now its almost unusable because of this fTPM issue. I am also not sure maybe this can get fixed by a Chipset update ? either way please if you are able to provide a status update we would be very grateful to know if anyone is looking into fixing this!

Feel free to email me for more information if required!  I'd love to help in any way i can so we can fix this issue that seems to affect certain types of fTPM users & certificates.

Thank you!

Hello baruni
If your motherboard can accept a TPM chip you can find out from the manufacturer. There are also reports that the problem cannot be 100% eliminated even with external TPM chips. In addition, the prices for such TPM chips are exploding. At the moment, we can only hope that AMD will provide a solution for these problems as soon as possible. If you can't or don't want to wait, you can only switch to Linux, as you could find out here and on the web, because there you probably won't encounter any problems.


AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

Is there a way to reliably reproduce the fTPM stuttering issue? I thought I saw it in MS FS2020, but the random, sudden FPS drop I was seeing didn't disappear when I disabled my motherboard's fTPM in the BIOS.


I myself have tried just about everything to bring this error manually, but unfortunately for me not reproducible. As far as I know, no other user has managed to "force" this error.

AMD Ryzen 5600X, Asrock X570 Steel Legend, 32GB G Skill Trident Z Royal Gold, AMD Rx 7900XTX, Gygabyte G34WQC

Several days ago i've enabled fTPM back, expecting a stuttering effect should get back as well. But it didn't.
Yesterday at evening, unexpectedly, a stuttering effect has begun to occur again. All these days since the moment fTPM has been enabled a PC was used as usually (usual work in office programs and in web-browser, with permanently running internet-radio in audio player). Since the moment fTMP was enabled and prior to the stuttering effect has begun to occur there was done nothing special that probably could trigger this effect, except one thing - couple of hours prior to this, a PC was in Sleep and then in Hibernate States for a while. I'm unsure if it could be a trigger, more time and tests are required...

If had tpm stutter happen from once a day to once a week to once a month, its not really worth disabling for fix if you have it once a month, once a day tho......... i honestly think Microsoft is slowly making improvements seeking the boundaries of how far they can go without anyone complaining about it or noticing it, and some machines perhaps with more drives or something else are effected more then others.

I have 1 2 tb nvme for example + 2x 1 tb ssd and another 2x 2 tb ssd's and a 4 tb mechanical drive.

i went from once a day to once a week to once a month last stutter i had during clean install when i switched out 500 gb nvme for a 2 tb one and added a discrete tpm chip cos of some people claiming that this fixes it, even making sure it was actually on discrete and enabling even SHA-384 cos the tpm chip supported it, and within an hour i had my first tpm stutter.

I swear only scalpers are claiming it fixes it while it actually does not.

the issue is probably not tpm it self but the way AMD cpu's handle tpm rather cause them to freeze up perhaps while circumstances under where it happens and hardware combinations are unclear.

Its probably windows issue while it effects mostly AMD users, however that does not change the fact AMD should probably look into it and poke at Microsoft to also look at it since it does effect their operating systems, not just windows 11 but also windows 10

I also have this issue on a Lenovo Legion 7 with a Ryzen 7 5800H running Windows 11 with fTPM enabled.

Actually, i'd like to see at least something that proves this issue in this case is up to a harware and not up to a software (meaning Windows10/11 OS with any related software). There seem to be nothing of this so far. More than that - this issue doesn't occur with another operating systems where fTMP is being used. Nevertheless, in a lot of messages on the internet forums it's for some reason stated, completely unreasonably, that it's a hardware issues. It's quite odd.

IDK about stuttering but my desktop with a 5950x on x570 chipset randomly loses its ftpm settings and gives a bios warning during post to reset itself.  Since I don't run bitlocker I just clear it out and let it populate again then go on.  My laptop running a 5800h has never displayed such an issue and both run 11 pro.

This does not happen on Linux and it also does not happen in windows with fTPM disabled in the bios. From those 2 data points we can deduce that it is in fact a software issue. Isn't fTPM a software implementation of TPM?

I have a MSI B550-A Pro mobo and a Ryzen 5 5600X CPU. I have had the fTPM enabled since December and have not seen any kind of stuttering issues at all. I game pretty heavily too and no problems.

I'm seeing a lot of people reporting the problem with X570 motherboards.  Could it be a factor to investigate?  My B550 is not having any issues.