Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

Amd driver replaced by windows

Immagine 2022-12-08 104421.jpg

Hi, my monitor goes black sometimes, and then the amd software tell me this. I want to gpedit to double click the feature tonot include the drivers with the Windows update's. Still having the problem

12 Replies
Adept II

This is wrong, your driver isn't actually getting removed by windows, it just crashes and can't restart itself (rebooting your PC would restart it). This is the infamous black screen bug (google it) that has started to increase dramatically in numbers on amd cards over the past few months.


Does this happen more often/exclusively when you switch tabs/switch to second monitor? If so, consider disabling MPO (again, google it), this isn't a 100% solution but this has helped a lot of people, otherwise wait for AMD or possibly Microsoft to adress it as there are allegations that it's Windows fault and not AMD's

ill'try thanks!



This issue has nothing to do with MPO, the error message explicitly states that the driver has been replaced.

I have had the exact same problem. The driver would crash (most of the time during alt-tabbing), and the screen would go black. Sometimes it would fix itself after a minute, other times it would not and would need a reboot to work again with the monitor, but I'd still be able to access the computer via my Steam Link app on my phone.


In both cases unless I reboot my PC if I would try to start the Radeon Settings app it would give me the same message about windows reinstalling the driver.

I believe this message is just a generic one, the app thinks that windows replaced it because after a driver crash it can't reboot the driver properly and just notices that the driver doesn't work with the gpu installed

Hell, twice even after rebooting my pc for the first time it would still be displaying that message when i would try to launch the app. A second reboot would fix that issue in both cases though


After being plagued by these crashes for over 2 months I've eventually found out about the MPO thing and disabled it. Now the black screen crashes are gone and subsequently the erorr about drivers being incompatible/suggesting windows has replaced them is gone too


By the way, I've made several reports about this behaviour to you guys via the radeon software app bug report feature, and I know for a fact that this issue is widespread (just one of the threads on the guru3d forums, which was started on October 1st 2022, has like 20+ pages), but you guys not only failed to adress it so far, you didn't even include the issue in the list of known issues with the drivers on the driver update page. Very disappointing.

Adept I

Roll back the driver in Windows device manager. Let it search for a new driver, then hide the driver update. That should fix it.

Disable Windows Update for drivers.

This Windows website gives you step for step instructions: elevenforum- enable-or-disable-include-drivers-with-windows-updates-in-windows-11.2232/ 

If you don't want to go the above route then use Microsoft Hide/Unhide Tool to hide the driver update from here:  Microsoft Hide/Unhide App from Major Geeks 

Doesn't work


I also tried these steps with registration etc. and it worked until Win11 informed me that the driver was automatically removed.


I had the exact same problem as you originally posted. I think somewhere online there was an article on three ways to prevent this unwanted automatic window driver update. One of these methods was editing a parameter named somethingoranother in the windows registry (using regedit or something like this). Try a websearch. If I can retrieve the article link I'll try to post it here.


The link that I posted from Windows 11 Eleven Forums in my previous reply shows 2 ways of disabling Windows Update for drivers.

1- Using Group Policy - windows 10/11 Pro and above

2- Using the Registry - Windows 10/11 Home edition.

Volunteer Moderator

When you say you double clicked the feature, did you click enable and apply it?

ASRock X570 Taichi, Ryzen 7 5700X, 32GB RAM 3600Mhz, AMD Radeon RX 7900 XT, Corsair HX1000 1000 Watt Fully Modular PSU, Win11Pro
Adept I

I had this issue at least 3 times already during the past 18 months or so.

Lenovo ideapad 330s 330S-15ARR
Radeon 540 with 2 GB dedicated VRAM GDDR5 64-bit (integrated Vega 10 enabled)
Ryzen 7 1st gen 2700U 4C/8T Raven Ridge 14 nm
12 GB DDR4-2666 / PC4-21300 DDR4 SDRAM SO-DIMM
Windows 10

Here are details I captured this time:

reported driver | date | device manager | adrenalin
1 2023.03.26 31.0.14043.7000 23.4.1 driver installed by me
2 2023.03.30 31.0.12027.9001 ! driver imposed by Windows Update
3 2023.05.23 31.0.14057.5006 23.5.2 driver I updated to (via adrenalin) after rolling back to driver 1