Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD Chipset Software installation failed (Win10 2004, New issue error code 1603)

So, I updated to the new Windows 10 May 2020 Update aka version 2004, and decided to check device manager what's going on with the GPIO-driver, because the latest drivers would be blocked on version 1909 (See thread AMD GPIO Controller blocked (Code 48) )

Well, it's working now, but it's using some ancient driver from 2017.

So, I just re-downloaded the latest chipset drivers ( and tried installing them.

Everything started fine, it said installing, but then suddenly just stopped and said installation failed, no error messages. I've attached the installation log, which shows error code 1603 ("MSI (c) (60:10) [14:14:28:438]: MainEngineThread is returning 1603")

  • Motherboard make & model: ASUS Prime X570-Pro
    • BIOS version: 1405
    • Graphics card and driver version: Radeon RX 5700 XT  | Driver Radeon Software 20.5.1
    • Windows version and build number: Windows 10 Pro build 19041.264
    • Anti Virus installed: Windows Defender
  • Did you uninstall the previous Chipset driver version > restart system > before installing the new Chipset Driver version? No, tried installing after Windows 10 May 2020 Update, which based on device manager changed drivers itself.
0 Replies