Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD Chipset Drivers Installation operation failed

AMD Chipset Drivers v2.07.14.327 log:

MSI (c) (0C:04) [15:19:17:804]: Windows Installer installed the product. Product Name: AMD_Chipset_Drivers. Product Version: Product Language: 1033. Manufacturer: Advanced Micro Devices, Inc.. Installation success or error status: 1603.

Any ideas?

5 Replies
Journeyman III

Adept II

nothing helped...


Had same issue exactly as op. fixed it by reinstalling my previous chipset version (2.04...). Then uninstalled it again (after a quick restart for good measure). Then manually deleted two subfolders in my c:/AMD folder (the ones that weren't my display driver). I don't know if you even have to delete those's what I read on this forum so I did it. Finally, I installed the latest chipset driver (the 2.07...) and it was successful. Yay!!

Journeyman III

I just tried to install the last chipset drivers ( and it failed (i am on windows 10 2004)

I looked at the installed logs and found a lot of errors like this.

MSI (s) (D0:74) [10:50:21:589]: Folder is not accessible: C:\Users\[YOUR_ACCOUNT_NAME]\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2457B349-20D8-423A-B291-CD885B9108A1}\IODriver\PCI\PCI Driver\W7x64

I looked at the installed files and the directory was named WTx64 instead of the W7x64 the setup was looking for (inside, i found all the files the setup was missing).


Steps to fix :

1 - Run the installer once (let it fail)

2 - go the directory (use your user account name for [YOUR USER ACCOUNT] )

C:\Users\[YOUR USER ACCOUNT]\AppData\Roaming\AMD\Chipset_Driver_Installer\AMD_Chipset_Drivers\{2457B349-20D8-423A-B291-CD885B9108A1}\IODriver\PCI\PCI Driver\

3 - Rename WTx64 to W7x64

4 - Run the installer again, it should complete successfully.


PS: I copied the above from another place. It worked with me, without the hassle of removing nor adding drivers.

Journeyman III

None of the solutions floating around the internet worked for me. I decided to do some digging and just start clicking on things because I figured I couldn't make it any worse and was confident I could fix anything I screwed up.
I eventually stumbled upon a utility that shows up after you run the initial extraction of the driver installer. In C:\AMD\Chipset_Driver_Installer\ChipsetDriversExtract\MSIFiles\Packages is an application called "AMD_Chipset_Drivers" that will fully uninstall any currently installed chipset drivers.
After running the utility, select the remove option, click next, click remove, let it do it's thing and restart after it's done.
My install went without a hitch after this.