Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Chipset Driver not installing

Hi, I cannot install the latest chipset driver ( for some reason. Every time I try to update it, I always get the message, "This installer is intended to be deployed only on an AMD system. Exiting installation as the requirement is not satisfied." The driver in detail supports 3rd gen cpus, which I have (see spec list below). I have tried to install in safe mode/administrator but the same message still appears. I have tried to install older drivers, and the same message still shows up. I also noticed that the actual file "AMD Chipset Driver" isn't even in settings and the control panel. I have just emailed amd customer support, but any help here helps a lot.

Motherboard: Asrock B550 Taichi

CPU: Ryzen 7 3700 X

RAM: G. Skill Trident Z Neo 16GB 3600 MHz CL18

GPU: Gigabyte GTX 1660 6GB

1 Reply
Adept III

the only way to get round this crap software issue i found is to format the pc, completely, update windows again totally, install the latest AMD gpu driver, then install the chipset driver before anything else.

i have tried all the solutions, contacted support and it all fails. 


Answer format, update,  install