Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Journeyman III

AMD Adrenaline Drivers Shut Off Laptop

Hello everyone.

I upgraded my RAM from 4 to 8 GB. The problem is, when I log in into Windows it instantly shuts off. That happens every time. I tried to clear new RAM, to reset the BIOS and install different drivers with, but with no luck. Then I thought that the problem is Windows 10 itself, so I tried to clean install Windows 11. I could not install it because laptop was randomly shutting off with new RAM inside, then I successfully installed it with my old one. In the end, I entered the Safe Mode and laptop wasn't shutting off. And if I uninstall all AMD drivers laptop's work is stable. Hence, the problem is in AMD Adrenalin software.

System Specs:

Name: Asus Vivobook 15 X512DK

Windows: 11

Processor: AMD Ryzen 3 3200U with Mobile Gfx (2 GB memory reserved)

GPU: AMD Radeon 540X GPU

RAM: 8 GB - 2400mhz ddr4

I don't know what else to do, is there any way to solve this problem or even to understand the cause of it?

(I found out that if install driver version: 30.0.13023.4001, only driver no Adrenalin software, the laptop doesn't shut off immediately but it can happen unexpectedly)

2 Replies

Here is the latest AMD Driver for your Laptop APU processor Ryzen 3 3200U:

Try installing the WHQL driver by using DDU (Display Driver Uninstaller) with the internet disconnected and deleting AMD Installation folder at C:\AMD.

It is preferred if you download and use your Laptop's OEM AMD APU Driver which is 100% compatible with your laptop first to see if the problem continues or not.

First make sure your laptop has  the latest Asus BIOS version installed  from here:

Then install from the above Asus Support for your Laptop OEM AMD CHIPSET AND GRAPHIC Drivers plus the Hot Fix if you have a Kingston SSD and Asus own laptop software:

Screenshot 2022-05-26 113352.pngScreenshot 2022-05-30 110657.pngScreenshot 2022-05-30 110727.png


Thank you very much for your help, I did everything you have advised and nothing worked. I think it is incompatible with single 8GB RAM. And the problem is exactly the AMD drivers.