Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept II

AMD Adrenalin edition 2019 : fan speed issue with Power Limit from wattman

Hi everyone,

I have just updated my Asus ROG Strix AMD RX 580 8 GB in the last recommended driver : 18.12.2 but just after that, when I set to the maximum limit of power, fan speed is running and I cannot turn fan speed off, even if I go back to the initial setting of Power Limit. I have tried to reset all settings in Wattman, nothings has changed. I have also restarted/turned off/on my computer, fan speed is still running. So it's like a few minutes of silence, then a few seconds of 1815 RPM horrible vacuum cleaner sound in my case.

So I have uninstalled the driver with DDU and deleted all drivers donwloaded on the AMD folder, installed the latest driver again and when I repeat the same thing, it happened again.

I think I can't use the power limit anymore for a while. Until a new driver comes out, maybe.

So what do you think? Am I able to resolve the issue with the first driver of the 2019 adrenalin edition or not?

My PC (Desktop System) :

  • OS : Windows 10 October 2018 update (1809 - OS build 17763.194)
  • Motherboard : GIGABYTE Z370 HD3P version 1.0 - BIOS version F10
  • CPU : Intel core i5 8600K 3.60 Mghz (Coffee Lake - 8th Generation)
  • Graphic Card : Asus TOG Strix AMD RX 580 8 GB OC version
  • PSU : FSP S Raider 750W - 80+ Silver
  • Memory : DDR4 Corsair LPX vengeance 16 GB - 2100Mhz : 4 slots of 4 GB
  • Driver version installed : AMD Radeon Adrenalin software 18.12.2
  • Display : Acer KG271A "27 - connected to my PC with HDMI with a refresh mode set at 144 Mhz
  • Case : Be Quiet Base 600 - black edition
3 Replies
Adept II

Thanks for your reponse,

Unfortunaltely, I don't have Afterburner or the ASUS equivalent on my PC. So when I set to the maximum power limit, fans start spinning at high level (more than 2000 RPM) all the time, even if I reset Wattman settings, even if I reboot my PC. So the only way to resolve this issue is reinstall the latest driver (or the driver before 2019 Adrenalin edition but I don't like this).

Volunteer Moderator

Have you tried installing the latest drivers?

Radeon™ RX 580 Drivers & Support | AMD 

I am assuming you are making these Wattman changes in a game profile...and not the Global settings?

What do you have the 'Max' temperature set at?

Could you post a screenshot of your Wattman settings?

Volunteer Moderator

Never mind...I just found your other post. You seem to have a lot of problems and issues....