Showing results for 
Search instead for 
Did you mean: 

Drivers & Software


Am using the Ryzen 7 but cannot create a VM

I am trying to create a VM, but get an error suggesting that the option is turned off in BIOS, but the BIOS shows "Hyperthreading.....YES" and  "Secure Virtual Machine     YES"

How can I overcome this problem? (A snapshot of the BIOS is attached)

3 Replies

Need to post more info on your computer setup.

If you have Windows 10 Pro installed, do you have HYPER-V activated?  What VM software are you trying to use? VMware, etc.

From Microsoft Support on how to create a VM using HYPER-V in Windows 10: Create a Virtual Machine with Hyper-V | Microsoft Docs 

This website give a more detail description on creating a VM in Windows 10 including BIOS Settings: 

From MSI Support concerning your Motherboard BIOS setting for VM. Seems like you have the proper VM setting configured correctly in BIOS:

I downloaded your Motherboard Manual but couldn't find anything concerning VM settings in BIOS. But I would advice to download the latest BIOS for your motherboard: Support For B350 TOMAHAWK | Motherboard - The world leader in motherboard design | MSI Global 



Version 7A34v1L
Release Date 2019-01-03
File Size 10.82 MB
- Update AGESA Code
- Improve compatibility with Raven CPU
- Support SATA hotplug function.
See if the latest BIOS Version has more VM Settings or you are now able to create a VM.

I have Windows 10 Pro installed, but Hyper-V Hypervisor will not install

because "Virtualisation support is disabled in the firmware".

I am trying to use Oracle VM VirtualBox.

With best wishes

*Paul *

Paul Adams UK Ltd

Bracken Cottage, Castle Hill

All Stretton



01694 723506

07740 161075

Reg in England : 3586295

N.B. Internet communications are not secure; hence we neither accept legal

responsibility for the contents of this message nor for it being

misdirected from the intended recipient. We operate anti-virus programs but

reject any liability for damage caused by viruses being passed in this


*Do you really need to print this e-mail? - Save Paper - use lots of that

lovely electricity to read it instead.........*


If you can't activate HYPER-V in Windows due to BIOS not having the proper setting configured it will be impossible to create a VM.

Either your BIOS is corrupted or you have a defective Motherboard. Since you "Enabled"  SVM and still Windows is saying that BIOS isn't compatible with HYPER-V after enabling SVM in BIOS indicates a defective BIOS or motherboard.

Try flashing your BIOS again with the latest BIOS from MSI Support for your motherboard. Leave everything in "Default" after flashing EXCEPT "Enable" SVM and any other VM Settings.

Now see if HYPER-V can be activated. If it still gives the error that it needs to be configure in BIOS to be activated, I would RMA your motherboard to MSI.

Best bet is to open a MSI SUPPORT TICKET and find out if your motherboard is defective (Bad BIOS CHIP) or open an AMD SERVICE REQUEST and see if possibly it could be your CPU is defective. Since the CPU has the instructions to support SVM.  AMD SERVICE REQUEST: Online Service Request | AMD