cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

bloopi
Adept I

All drivers after WHQL 22.5.1 hard freezes my entire computer

Every driver after the WHQL drivers 22.5.1 hard freezes my entire computer randomly while playing and doing something else on the other screen at the same time. No matter what I do, i can't seem to re-create the issue at will, it just happens randomly. However, it only seems to affect the more power hungry games, like BF2042, Cyberpunk, The Divsion 2, etc. What happens is that the games slowly begins to stutter och lag a bit, then it just freezes completely efter a min or two. Heck, it even happened on the startup screen for The Divsion 2 one time. Usually 1-2 freezes per day when running any driver above the WHQL ones.

My specs:
5800x3D Processor
6800xt Graphic Card (reference card)
Corsair Vengeance RGB Pro 32gb 3200mhz cl16 Ram
Aorus Elite x570 Motherboard
Corsair RM750x V2 750W Gold Power Supply
Running latest Windows 11 build

My bios is up to date on the motherboard. Nothing is or has been overclocked. Not having any heat issues whatsoever. Latest chipset drivers is installed. I've tried disabling background programs like ICUE, Steel Series GG, Discord, Wallpaper engine, etc, but no luck there. Reinstalled windows 11 and even tried using different builds, nothing and i mean nothing has worked. I've heard something about turning off different overlays and stuff, but that didn't work for me.

I'm at my wits end here and I'm strongly thinking of going back to team green again... This honestly reminds of the time when I first purchased the 5700xt... Oh boy, what a complete fustercluck that was. Oh, did I mention before that I recently slapped in a 3070 a week ago in my computer, and it worked absolutely flawlessly after having testing it for a couple of days?

It seems that they've added something new to the recent drivers that my computer doesn't seem to like. The WHQL drivers is stable so far for me, and I guess I have to stick with them a couple of more months. Kind of sucks having to run drivers that are quite old and outdated.

1 Solution
bloopi
Adept I

Ok, so I removed my Elgato Game Capture HD60 Pro card, uninstalled the driver, ddud my current installed graphic driver and installed the most current one (22.11.2) and... it seems to be working perfectly fine now. This is my 4th day, using the current driver, without any crashes whatsoever.

Well, this is a surprise. Never expected it to be the capture card that might've been the issue here. I know for a fact that my old capture card is not broken, since it's working just fine with my other Nvidia card, 3070. I hope that I don't encounter the same issue when I install my new capture card, AverMedia Live Gamer 4K.

View solution in original post

0 Likes
4 Replies

Probably was the MPO bug which is now fixed in current driver.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..
0 Likes

I still have issues. Keeping MPO disabled.

[ 5800X | 5700XT | MSI B550 | H115i Pro | G.SKILL 32GB 3600Mhz | 850W Gold ]
0 Likes
bloopi
Adept I

I've tried the latest drivers as well, and the issue persists, sadly.

0 Likes
bloopi
Adept I

Ok, so I removed my Elgato Game Capture HD60 Pro card, uninstalled the driver, ddud my current installed graphic driver and installed the most current one (22.11.2) and... it seems to be working perfectly fine now. This is my 4th day, using the current driver, without any crashes whatsoever.

Well, this is a surprise. Never expected it to be the capture card that might've been the issue here. I know for a fact that my old capture card is not broken, since it's working just fine with my other Nvidia card, 3070. I hope that I don't encounter the same issue when I install my new capture card, AverMedia Live Gamer 4K.

0 Likes