cancel
Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Derzaum
Adept I

Age of Empires 2 Definitive Edition Poor performance, Massive Stuttering and Occasional Freezing

Hello. Im having the problems described in the tittle with the following specs:

Windows 10 v22h2
Ryzen 5 2400g
ASRock Challenger RX 6600
16gb DDR4 RAM
B450m Gigabyte Gaming
600W PSU 80plus bronze

After some extensive research on the internet, i've found that the Radeon RX 6000 series have been suffering from this problem for a LONG TIME, like one and a half year or more, there are reports all over different forums complaining about low performance and stuttering specially during mid/late game matches.

The problem is easly replicable by  playing 3x3 or 4x4 versus de CPU and reaching mid/late game, or even just selecting only CPUs playing each other, but poor performance can be noticed even before that. If you turn on MSI Afterburner, you can see spikes on the frametime graph EVERYTIME you click/select a unit and give any commands to it, it just gets worse as the game goes on. It starts around 70/80 fps on my machine, and goes down as low as 20, 10 fps endgame, meanwhile, the GPU performance is nearly at 0%. There are reports of people making the game playable by running a freaking benchmark or heavy applications on background so the GPU wont enter what appears to be an "ECO MODE". I've tried that, stutter gets a little better but the FPS is still trash. Same problem happens in Single Player Campaign Mode on big maps with lots of buildings and units. I aslo had the computer completely freezing while playing campaign mode two times by now.

I managed to play the game just fine when i was using my integrated graphics , it also ran nice on my old Radeon GPU, a Sapphire Radeon HD 7970, but it  went downhill after buying the RX 6600 ON THIS GAME ONLY. Other games are running just fine so far. People also saying they havent had issues with RX 500/600 series or older gpus, something along this line.

Considering this is a know issue for a long time, AT LEAST by the community,  AMD is probably aware of the problem by now, right? Cuz if it hasn't been solved TO THIS DAY, i can't help to think of negligence and disrespect with their costumers. 

Funny thing is that  a friend of mine bought a rtx 3060 ti instead of a RX 6750 that i recommended to him due its clear superiority in performance, bigger VRAM and better price, he claimed that he was afraid of the "bad driver" reputation AMD has had for a while and i told him those times were behind and he made a really poor decision. Guess who is feeling like a regretful clown right now? 

EDIT: removed a link to AOE2 Forums because post was marked as spam


0 Likes
1 Reply
lupu
Journeyman III

I have the same issues on an RX 6600M. I was able to fix it by forcing the game to use Vulkan instead of DirectX.

You can download the DLLs from the link below. Or search the internet for dxvk, if the link is removed by the forum.

https://github.com/doitsujin/dxvk

0 Likes