Showing results for 
Search instead for 
Did you mean: 

Drivers & Software

Adept I

Age of Empires 2 and RX 6600, Massive Stutter, Poor Performance and Occasional Freezing PC

Hello. Im having the problems described in the tittle with the following specs playing Age of Empires 2 Definitive Edition:

Windows 10 v22h2
Ryzen 5 2400g
ASRock Challenger RX 6600
16gb DDR4 RAM
B450m Gigabyte Gaming
600W PSU 80plus bronze

After some extensive research on the internet, i've found out that the Radeon RX 6000 series have been suffering from this problem for a LONG TIME, like one and a half year or more, there are reports all over different forums complaining about low performance and stuttering specially during mid/late game matches.

The problem is easly replicable by playing 3x3 or 4x4 versus de CPU and reaching mid/late game, or even just selecting only CPUs playing each other, but poor performance can be noticed even before that. If you turn on MSI Afterburner, you can see spikes on the frametime graph EVERYTIME you click/select a unit and give any commands to it, it just gets worse as the game goes on. It starts around 70/80 fps on my machine, and goes down as low as 20, 10 fps endgame, meanwhile, the GPU performance is nearly at 0%. There are reports of people making the game playable by running a benchmark or heavy applications on background so the GPU wont enter what appears to be an "ECO MODE". I've tried that, stutter gets a little better but the FPS is still trash. Same problem happens in Single Player Campaign Mode on big maps with lots of buildings and units. I aslo had the computer completely freezing while playing campaign mode two times by now.

I managed to play the game just fine when i was using my integrated graphics , it also ran nice on my old Radeon GPU, a Sapphire Radeon HD 7970, but it went downhill after buying the RX 6600 ON THIS GAME ONLY. Other games are running just fine so far. People also saying they havent had issues with RX 500/600 series or older gpus, something along this line.

Considering this is a know issue for a long time, AT LEAST by the community, AMD is probably aware of the problem by now, right? Cuz if it hasn't been solved TO THIS DAY, i can't help to think of negligence and disrespect with their costumers.

Funny thing is that a friend of mine bought a rtx 3060 ti instead of a RX 6750 that i recommended to him due its clear superiority in performance, bigger VRAM and better price, he claimed that he was afraid of the "bad driver" reputation AMD has had for a while and i told him those times were behind us and that he made a really poor decision. Guess who is feeling like a regretful clown right now?

Edit: I have the latest driver installed after DDUing the old ones.

7 Replies
Adept I

Please, let this reach some AMD representative. The problem has been around for 2+ years, Age of Empires 2 Definitive Edition is CONSTANTLY on Steam's top 50 played games daily. You can't let every RDNA2 card user keep experiencing this problem. Help, AMD, please.

Journeyman III

bottleneck!!! upgrade your cpu rx 6600 is too high for r5 2400g


Yes, the CPU will bottleneck the GPU on high demand applications/games but, no, it's not the case with a game launched in 1998 with enhanced hd textures that have these recommended requirements:


    • OS: Windows 10 64bit
    • Processor: 2.4 Ghz i5 or greater or AMD equivalent
    • Memory: 8 GB RAM
    • Graphics: Nvidia® GTX 650 or AMD HD 5850 or better
    • DirectX: Version 11
    • Network: Broadband Internet connection
    • Storage: 15 GB available space

Have you tried if the game runs well on DXVK? It might fix some issues.

I didn't know such thing existed. Researched about it and it's for linux but apparently could work on Windows as well, despite not being supported. Since i'm desperate here, tried to give it a shot and... Well, was the best solution to the problem i have tried so far! And i tried every generic stuff you could imagine. The stutter is GONE while utilizing this vulkan workaround, its much smoother. I limited the FPS via the AMD software to 70 and the early game frametime graph is perfect flat lined! But mid game comes and the performance still drops a lot, to the 40/30 fps, but still, the stutter is no more and i thank you for your big help! It's not a fix but at least the game is playable now. 

But i've read somewhere that people said it's like "modding" the game, thus might be dangerous to get banned during online gameplay. I'm just trying to finish all campaigns and occasionally play 3x3 or 4x4 against the cpu with a friend, so, its fine for me. 

Still hoping that AMD works on a fix for this. PLEASE


I dont play Age of Empire 2, but if that game can use VULKAN and have better performance with neweset driver version, then try use older like 22.11.2. I play dota on DX11 and it freeze at randomly and need to do hard reset. Dota can use VULKAN, i try and never freeze again. AMD like breaking DX11 on newer driver.


For mid games getting low FPS, i only can assume the longer you play, your CPU (maybe GPU) getting hotter and fail to cool it down or at least maintain the temp in ideal temp. Just a guess, you can try monitor it.


I play games like 4-5 hours no pause and the temp for GPU always around 70 celcius and CPU always around 60 celcius. It should like that even you play 24 hours. If yours getting higher and higher then you need to fix that.

MSI B550 Pro-VDH - MSI 6600XT - Ryzen 5600G
Adept III

I would say bottleneck too. game runs great on my system. 5900x with 6900xt

EK watercooled 6900xt - 5900x - Lian Li XL - Samsung neo G8 - Logitech G910 - Hero G502